Add telak.
Telak is a small tool to draw local or remote pictures on your root window. This is very useful if you want to have RRD graphs drawn above your wallpaper. WWW: http://julien.danjou.info/telak.html PR: ports/86069 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
This commit is contained in:
parent
b5bf2fbd48
commit
108960574a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=142656
@ -541,6 +541,7 @@
|
||||
SUBDIR += synaesthesia
|
||||
SUBDIR += tcm
|
||||
SUBDIR += teddy
|
||||
SUBDIR += telak
|
||||
SUBDIR += tgif
|
||||
SUBDIR += tgif-nls
|
||||
SUBDIR += threeDS
|
||||
|
40
graphics/telak/Makefile
Normal file
40
graphics/telak/Makefile
Normal file
@ -0,0 +1,40 @@
|
||||
# New ports collection makefile for: telak
|
||||
# Date created: 13 Sep 2005
|
||||
# Whom: Emanuel Haupt <ehaupt@critical.ch>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= telak
|
||||
PORTVERSION= 0.4
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= http://critical.ch/distfiles/
|
||||
|
||||
MAINTAINER= ehaupt@critical.ch
|
||||
COMMENT= A tool to draw pictures on your root window
|
||||
|
||||
LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl \
|
||||
gcrypt.13:${PORTSDIR}/security/libgcrypt \
|
||||
Imlib2.3:${PORTSDIR}/graphics/imlib2
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_GETOPT_LONG=yes
|
||||
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
MAKE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
|
||||
PLIST_FILES= bin/telak
|
||||
MAN1= telak.1
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||
${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
install-user:
|
||||
@${SH} ${FILESDIR}/install-user
|
||||
|
||||
.include <bsd.port.mk>
|
2
graphics/telak/distinfo
Normal file
2
graphics/telak/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
MD5 (telak-0.4.tar.gz) = ab8d56f191d3c5215a04af846c32c575
|
||||
SIZE (telak-0.4.tar.gz) = 13975
|
30
graphics/telak/files/install-user
Normal file
30
graphics/telak/files/install-user
Normal file
@ -0,0 +1,30 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
# Emanuel Haupt <ehaupt@critical.ch>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
writeconf()
|
||||
{
|
||||
cat << "EOF" > $HOME/.telak/telakrc
|
||||
# telakrc - see telak(1) for more config options
|
||||
|
||||
[example]
|
||||
url = http://www.critical.ch/telak/d-mon.gif
|
||||
x = 15
|
||||
y = 15
|
||||
|
||||
EOF
|
||||
}
|
||||
|
||||
if [ ! -d $HOME/.telak/cache ]; then
|
||||
mkdir -p $HOME/.telak/cache
|
||||
if [ ! -f $HOME/.telak/telakrc ]; then
|
||||
writeconf
|
||||
echo "Example config successfully installed under $HOME/.telak/"
|
||||
else
|
||||
echo "$HOME/.telak/telakrc does already exist."
|
||||
fi
|
||||
else
|
||||
echo "$HOME/.telak does already exist."
|
||||
fi
|
13
graphics/telak/files/patch-Makefile
Normal file
13
graphics/telak/files/patch-Makefile
Normal file
@ -0,0 +1,13 @@
|
||||
--- Makefile.orig Thu Apr 28 22:15:06 2005
|
||||
+++ Makefile Wed Sep 14 01:04:46 2005
|
||||
@@ -1,8 +1,8 @@
|
||||
VERSION = $(shell grep '^Version' ChangeLog | head -n 1 | cut -d' ' -f2 | tr -d ' ')
|
||||
BIN = telak
|
||||
O = telak.o fetch.o image.o parse.o
|
||||
-LDFLAGS = $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt
|
||||
-CFLAGS = -W -Wall $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\"" -g
|
||||
+LDFLAGS += -L$(LOCALBASE)/lib $(shell imlib2-config --libs) $(shell curl-config --libs) -lgcrypt
|
||||
+CFLAGS += -I$(LOCALBASE)/include $(shell curl-config --cflags) $(shell imlib2-config --cflags) -DTELAK_USER_AGENT="\"$(BIN) $(VERSION)\"" -DTELAK_VERSION="\"$(VERSION)\""
|
||||
|
||||
BINDIR=$(DESTDIR)/usr/bin
|
||||
MANDIR=$(DESTDIR)/usr/share/man/man1
|
10
graphics/telak/files/patch-parse.c
Normal file
10
graphics/telak/files/patch-parse.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- parse.c.orig Tue Sep 13 22:05:22 2005
|
||||
+++ parse.c Tue Sep 13 22:05:39 2005
|
||||
@@ -17,6 +17,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <pwd.h>
|
||||
#include <time.h>
|
||||
+#include <sys/time.h>
|
||||
|
||||
#include "telak.h"
|
||||
#include "image.h"
|
18
graphics/telak/files/patch-telak.c
Normal file
18
graphics/telak/files/patch-telak.c
Normal file
@ -0,0 +1,18 @@
|
||||
--- telak.c.orig Wed Sep 14 01:08:51 2005
|
||||
+++ telak.c Wed Sep 14 01:08:52 2005
|
||||
@@ -91,7 +91,6 @@
|
||||
Atom SWM_VROOT = XInternAtom(display, "__SWM_VROOT", False);
|
||||
Atom NAUTILUS_DESKTOP_WINDOW_ID =
|
||||
XInternAtom(display, "NAUTILUS_DESKTOP_WINDOW_ID", False);
|
||||
- win = DefaultRootWindow(display);
|
||||
|
||||
Window unused, *windows = 0;
|
||||
unsigned int count;
|
||||
@@ -101,6 +100,7 @@
|
||||
unsigned long nitems, bytes_after_return;
|
||||
unsigned char *virtual_root_window;
|
||||
|
||||
+ win = DefaultRootWindow(display);
|
||||
if(XGetWindowProperty(display, win, NAUTILUS_DESKTOP_WINDOW_ID,
|
||||
0, 1, False, XA_WINDOW, &type, &format,
|
||||
&nitems, &bytes_after_return,
|
7
graphics/telak/pkg-descr
Normal file
7
graphics/telak/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
Telak is a small tool to draw local or remote pictures on your root window.
|
||||
This is very useful if you want to have RRD graphs drawn above your wallpaper.
|
||||
|
||||
WWW: http://julien.danjou.info/telak.html
|
||||
|
||||
- ehaupt
|
||||
ehaupt@critical.ch
|
4
graphics/telak/pkg-message
Normal file
4
graphics/telak/pkg-message
Normal file
@ -0,0 +1,4 @@
|
||||
===============================================================================
|
||||
To install an example config file, log into your user account and type
|
||||
'make install-user'.
|
||||
===============================================================================
|
Loading…
Reference in New Issue
Block a user