MFH: r518295

security/theonionbox: Unbreak at runtime and prepare for urllib3 1.25.6

PR:		241827
Submitted by:	kai

Approved by:	ports-secteam@FreeBSD.org
This commit is contained in:
Yuri Victorovich 2019-11-26 02:00:18 +00:00
parent 044d76fd9f
commit 1013e5cda1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2019Q4/; revision=518441
3 changed files with 35 additions and 2 deletions

View File

@ -2,7 +2,7 @@
PORTNAME= theonionbox
DISTVERSION= 4.3.1
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= security net python
MASTER_SITES= CHEESESHOP

View File

@ -1,4 +1,4 @@
--- setup.py.orig 2019-05-11 04:02:35 UTC
--- setup.py.orig 2019-05-10 21:59:01 UTC
+++ setup.py
@@ -295,19 +295,9 @@ package_data_exclude = {
}
@ -23,3 +23,16 @@
]
# print(generate_data_files(data_files))
@@ -381,10 +371,10 @@ setup(
'requests>=2.21',
'PySocks>=1.6.7',
'bottle>=0.12.13',
- 'stem>=1.5.4, <=1.6',
+ 'stem>=1.5.4',
'tzlocal>=1.5',
'futures>=3.2; python_version<"3.0"',
- 'urllib3>=1.24.2, <1.25' # '<1.25' due to requests 2.21 requirement
+ 'urllib3>=1.21.1,<1.26' # copied (except the exclusions) from requests 2.22
],
long_description_content_type='text/x-rst; charset=UTF-8',
classifiers=[

View File

@ -0,0 +1,20 @@
--- theonionbox/theonionbox.py.orig 2019-11-09 13:37:29 UTC
+++ theonionbox/theonionbox.py
@@ -513,7 +513,7 @@ required_modules = {
'info': "Check 'https://pypi.python.org/pypi/psutil' for installation instructions."
},
'stem': {
- 'version': '>=1.5.4, <=1.6'
+ 'version': '>=1.5.4'
},
'bottle': {
'version': '>=0.12.13'
@@ -539,7 +539,7 @@ required_modules = {
'version': '>=3.2; python_version<"3.0"'
},
'urllib3': {
- 'version': '>=1.24.2, <1.25'
+ 'version': '>=1.21.1,<1.26' #copied (except the exclusions) from requests 2.22
}
}