- Update from 1.1 to 1.2
This commit is contained in:
parent
b5f5dde7fd
commit
10093156ba
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=345639
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= zutils
|
||||
PORTVERSION= 1.1
|
||||
PORTVERSION= 1.2
|
||||
CATEGORIES= archivers
|
||||
MASTER_SITES= SAVANNAH/zutils
|
||||
EXTRACT_SUFX= .tar.lz
|
||||
@ -25,6 +25,9 @@ do-extract:
|
||||
|
||||
post-patch:
|
||||
# Remove compiler hardcoded flags and use environment
|
||||
${REINPLACE_CMD} '24,27d' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} '24,27d' ${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
@${RM} ${STAGEDIR}${PREFIX}/info/dir
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (zutils-1.1.tar.lz) = c431cff331ce20a5405125a5be163de4980f06ecdca3b4e4fbe1ed1f68724e3f
|
||||
SIZE (zutils-1.1.tar.lz) = 43985
|
||||
SHA256 (zutils-1.2.tar.lz) = 987fc1971493cde29b046f9d1392a74c81df201bf9d416e350e073273c4b358e
|
||||
SIZE (zutils-1.2.tar.lz) = 46544
|
||||
|
10
archivers/zutils/files/patch-zupdate.cc
Normal file
10
archivers/zutils/files/patch-zupdate.cc
Normal file
@ -0,0 +1,10 @@
|
||||
--- ./zupdate.cc.orig 2014-02-22 09:12:36.000000000 -0300
|
||||
+++ ./zupdate.cc 2014-02-22 09:12:57.000000000 -0300
|
||||
@@ -32,6 +32,7 @@
|
||||
#include <unistd.h>
|
||||
#include <utime.h>
|
||||
#include <sys/stat.h>
|
||||
+#include <sys/wait.h>
|
||||
#if defined(__MSVCRT__) || defined(__OS2__)
|
||||
#include <io.h>
|
||||
#endif
|
@ -1,5 +1,5 @@
|
||||
--- ./zutils.h.orig 2013-07-07 14:15:39.000000000 -0300
|
||||
+++ ./zutils.h 2013-09-25 17:32:23.000000000 -0300
|
||||
--- ./zutils.h.orig 2014-01-30 14:46:32.000000000 -0200
|
||||
+++ ./zutils.h 2014-02-22 09:12:24.000000000 -0300
|
||||
@@ -15,6 +15,9 @@
|
||||
along with this program. If not, see <http://www.gnu.org/licenses/>.
|
||||
*/
|
||||
@ -7,6 +7,6 @@
|
||||
+#include <sys/types.h>
|
||||
+#include <signal.h>
|
||||
+
|
||||
const char * const Program_name = "Zutils";
|
||||
const char * const program_name = "zutils";
|
||||
const char * const config_file_name = "zutilsrc";
|
||||
int parse_format_type( const std::string & arg );
|
||||
|
||||
int readblock( const int fd, uint8_t * const buf, const int size );
|
||||
|
@ -4,11 +4,12 @@ bin/zdiff
|
||||
bin/zegrep
|
||||
bin/zfgrep
|
||||
bin/zgrep
|
||||
bin/zupdate
|
||||
bin/ztest
|
||||
bin/zutils
|
||||
etc/zutilsrc
|
||||
man/man1/zcat.1.gz
|
||||
man/man1/zcmp.1.gz
|
||||
man/man1/zdiff.1.gz
|
||||
man/man1/zgrep.1.gz
|
||||
man/man1/zupdate.1.gz
|
||||
man/man1/ztest.1.gz
|
||||
|
Loading…
Reference in New Issue
Block a user