- Update to 0.2.5

PR:		ports/98754
Submitted by:	maintainer (chinsan)
This commit is contained in:
Cheng-Lung Sung 2006-06-09 17:13:28 +00:00
parent 090b4ad000
commit 0fe5563013
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164917
10 changed files with 15 additions and 101 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= zhcon
PORTVERSION= 0.2.3
PORTREVISION= 7
PORTVERSION= 0.2.5
CATEGORIES= chinese
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -16,21 +15,25 @@ MAINTAINER= chinsan.tw@gmail.com
COMMENT= A fast Console Chinese System which supports framebuffer device
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
ONLY_FOR_ARCHS= i386
# Don't bother to add ".if !defined(WITHOUT_NLS)", zhcon requires libintl
USE_GETTEXT= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
MAN1= zhcon.1
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/doc/zhcon.1.in
@${REINPLACE_CMD} -e 's,/etc,${PREFIX}/etc,' ${WRKSRC}/doc/zhcon.1.in
@${REINPLACE_CMD} -Ee 's,/dev/vga,/dev/ttyv0,g' ${WRKSRC}/src/display/fbdev.cpp
@${REINPLACE_CMD} -e '5 s|#||;' ${WRKSRC}/src/zhcon.conf
@${REINPLACE_CMD} -Ee 's,endian,sys/endian,g' ${WRKSRC}/src/display/fblinear4.cpp \
${WRKSRC}/src/display/fblinear8.cpp ${WRKSRC}/src/display/fblinear16.cpp \
${WRKSRC}/src/display/fblinear24.cpp
@${REINPLACE_CMD} -e '5 s,#,,; s,/usr/lib,${PREFIX}/lib,' ${WRKSRC}/src/zhcon.conf
@${REINPLACE_CMD} -e 's,"/etc,PREFIX"/etc,' ${WRKSRC}/src/zhcon.cpp
@${REINPLACE_CMD} -Ee 's,(\s*=\s*)("?)/usr/local([^"]*)("?),\1\2${PREFIX}\3\4,g' \
-e '/_nl_expand_alias/s,\(0\),\(\),g' ${WRKSRC}/${CONFIGURE_SCRIPT}
.if defined(WITH_BIG5)
@${REINPLACE_CMD} -e '11 s,gb2312,big5,' ${WRKSRC}/src/zhcon.conf
.endif
post-install:
@${CAT} ${PKGMESSAGE}

View File

@ -1,3 +1,3 @@
MD5 (zhcon-0.2.3.tar.gz) = 64b5d6c2d7055b4e45f4eadfd1303e8f
SHA256 (zhcon-0.2.3.tar.gz) = 60e2f7a3b2a548e043838794b7ab3cb0e84f13508d48b384e9b6598698baacbb
SIZE (zhcon-0.2.3.tar.gz) = 5030677
MD5 (zhcon-0.2.5.tar.gz) = 79e1c68aab8341e32129f61c1670baeb
SHA256 (zhcon-0.2.5.tar.gz) = 4ce4dc1395b6f6a920d44aac069a284bff76df4019ac4164850d263538465d59
SIZE (zhcon-0.2.5.tar.gz) = 5011644

View File

@ -1,11 +0,0 @@
--- src/Makefile.in.orig Thu Apr 17 19:29:48 2003
+++ src/Makefile.in Wed Apr 30 21:10:39 2003
@@ -478,7 +478,7 @@
install-data-local:
$(mkinstalldirs) $(DESTDIR)/etc
- $(INSTALL_DATA) $(srcdir)/zhcon.conf $(DESTDIR)/etc/zhcon.conf
+ $(INSTALL_DATA) $(srcdir)/zhcon.conf $(PREFIX)/etc/zhcon.conf
uninstall-local:
-rm -f $(DESTDIR)/etc/zhcon.conf

View File

@ -1,21 +0,0 @@
--- src/configfile.cpp.orig Tue Jan 25 07:38:59 2005
+++ src/configfile.cpp Tue Jan 25 07:41:19 2005
@@ -19,13 +19,18 @@
#include <stdexcept>
#include <fstream>
#include <cstdlib>
+#include <sys/types.h>
+#include <unistd.h>
#include "configfile.h"
ConfigFile::ConfigFile(const char *fn) {
+ uid_t euid = geteuid();
+ seteuid(getuid());
ifstream in(fn);
if (!in)
throw runtime_error("Could not open config file!");
ParseFile(in);
+ seteuid(euid);
}
ConfigFile::~ConfigFile() {}

View File

@ -1,16 +0,0 @@
--- src/display/fblinear24.cpp~ Sun Aug 1 17:22:19 2004
+++ src/display/fblinear24.cpp Sun Aug 1 17:27:33 2004
@@ -203,11 +203,11 @@
d1 = (-(*cdat >> 3 & 1) & eorx) ^ bgx;
d2 = (-(*cdat >> 2 & 1) & eorx) ^ bgx;
fb_writel(d1 | (d2<<24), dest32++);
- fb_writew(d2>>8, ((__u16*)dest32)++);
+ fb_writew(d2>>8, ((__u16*)dest32) + 1);
}
if (pFont->w & 1) {
d3 = (-(*cdat >> 1 & 1) & eorx) ^ bgx;
- fb_writew(d3, ((__u16*)dest32)++);
+ fb_writew(d3, ((__u16*)dest32) + 1);
fb_writeb(d3>>16, (__u8*)dest32);
}
cdat++;

View File

@ -1,11 +0,0 @@
--- src/display/fblinear8.cpp~ Sun Aug 1 17:29:43 2004
+++ src/display/fblinear8.cpp Sun Aug 1 17:39:12 2004
@@ -102,7 +102,7 @@
fb_writel((nibbletab_cfb8[*cdat >> 4] & eorx) ^ bgx, dest32++);
}
if (pFont->w & 2) {
- fb_writew((nibbletab_cfb8[*cdat & 0xc] & eorx) ^ bgx, ((__u16*)dest32)++);
+ fb_writew((nibbletab_cfb8[*cdat & 0xc] & eorx) ^ bgx, ((__u16*)dest32) + 1);
}
if (pFont->w & 1) {
fb_writeb((*cdat & 2) ? fg : bg, (__u8*)dest32);

View File

@ -1,10 +0,0 @@
--- src/inputclient.h.orig Sat Aug 16 16:34:06 2003
+++ src/inputclient.h Sat Aug 16 16:34:15 2003
@@ -19,6 +19,7 @@
#ifndef INPUTCLIENT_H
#define INPUTCLIENT_H
+#include <cassert>
#include <string>
#include "console.h"

View File

@ -1,11 +0,0 @@
--- src/zhcon.cpp.orig Tue Nov 26 01:35:04 2002
+++ src/zhcon.cpp Tue Nov 26 01:35:25 2002
@@ -131,7 +131,7 @@
string cfgfile = getenv("HOME");
cfgfile += "/.zhconrc";
if (access(cfgfile.c_str(), R_OK) != 0)
- cfgfile = "/etc/zhcon.conf";
+ cfgfile = PREFIX"/etc/zhcon.conf";
//for debug,a pause enable us to attach zhcon's pid in gdb
//char c;cin>>c;

View File

@ -1,7 +1,8 @@
Zhcon is a fast Linux Console Chinese System which supports
framebuffer device.It can display Chinese,Japanese or Korean
double byte characters.Supported language encodings include:
GB2312,GBK,BIG5,JIS and KSCM.
GB2312,GBK,BIG5,JIS and KSC. UTF-8 is also supported.
It can also use input methods(table based) from M$pwin98 and
UCDOS for M$-DOG.

View File

@ -34,16 +34,6 @@ lib/zhcon/input/wbh.mb
lib/zhcon/input/winpy.mb
lib/zhcon/input/winsp.mb
lib/zhcon/input/winzm.mb
share/locale/ja/LC_MESSAGES/zhcon.mo
share/locale/ko/LC_MESSAGES/zhcon.mo
share/locale/zh_CN.EUC/LC_MESSAGES/zhcon.mo
share/locale/zh_CN.GB2312/LC_MESSAGES/zhcon.mo
share/locale/zh_CN.GBK/LC_MESSAGES/zhcon.mo
share/locale/zh_TW.Big5/LC_MESSAGES/zhcon.mo
@dirrmtry share/locale/zh_CN.GBK/LC_MESSAGES
@dirrmtry share/locale/zh_CN.GBK
@dirrmtry share/locale/zh_CN.EUC/LC_MESSAGES
@dirrmtry share/locale/zh_CN.EUC
@dirrm lib/zhcon/input
@dirrm lib/zhcon/font
@dirrm lib/zhcon