- Update to 2.4.4

Submitted by:	Ports fury
PR:		ports/92609
This commit is contained in:
Simon Barner 2006-01-31 16:11:45 +00:00
parent 97f3ddb8dd
commit 0fb6df4d57
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=154906
3 changed files with 22 additions and 6 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= ecasound
PORTVERSION= 2.4.3
PORTVERSION= 2.4.4
CATEGORIES= audio
MASTER_SITES= http://ecasound.seul.org/download/
@ -18,7 +18,8 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-pyecasound --disable-rubyecasound --with-largefile
CONFIGURE_ARGS= --disable-pyecasound --disable-rubyecasound --with-largefile \
--enable-sys-readline
INSTALLS_SHLIB= yes
MAN1= ecasound-iam.1 ecasound.1 ecatools.1 ecaconvert.1 \
@ -32,6 +33,7 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
CFLAGS+= -fpermissive
.endif
@ -54,7 +56,7 @@ CONFIGURE_ARGS+= --disable-jack
.endif
.if defined(WITH_SAMPLERATE)
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsndfile
LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+= --disable-libsamplerate --disable-sndfile
.endif

View File

@ -1,3 +1,3 @@
MD5 (ecasound-2.4.3.tar.gz) = ea4af6ffa9f00743270151927f7b4584
SHA256 (ecasound-2.4.3.tar.gz) = 18e198993d4fe696ffc495b2229d99c75583015b4b2429349fab2d5219057945
SIZE (ecasound-2.4.3.tar.gz) = 1112995
MD5 (ecasound-2.4.4.tar.gz) = 3032a157f736bb38426b2ebcc92c6513
SHA256 (ecasound-2.4.4.tar.gz) = dd6afb770f97894763310d4435c1ab4ceb6529f0c0c9c790d126f22ea6f8bf77
SIZE (ecasound-2.4.4.tar.gz) = 1128867

View File

@ -0,0 +1,14 @@
--- ecatools/ecaplay.c.orig Mon Oct 3 06:44:57 2005
+++ ecatools/ecaplay.c Sun Jan 29 21:54:01 2006
@@ -211,9 +211,10 @@
else {
static int once = 1;
if (once) {
+ char *tmpstr;
eci_command_r(eci, "ao-iselect 1");
eci_command_r(eci, "ao-describe");
- char *tmpstr = (char*)eci_last_string_r(eci);
+ tmpstr = (char*)eci_last_string_r(eci);
/* skip the "-x:" prefix where x is one of [io] */
while(*tmpstr && *tmpstr++ != ':')
;