MFH: r476485

Fix build with Perl >= 5.26 - regular expression match was failing with
newer MakeMaker which caused the objects to be written to the wrong location

Add LICENSE - the README says it is licensed the same as Perl

Approved by:	ports-secteam (blanket)
This commit is contained in:
Jason E. Hale 2018-08-06 03:06:12 +00:00
parent 93d78fcb80
commit 0faf4e13e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q3/; revision=476486
2 changed files with 20 additions and 7 deletions

View File

@ -10,6 +10,9 @@ MASTER_SITES= http://www.prima.eu.org/IPA/ CPAN/Prima/KARASIK
MAINTAINER= ports@FreeBSD.org
COMMENT= Image Processing Algorithms
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
RUN_DEPENDS= p5-Prima>1.24:x11-toolkits/p5-Prima
BUILD_DEPENDS:= ${RUN_DEPENDS}
@ -21,10 +24,4 @@ MAKE_JOBS_UNSAFE= yes
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/IPA/IPA.so
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} >= 502600
BROKEN= Does not build
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,16 @@
Fix regular expression match and build with MakeMaker >= 7.05_05 which adds a
space between the target name and the operator.
--- Makefile.PL.orig 2011-05-14 06:27:26 UTC
+++ Makefile.PL
@@ -79,8 +79,8 @@ H
sub c_o
{
my $t = shift-> SUPER::c_o(@_);
- unless ( $t =~ /.c\$\(OBJ_EXT\):\n\t.*\$\*\$\(OBJ_EXT\)/ ) {
- $t =~ s/(\.c\$\(OBJ_EXT\):\n\t.*)/$1 $co\$*\$(OBJ_EXT)/;
+ unless ( $t =~ /\.c\$\(OBJ_EXT\)\s*:\n\t.*\Q\$\*\$\(OBJ_EXT\)\E/ ) {
+ $t =~ s/(\.c\$\(OBJ_EXT\)\s*:\n\t.*)/$1 $co\$*\$(OBJ_EXT)/;
}
return $t;
}