- Upgraded to 1.1.14.
- Made various stylistic fixes to Makefile. - Broke files/patch-* files into individiual patch files and used "make makepatch" to name them all correctly. - Removed NOPORTDOCS support, pending support in upstream package installation process. Reviewed by: beech, itetcu Approved by: beech (mentor, implicit)
This commit is contained in:
parent
25280107c0
commit
0f9d4fa801
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=219678
@ -6,16 +6,18 @@
|
||||
#
|
||||
|
||||
PORTNAME= GraphicsMagick
|
||||
PORTVERSION= 1.1.12
|
||||
PORTVERSION= 1.1.14
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
|
||||
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/
|
||||
MASTER_SITES= SF \
|
||||
ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.1/
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME:L}
|
||||
|
||||
MAINTAINER= glarkin@FreeBSD.org
|
||||
COMMENT= Fast image processing tools based on ImageMagick
|
||||
|
||||
CONFLICTS= GraphicsMagick-1.2.*
|
||||
|
||||
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
|
||||
fpx.[2-9]:${PORTSDIR}/graphics/libfpx \
|
||||
jbig:${PORTSDIR}/graphics/jbigkit \
|
||||
@ -23,9 +25,9 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
|
||||
xml2:${PORTSDIR}/textproc/libxml2
|
||||
OTHERGRAPHICS= jasper jpeg lcms png tiff
|
||||
LIB_DEPENDS+= ${OTHERGRAPHICS:C|(.+)|\1:${PORTSDIR}/graphics/\1|}
|
||||
OPTIONS= Q8BIT "Use 8-bit pixels (speed) instead of 16 (quality)" off
|
||||
|
||||
OPTIONS+= TESTS "Run bundled self-tests after build" on
|
||||
OPTIONS= Q8BIT "Use 8-bit pixels (speed) instead of 16 (quality)" off \
|
||||
TESTS "Run bundled self-tests after build" on
|
||||
|
||||
USE_ICONV= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
@ -49,15 +51,8 @@ CONFIGURE_ARGS= --without-perl --enable-shared --enable-static \
|
||||
--without-threads
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
.if defined(WITH_WINDOWS_FONT_DIR)
|
||||
CONFIGURE_ARGS+= --with-windows-font-dir="${WINDOWS_FONT_DIR}"
|
||||
.endif
|
||||
|
||||
ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
|
||||
|
||||
.if !defined(NOPORTDOCS)
|
||||
INSTALL_TARGET= install install-data-html
|
||||
.endif
|
||||
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
@ -66,8 +61,9 @@ test check:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Perl and Tcl APIs will be installed by separate ports
|
||||
PLIST_SUB+= WITH_PERL="@comment "
|
||||
.if defined(WITH_WINDOWS_FONT_DIR)
|
||||
CONFIGURE_ARGS+= --with-windows-font-dir="${WINDOWS_FONT_DIR}"
|
||||
.endif
|
||||
|
||||
.if defined(WITHOUT_X11)
|
||||
PKGNAMESUFFIX+= -nox11
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (GraphicsMagick-1.1.12.tar.bz2) = 07653ae3d22a79786e637202a0532a95
|
||||
SHA256 (GraphicsMagick-1.1.12.tar.bz2) = 50e2a96cccad84e7eb5dfa277d3b68055e154f32a8d00d81acd072ba91a1a92e
|
||||
SIZE (GraphicsMagick-1.1.12.tar.bz2) = 5034822
|
||||
MD5 (GraphicsMagick-1.1.14.tar.bz2) = a4085265d4493a090557534b938ce942
|
||||
SHA256 (GraphicsMagick-1.1.14.tar.bz2) = 4454f0f97a10e1628ea411744e2e1997a148df79a06ee9d25a3ff7e0c885114e
|
||||
SIZE (GraphicsMagick-1.1.14.tar.bz2) = 5060409
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- ./Magick++/lib/Makefile.in.orig 2008-04-10 11:16:21.000000000 -0400
|
||||
+++ ./Magick++/lib/Makefile.in 2008-09-02 08:05:28.000000000 -0400
|
||||
@@ -400,7 +400,7 @@
|
||||
AM_LDFLAGS = @LDFLAGS@ $(LIBSTDCLDFLAGS)
|
||||
|
||||
# Pkgconfig directory
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
|
||||
# Files to install in Pkgconfig directory
|
||||
pkgconfig_DATA = GraphicsMagick++.pc
|
@ -1,89 +0,0 @@
|
||||
--- Makefile.in Fri Mar 18 19:36:21 2005
|
||||
+++ Makefile.in Sun Jul 24 18:21:35 2005
|
||||
@@ -466,5 +466,5 @@
|
||||
|
||||
# Install HTML files
|
||||
-pkgdocdir = @MagickSharePath@
|
||||
+pkgdocdir = ${DATA_DIR}/doc/GraphicsMagick
|
||||
DOCDIRS = images www www/api www/Magick++
|
||||
@WITH_PERL_TRUE@PERLMAGICK = PerlMagick
|
||||
@@ -1079,5 +1079,5 @@
|
||||
|
||||
# Install arch-independent package data
|
||||
-install-data-local: install-data-html
|
||||
+install-data-local:
|
||||
|
||||
# Uninstall arch-independent package data
|
||||
--- coders/Makefile.in Fri Mar 18 19:36:16 2005
|
||||
+++ coders/Makefile.in Sun Jul 24 19:22:21 2005
|
||||
@@ -1479,5 +1479,5 @@
|
||||
install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z "$(pkg_LTLIBRARIES)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
@@ -1825,5 +1825,5 @@
|
||||
install-pkgDATA: $(pkg_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
@@ -1842,5 +1842,5 @@
|
||||
install-pkgdataDATA: $(pkgdata_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
|
||||
+ test -z "$(pkgdatadir)" -o -z '$(pkgdata_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
|
||||
@list='$(pkgdata_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
--- filters/Makefile.in Fri Mar 18 19:36:17 2005
|
||||
+++ filters/Makefile.in Sun Jul 24 19:23:33 2005
|
||||
@@ -522,5 +522,5 @@
|
||||
install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_LTLIBRARIES)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
@@ -592,5 +592,5 @@
|
||||
install-pkgDATA: $(pkg_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
--- magick/Makefile.in Fri Mar 18 19:36:18 2005
|
||||
+++ magick/Makefile.in Tue Jul 26 21:05:48 2005
|
||||
@@ -664,5 +664,5 @@
|
||||
|
||||
# Pkgconfig directory
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
|
||||
# Files to install in Pkgconfig directory
|
||||
@@ -930,5 +930,5 @@
|
||||
install-pkgDATA: $(pkg_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
--- Magick++/lib/Makefile.in Fri Mar 18 19:36:13 2005
|
||||
+++ Magick++/lib/Makefile.in Tue Jul 26 21:37:39 2005
|
||||
@@ -453,5 +453,5 @@
|
||||
|
||||
# Pkgconfig directory
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
|
||||
# Files to install in Pkgconfig directory
|
||||
--- wand/Makefile.in Fri Mar 18 19:36:20 2005
|
||||
+++ wand/Makefile.in Tue Jul 26 21:38:43 2005
|
||||
@@ -478,5 +478,5 @@
|
||||
|
||||
# Pkgconfig directory
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
|
||||
# Files to install in Pkgconfig directory
|
29
graphics/GraphicsMagick/files/patch-coders__Makefile.in
Normal file
29
graphics/GraphicsMagick/files/patch-coders__Makefile.in
Normal file
@ -0,0 +1,29 @@
|
||||
--- ./coders/Makefile.in.orig 2008-04-10 11:16:23.000000000 -0400
|
||||
+++ ./coders/Makefile.in 2008-09-02 08:05:28.000000000 -0400
|
||||
@@ -1696,7 +1696,7 @@
|
||||
done
|
||||
install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z "$(pkg_LTLIBRARIES)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
f=$(am__strip_dir) \
|
||||
@@ -2038,7 +2038,7 @@
|
||||
-rm -rf .libs _libs
|
||||
install-pkgDATA: $(pkg_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
f=$(am__strip_dir) \
|
||||
@@ -2055,7 +2055,7 @@
|
||||
done
|
||||
install-pkgdataDATA: $(pkgdata_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdatadir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
|
||||
+ test -z "$(pkgdatadir)" -o -z '$(pkgdata_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdatadir)"
|
||||
@list='$(pkgdata_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
f=$(am__strip_dir) \
|
@ -1,6 +1,7 @@
|
||||
--- coders/fpx.c 2004-04-14 18:45:28.000000000 -0400
|
||||
+++ coders/fpx.c 2007-11-01 23:30:18.000000000 -0500
|
||||
@@ -182,13 +182,13 @@
|
||||
--- ./coders/fpx.c.orig 2007-11-05 22:03:47.000000000 -0500
|
||||
+++ ./coders/fpx.c 2008-09-02 08:05:29.000000000 -0400
|
||||
@@ -181,15 +181,15 @@
|
||||
|
||||
unsigned int
|
||||
status,
|
||||
- subimage;
|
||||
@ -18,3 +19,4 @@
|
||||
+
|
||||
/*
|
||||
Open image.
|
||||
*/
|
@ -1,23 +1,29 @@
|
||||
--- configure Fri Mar 18 19:35:06 2005
|
||||
+++ configure Tue Jul 26 22:53:50 2005
|
||||
@@ -2092,5 +2092,5 @@
|
||||
MagickLibConfigSubDir="${MagickLibSubdir}/config"
|
||||
AC_DEFINE_UNQUOTED(MagickLibConfigSubDir,"$MagickLibConfigSubDir",Subdirectory of lib where architecture-dependent configuration files live.)
|
||||
--- ./configure.orig 2008-04-10 11:16:29.000000000 -0400
|
||||
+++ ./configure 2008-09-02 08:05:29.000000000 -0400
|
||||
@@ -34040,7 +34040,7 @@
|
||||
#define MagickLibConfigSubDir "$MagickLibConfigSubDir"
|
||||
_ACEOF
|
||||
|
||||
-MagickLibConfigPath="${LIB_DIR}/${MagickLibConfigSubDir}"
|
||||
+MagickLibConfigPath="${DATA_DIR}/GraphicsMagick/config"
|
||||
MagickLibConfigPathDefine="${MagickLibConfigPath}/"
|
||||
if test "$native_win32_build" = 'yes'
|
||||
@@ -2130,5 +2130,5 @@
|
||||
then
|
||||
@@ -34098,7 +34098,7 @@
|
||||
#
|
||||
# Path to GraphicsMagick share files
|
||||
MagickShareSubdir="${PACKAGE_NAME}-${PACKAGE_VERSION}"
|
||||
-MagickSharePath="${DATA_DIR}/${MagickShareSubdir}"
|
||||
+MagickSharePath="${DATA_DIR}/GraphicsMagick/"
|
||||
MagickSharePathDefine="${MagickSharePath}/"
|
||||
if test "$native_win32_build" = 'yes'
|
||||
@@ -2142,5 +2142,5 @@
|
||||
MagickShareConfigSubDir="${MagickLibSubdir}/config"
|
||||
AC_DEFINE_UNQUOTED(MagickShareConfigSubDir,"$MagickShareConfigSubDir",Subdirectory of lib where architecture-independent configuration files live.)
|
||||
then
|
||||
@@ -34118,7 +34118,7 @@
|
||||
#define MagickShareConfigSubDir "$MagickShareConfigSubDir"
|
||||
_ACEOF
|
||||
|
||||
-MagickShareConfigPath="${DATA_DIR}/${MagickShareConfigSubDir}"
|
||||
+MagickShareConfigPath="${MagickLibConfigPath}"
|
||||
MagickShareConfigPathDefine="${MagickShareConfigPath}/"
|
||||
if test "$native_win32_build" = 'yes'
|
||||
then
|
||||
|
20
graphics/GraphicsMagick/files/patch-filters__Makefile.in
Normal file
20
graphics/GraphicsMagick/files/patch-filters__Makefile.in
Normal file
@ -0,0 +1,20 @@
|
||||
--- ./filters/Makefile.in.orig 2008-04-10 11:16:24.000000000 -0400
|
||||
+++ ./filters/Makefile.in 2008-09-02 08:05:29.000000000 -0400
|
||||
@@ -464,7 +464,7 @@
|
||||
done
|
||||
install-pkgLTLIBRARIES: $(pkg_LTLIBRARIES)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_LTLIBRARIES)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_LTLIBRARIES)'; for p in $$list; do \
|
||||
if test -f $$p; then \
|
||||
f=$(am__strip_dir) \
|
||||
@@ -530,7 +530,7 @@
|
||||
-rm -rf .libs _libs
|
||||
install-pkgDATA: $(pkg_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
f=$(am__strip_dir) \
|
20
graphics/GraphicsMagick/files/patch-magick__Makefile.in
Normal file
20
graphics/GraphicsMagick/files/patch-magick__Makefile.in
Normal file
@ -0,0 +1,20 @@
|
||||
--- ./magick/Makefile.in.orig 2008-04-10 11:16:24.000000000 -0400
|
||||
+++ ./magick/Makefile.in 2008-09-02 08:05:29.000000000 -0400
|
||||
@@ -612,7 +612,7 @@
|
||||
pkgdata_DATA =
|
||||
|
||||
# Pkgconfig directory
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
|
||||
# Files to install in Pkgconfig directory
|
||||
pkgconfig_DATA = GraphicsMagick.pc
|
||||
@@ -876,7 +876,7 @@
|
||||
done
|
||||
install-pkgDATA: $(pkg_DATA)
|
||||
@$(NORMAL_INSTALL)
|
||||
- test -z "$(pkgdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
+ test -z "$(pkgdir)" -o -z '$(pkg_DATA)' || $(MKDIR_P) "$(DESTDIR)$(pkgdir)"
|
||||
@list='$(pkg_DATA)'; for p in $$list; do \
|
||||
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
|
||||
f=$(am__strip_dir) \
|
@ -1,5 +1,5 @@
|
||||
--- magick/symbols.h.orig Mon Jul 16 21:55:06 2007
|
||||
+++ magick/symbols.h Mon Jul 16 21:56:04 2007
|
||||
--- ./magick/symbols.h.orig 2004-04-14 18:45:07.000000000 -0400
|
||||
+++ ./magick/symbols.h 2008-09-02 08:05:29.000000000 -0400
|
||||
@@ -17,6 +17,8 @@
|
||||
#if !defined(_MAGICK_SYMBOLS_H)
|
||||
#define _MAGICK_SYMBOLS_H
|
11
graphics/GraphicsMagick/files/patch-wand__Makefile.in
Normal file
11
graphics/GraphicsMagick/files/patch-wand__Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./wand/Makefile.in.orig 2008-04-10 11:16:25.000000000 -0400
|
||||
+++ ./wand/Makefile.in 2008-09-02 08:05:29.000000000 -0400
|
||||
@@ -427,7 +427,7 @@
|
||||
noinst_HEADERS = magick_compat.h
|
||||
|
||||
# Pkgconfig directory
|
||||
-pkgconfigdir = $(libdir)/pkgconfig
|
||||
+pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
|
||||
# Files to install in Pkgconfig directory
|
||||
pkgconfig_DATA = GraphicsMagickWand.pc
|
@ -1,13 +1,10 @@
|
||||
This is a port of GraphicsMagick(TM), the "swiss army knife" of image
|
||||
processing. It provides a robust collection of tools and libraries which
|
||||
support reading, writing, and manipulating an image in over 88 major
|
||||
formats including formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF, SVG
|
||||
and TIFF.
|
||||
This is a port of GraphicsMagick(TM), the "swiss army knife" of
|
||||
image processing. It provides a robust collection of tools and
|
||||
libraries which support reading, writing, and manipulating an image
|
||||
in over 88 major formats including formats like DPX, GIF, JPEG,
|
||||
JPEG-2000, PNG, PDF, SVG and TIFF.
|
||||
|
||||
The program is the fork of a better-known ImageMagick (5.5.2), which
|
||||
emphasizes end-user and API-stabilities.
|
||||
|
||||
WWW: http://www.graphicsmagick.org/
|
||||
|
||||
- Ron van Daal
|
||||
ronvdaal@n1x.nl
|
||||
WWW: http://www.graphicsmagick.org/
|
||||
|
@ -66,16 +66,6 @@ include/GraphicsMagick/wand/drawing_wand.h
|
||||
include/GraphicsMagick/wand/magick_wand.h
|
||||
include/GraphicsMagick/wand/pixel_wand.h
|
||||
include/GraphicsMagick/wand/wand_api.h
|
||||
%%DATADIR%%/Copyright.txt
|
||||
%%DATADIR%%/config/colors.mgk
|
||||
%%DATADIR%%/config/delegates.mgk
|
||||
%%DATADIR%%/config/log.mgk
|
||||
%%DATADIR%%/config/magic.mgk
|
||||
%%DATADIR%%/config/modules.mgk
|
||||
%%DATADIR%%/config/type-ghostscript.mgk
|
||||
%%DATADIR%%/config/type-solaris.mgk
|
||||
%%DATADIR%%/config/type-windows.mgk
|
||||
%%DATADIR%%/config/type.mgk
|
||||
lib/libGraphicsMagick++.a
|
||||
lib/libGraphicsMagick++.la
|
||||
lib/libGraphicsMagick++.so
|
||||
@ -91,153 +81,153 @@ lib/libGraphicsMagickWand.so.0
|
||||
libdata/pkgconfig/GraphicsMagick++.pc
|
||||
libdata/pkgconfig/GraphicsMagick.pc
|
||||
libdata/pkgconfig/GraphicsMagickWand.pc
|
||||
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/Graphics/Magick.pm
|
||||
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/.packlist
|
||||
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/Magick.so
|
||||
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/Magick.bs
|
||||
%%WITH_PERL%%%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick/autosplit.ix
|
||||
@comment lib/GraphicsMagick-%%PORTVERSION%%/modules-%%Q%%/coders
|
||||
@comment lib/GraphicsMagick-%%PORTVERSION%%/modules-%%Q%%/filters
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/ball.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/corbis.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/examples.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/gm-125x80t.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/gm-188x120t.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/gm-282x180t.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/home.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/mail.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/pdfsages.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/pngnow.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/right_triangle_option.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/AUTHORS.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Changelog.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Copyright.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/FAQ.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/GraphicsMagick.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-unix.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/INSTALL-windows.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/ImageMagickObject.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Blob.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Cache.svg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ChangeLog.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/CoderInfo.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Color.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Documentation.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Drawable_example_1.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Enumerations.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Exception.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/FormatCharacters.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Future.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Geometry.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Image.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageDesign.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/ImageMagick.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Install.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Magick++.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Montage.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/NEWS.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/PixelPacket.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/Pixels.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/STL.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/TypeMetric.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/gm-188x120t.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/montage-sample-framed.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/right_triangle.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.fig
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-framed.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/Magick++/thumbnail-sample-plain.jpg
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/NEWS.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/README.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/animate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/animate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/annotate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/attribute.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/blob.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/cache.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/cache_view.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/color.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/composite.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/constitute.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/decorate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/deprecate.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/display.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/draw.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/effect.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/enhance.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/error.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/fx.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/image.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/list.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/magick.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/memory.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/monitor.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/montage.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/paint.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/profile.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/quantize.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/registry.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/render.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/resize.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/resource.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/segment.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/shear.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/signature.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/stream.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/transform.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/types.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/api/widget.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/body.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/books.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/color.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/composite.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/conjure.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/contribute.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/convert.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/cvs.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/development.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/display.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/download.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/formats.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/gm.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/header.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/identify.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/import.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/index.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/install.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/links.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/magick.css
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/miff.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/mission.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/mogrify.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/montage.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/perl.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/programming.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/quantize.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/smile.c
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/tools.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/utilities.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/www/windows.html
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/api
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/www/Magick++
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/www
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
|
||||
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
||||
%%WITH_PERL%%@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics/Magick
|
||||
%%WITH_PERL%%@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graphics
|
||||
%%WITH_PERL%%@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Graphics
|
||||
%%DATADIR%%/config/colors.mgk
|
||||
%%DATADIR%%/config/delegates.mgk
|
||||
%%DATADIR%%/config/log.mgk
|
||||
%%DATADIR%%/config/magic.mgk
|
||||
%%DATADIR%%/config/modules.mgk
|
||||
%%DATADIR%%/config/type-ghostscript.mgk
|
||||
%%DATADIR%%/config/type-solaris.mgk
|
||||
%%DATADIR%%/config/type-windows.mgk
|
||||
%%DATADIR%%/config/type.mgk
|
||||
%%DOCSDIR%%/Copyright.txt
|
||||
%%DOCSDIR%%/images/ball.png
|
||||
%%DOCSDIR%%/images/corbis.png
|
||||
%%DOCSDIR%%/images/examples.jpg
|
||||
%%DOCSDIR%%/images/gm-125x80t.png
|
||||
%%DOCSDIR%%/images/gm-188x120t.png
|
||||
%%DOCSDIR%%/images/gm-282x180t.png
|
||||
%%DOCSDIR%%/images/home.png
|
||||
%%DOCSDIR%%/images/mail.png
|
||||
%%DOCSDIR%%/images/pdfsages.png
|
||||
%%DOCSDIR%%/images/pngnow.png
|
||||
%%DOCSDIR%%/images/right_triangle.png
|
||||
%%DOCSDIR%%/images/right_triangle_option.png
|
||||
%%DOCSDIR%%/index.html
|
||||
%%DOCSDIR%%/www/AUTHORS.html
|
||||
%%DOCSDIR%%/www/Changelog.html
|
||||
%%DOCSDIR%%/www/Copyright.html
|
||||
%%DOCSDIR%%/www/FAQ.html
|
||||
%%DOCSDIR%%/www/GraphicsMagick.html
|
||||
%%DOCSDIR%%/www/INSTALL-unix.html
|
||||
%%DOCSDIR%%/www/INSTALL-windows.html
|
||||
%%DOCSDIR%%/www/ImageMagickObject.html
|
||||
%%DOCSDIR%%/www/Magick++/Blob.html
|
||||
%%DOCSDIR%%/www/Magick++/Cache.fig
|
||||
%%DOCSDIR%%/www/Magick++/Cache.png
|
||||
%%DOCSDIR%%/www/Magick++/Cache.svg
|
||||
%%DOCSDIR%%/www/Magick++/ChangeLog.html
|
||||
%%DOCSDIR%%/www/Magick++/CoderInfo.html
|
||||
%%DOCSDIR%%/www/Magick++/Color.html
|
||||
%%DOCSDIR%%/www/Magick++/Documentation.html
|
||||
%%DOCSDIR%%/www/Magick++/Drawable.html
|
||||
%%DOCSDIR%%/www/Magick++/Drawable_example_1.png
|
||||
%%DOCSDIR%%/www/Magick++/Enumerations.html
|
||||
%%DOCSDIR%%/www/Magick++/Exception.html
|
||||
%%DOCSDIR%%/www/Magick++/FormatCharacters.html
|
||||
%%DOCSDIR%%/www/Magick++/Future.html
|
||||
%%DOCSDIR%%/www/Magick++/Geometry.html
|
||||
%%DOCSDIR%%/www/Magick++/Image.fig
|
||||
%%DOCSDIR%%/www/Magick++/Image.html
|
||||
%%DOCSDIR%%/www/Magick++/Image.png
|
||||
%%DOCSDIR%%/www/Magick++/ImageDesign.html
|
||||
%%DOCSDIR%%/www/Magick++/ImageMagick.png
|
||||
%%DOCSDIR%%/www/Magick++/Install.html
|
||||
%%DOCSDIR%%/www/Magick++/Magick++.png
|
||||
%%DOCSDIR%%/www/Magick++/Montage.html
|
||||
%%DOCSDIR%%/www/Magick++/NEWS.html
|
||||
%%DOCSDIR%%/www/Magick++/PixelPacket.html
|
||||
%%DOCSDIR%%/www/Magick++/Pixels.html
|
||||
%%DOCSDIR%%/www/Magick++/README.txt
|
||||
%%DOCSDIR%%/www/Magick++/STL.html
|
||||
%%DOCSDIR%%/www/Magick++/TypeMetric.html
|
||||
%%DOCSDIR%%/www/Magick++/gm-188x120t.png
|
||||
%%DOCSDIR%%/www/Magick++/index.html
|
||||
%%DOCSDIR%%/www/Magick++/montage-sample-framed.jpg
|
||||
%%DOCSDIR%%/www/Magick++/right_triangle.png
|
||||
%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.fig
|
||||
%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-framed.jpg
|
||||
%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.fig
|
||||
%%DOCSDIR%%/www/Magick++/thumbnail-anatomy-plain.jpg
|
||||
%%DOCSDIR%%/www/Magick++/thumbnail-sample-framed.jpg
|
||||
%%DOCSDIR%%/www/Magick++/thumbnail-sample-plain.jpg
|
||||
%%DOCSDIR%%/www/NEWS.html
|
||||
%%DOCSDIR%%/www/README.html
|
||||
%%DOCSDIR%%/www/animate.html
|
||||
%%DOCSDIR%%/www/api.html
|
||||
%%DOCSDIR%%/www/api/animate.html
|
||||
%%DOCSDIR%%/www/api/annotate.html
|
||||
%%DOCSDIR%%/www/api/attribute.html
|
||||
%%DOCSDIR%%/www/api/blob.html
|
||||
%%DOCSDIR%%/www/api/cache.html
|
||||
%%DOCSDIR%%/www/api/cache_view.html
|
||||
%%DOCSDIR%%/www/api/color.html
|
||||
%%DOCSDIR%%/www/api/composite.html
|
||||
%%DOCSDIR%%/www/api/constitute.html
|
||||
%%DOCSDIR%%/www/api/decorate.html
|
||||
%%DOCSDIR%%/www/api/deprecate.html
|
||||
%%DOCSDIR%%/www/api/display.html
|
||||
%%DOCSDIR%%/www/api/draw.html
|
||||
%%DOCSDIR%%/www/api/effect.html
|
||||
%%DOCSDIR%%/www/api/enhance.html
|
||||
%%DOCSDIR%%/www/api/error.html
|
||||
%%DOCSDIR%%/www/api/fx.html
|
||||
%%DOCSDIR%%/www/api/image.html
|
||||
%%DOCSDIR%%/www/api/list.html
|
||||
%%DOCSDIR%%/www/api/magick.html
|
||||
%%DOCSDIR%%/www/api/memory.html
|
||||
%%DOCSDIR%%/www/api/monitor.html
|
||||
%%DOCSDIR%%/www/api/montage.html
|
||||
%%DOCSDIR%%/www/api/paint.html
|
||||
%%DOCSDIR%%/www/api/profile.html
|
||||
%%DOCSDIR%%/www/api/quantize.html
|
||||
%%DOCSDIR%%/www/api/registry.html
|
||||
%%DOCSDIR%%/www/api/render.html
|
||||
%%DOCSDIR%%/www/api/resize.html
|
||||
%%DOCSDIR%%/www/api/resource.html
|
||||
%%DOCSDIR%%/www/api/segment.html
|
||||
%%DOCSDIR%%/www/api/shear.html
|
||||
%%DOCSDIR%%/www/api/signature.html
|
||||
%%DOCSDIR%%/www/api/stream.html
|
||||
%%DOCSDIR%%/www/api/transform.html
|
||||
%%DOCSDIR%%/www/api/types.html
|
||||
%%DOCSDIR%%/www/api/widget.html
|
||||
%%DOCSDIR%%/www/body.html
|
||||
%%DOCSDIR%%/www/books.html
|
||||
%%DOCSDIR%%/www/color.html
|
||||
%%DOCSDIR%%/www/composite.html
|
||||
%%DOCSDIR%%/www/conjure.html
|
||||
%%DOCSDIR%%/www/contribute.html
|
||||
%%DOCSDIR%%/www/convert.html
|
||||
%%DOCSDIR%%/www/cvs.html
|
||||
%%DOCSDIR%%/www/development.html
|
||||
%%DOCSDIR%%/www/display.html
|
||||
%%DOCSDIR%%/www/download.html
|
||||
%%DOCSDIR%%/www/formats.html
|
||||
%%DOCSDIR%%/www/gm.html
|
||||
%%DOCSDIR%%/www/header.html
|
||||
%%DOCSDIR%%/www/identify.html
|
||||
%%DOCSDIR%%/www/import.html
|
||||
%%DOCSDIR%%/www/index.html
|
||||
%%DOCSDIR%%/www/install.html
|
||||
%%DOCSDIR%%/www/links.html
|
||||
%%DOCSDIR%%/www/magick.css
|
||||
%%DOCSDIR%%/www/miff.html
|
||||
%%DOCSDIR%%/www/mission.html
|
||||
%%DOCSDIR%%/www/mogrify.html
|
||||
%%DOCSDIR%%/www/montage.html
|
||||
%%DOCSDIR%%/www/perl.html
|
||||
%%DOCSDIR%%/www/programming.html
|
||||
%%DOCSDIR%%/www/quantize.html
|
||||
%%DOCSDIR%%/www/smile.c
|
||||
%%DOCSDIR%%/www/tools.html
|
||||
%%DOCSDIR%%/www/utilities.html
|
||||
%%DOCSDIR%%/www/windows.html
|
||||
@dirrm %%DOCSDIR%%/www/api
|
||||
@dirrm %%DOCSDIR%%/www/Magick++
|
||||
@dirrm %%DOCSDIR%%/www
|
||||
@dirrm %%DOCSDIR%%/images
|
||||
@dirrm %%DOCSDIR%%
|
||||
@dirrm %%DATADIR%%/config
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm include/GraphicsMagick/wand
|
||||
|
Loading…
Reference in New Issue
Block a user