Fix build with Qt 5.11
Adjust the local patch for CMakeLists.txt for the changes made upstream and fix it to find and link to QtDBus like it was intending. Add dependency on QtDBus since it links to it now. Bump PORTREVISION since QtDBus is detected now. PR: 230844 Obtained from: upstream
This commit is contained in:
parent
a4453a63ba
commit
0f581d8ce7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478549
@ -3,9 +3,12 @@
|
||||
PORTNAME= seafile-gui
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 6.1.7
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net-mgmt devel
|
||||
|
||||
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
|
||||
PATCHFILES= 03c883561d40.patch:-p1
|
||||
|
||||
MAINTAINER= ultima@FreeBSD.org
|
||||
COMMENT= Open Source Cloud Storage (Client)
|
||||
|
||||
@ -20,7 +23,7 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
|
||||
libevent.so:devel/libevent \
|
||||
libuuid.so:misc/e2fsprogs-libuuid
|
||||
|
||||
USES= compiler:c++11-lang cmake pkgconfig qt:5 shebangfix ssl
|
||||
USES= compiler:c++11-lang cmake gnome pkgconfig qt:5 shebangfix ssl
|
||||
SHEBANG_FILES= extensions/*.sh scripts/*.sh fsplugin/*.sh \
|
||||
scripts/*.py
|
||||
|
||||
@ -29,7 +32,7 @@ GH_ACCOUNT= haiwen
|
||||
GH_PROJECT= seafile-client
|
||||
|
||||
USE_GNOME= glib20
|
||||
USE_QT= core gui network widgets \
|
||||
USE_QT= core dbus gui network widgets \
|
||||
qmake_build buildtools_build linguisttools_build
|
||||
#INSTALLS_ICONS= yes
|
||||
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:PATH=include/glib-2.0 \
|
||||
|
@ -1,3 +1,5 @@
|
||||
TIMESTAMP = 1524155528
|
||||
TIMESTAMP = 1535713431
|
||||
SHA256 (haiwen-seafile-client-v6.1.7_GH0.tar.gz) = 25dfcce4a1f1ad5bc72d551b9209c1d40bec6b92459d1d530e0829ce1b08a14d
|
||||
SIZE (haiwen-seafile-client-v6.1.7_GH0.tar.gz) = 2260217
|
||||
SHA256 (03c883561d40.patch) = b4ddec43a37e1eabfa9016670be6de91fd8245e051613cfb9189d2fa27082996
|
||||
SIZE (03c883561d40.patch) = 1553
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- CMakeLists.txt.orig 2017-05-09 08:39:31 UTC
|
||||
--- CMakeLists.txt.orig 2018-08-31 11:31:59 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -107,7 +107,7 @@ IF (WIN32)
|
||||
SET(SPARKLE_LIBS ${CMAKE_SOURCE_DIR}/WinSparkle.lib)
|
||||
@ -9,7 +9,16 @@
|
||||
INCLUDE_DIRECTORIES(${QT_QTDBUS_INCLUDE_DIR})
|
||||
LINK_DIRECTORIES(${QT_QTDBUS_LIBRARIES})
|
||||
SET(EXTRA_LIBS ${EXTRA_LIBS} ${QT_QTDBUS_LIBRARIES})
|
||||
@@ -360,7 +360,7 @@ PKG_CHECK_MODULES(LIBCCNET REQUIRED libccnet>=1.3)
|
||||
@@ -183,7 +183,7 @@ IF (BUILD_SHIBBOLETH_SUPPORT)
|
||||
ADD_DEFINITIONS(-DHAVE_SHIBBOLETH_SUPPORT)
|
||||
ENDIF()
|
||||
|
||||
-IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
|
||||
+IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
|
||||
SET(USE_QT_LIBRARIES ${USE_QT_LIBRARIES} "DBus")
|
||||
ENDIF()
|
||||
|
||||
@@ -367,7 +367,7 @@ PKG_CHECK_MODULES(LIBCCNET REQUIRED libccnet>=1.3)
|
||||
|
||||
PKG_CHECK_MODULES(LIBSEARPC REQUIRED libsearpc>=1.0)
|
||||
|
||||
@ -18,7 +27,7 @@
|
||||
|
||||
PKG_CHECK_MODULES(LIBSEAFILE REQUIRED libseafile>=1.7)
|
||||
|
||||
@@ -561,7 +561,7 @@ IF (WIN32)
|
||||
@@ -574,7 +574,7 @@ IF (WIN32)
|
||||
src/utils/registry.cpp
|
||||
src/utils/utils-win.cpp
|
||||
)
|
||||
@ -27,12 +36,12 @@
|
||||
LIST(APPEND utils_sources
|
||||
src/utils/process-linux.cpp
|
||||
)
|
||||
@@ -761,7 +761,7 @@ QT5_USE_MODULES(seafile-applet ${WEBKIT_NAME} ${WEBKIT
|
||||
@@ -775,7 +775,7 @@ target_link_libraries(seafile-applet Qt5::WebEngine Qt
|
||||
ENDIF()
|
||||
|
||||
## QtBus
|
||||
-IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD")
|
||||
+IF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
|
||||
TARGET_LINK_LIBRARIES(seafile-applet
|
||||
${QT_QTDBUS_LIBRARIES}
|
||||
)
|
||||
target_link_libraries(seafile-applet Qt5::DBus)
|
||||
ENDIF()
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user