add qtfw
A GUI frontend for ipfw utility in FreeBSD PR: 30077 Submitted by: Patrick Li <pat@databits.net>
This commit is contained in:
parent
7c2e77dac9
commit
0f4eb80eba
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47081
@ -153,6 +153,7 @@
|
||||
SUBDIR += py-gnupg
|
||||
SUBDIR += py-m2crypto
|
||||
SUBDIR += py-rijndael
|
||||
SUBDIR += qtfw
|
||||
SUBDIR += racoon
|
||||
SUBDIR += radiusniff
|
||||
SUBDIR += rain
|
||||
|
26
security/qtfw/Makefile
Normal file
26
security/qtfw/Makefile
Normal file
@ -0,0 +1,26 @@
|
||||
# New ports collection makefile for: qtfw
|
||||
# Date created: Sat Aug 25 10:42:02 EDT 2001
|
||||
# Whom: Patrick Li <pat@databits.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= qtfw
|
||||
PORTVERSION= 0.3.1
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= pat@databits.net
|
||||
|
||||
ALL_TARGET= ${PORTNAME}
|
||||
USE_QT_VER= 2
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
|
||||
@${INSTALL_DATA} ${WRKSRC}/examples/* \
|
||||
${PREFIX}/share/examples/${PORTNAME}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
security/qtfw/distinfo
Normal file
1
security/qtfw/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (qtfw-0.3.1.tar.gz) = 6860180726c24deea67218a34d83c7a8
|
39
security/qtfw/files/patch-Makefile
Normal file
39
security/qtfw/files/patch-Makefile
Normal file
@ -0,0 +1,39 @@
|
||||
--- Makefile.orig Fri Aug 24 12:17:26 2001
|
||||
+++ Makefile Sat Aug 25 10:49:38 2001
|
||||
@@ -7,18 +7,18 @@
|
||||
aboutdlg.cpp moc_aboutdlg.cpp
|
||||
OBJS=$(SOURCES:.cpp=.o)
|
||||
|
||||
-CFLAGS=-g -Wall -I/usr/X11R6/include/qt2
|
||||
-LDFLAGS=-L/usr/X11R6/lib -lqt2
|
||||
+CFLAGS=-g -Wall -I${X11BASE}/include/qt2
|
||||
+LDFLAGS=-L${X11BASE}/lib -lqt2
|
||||
|
||||
-INSTALL_PREFIX=/usr/X11R6
|
||||
+INSTALL_PREFIX=${PREFIX}
|
||||
HTMLS:=`echo docs/*.html`
|
||||
EXAMPLES:=`echo examples/*.html`
|
||||
|
||||
$(TARGET):$(OBJS)
|
||||
- g++ $(LDFLAGS) -o $(TARGET) $(OBJS)
|
||||
+ ${CXX} $(LDFLAGS) -o $(TARGET) $(OBJS)
|
||||
|
||||
.cpp.o:
|
||||
- g++ $(CFLAGS) -c $<
|
||||
+ ${CXX} $(CFLAGS) -c $<
|
||||
|
||||
moc_mainformbase.cpp : mainformbase.H
|
||||
moc2 mainformbase.H > moc_mainformbase.cpp
|
||||
@@ -57,11 +57,7 @@
|
||||
rm -f moc_*
|
||||
|
||||
install: $(TARGET)
|
||||
- install -c $(TARGET) $(INSTALL_PREFIX)/bin/
|
||||
- install -d $(INSTALL_PREFIX)/share/$(TARGET)/docs/
|
||||
- install -d $(INSTALL_PREFIX)/share/$(TARGET)/examples/
|
||||
- cp -R docs/ $(INSTALL_PREFIX)/share/$(TARGET)/docs/
|
||||
- cp -R examples/ $(INSTALL_PREFIX)/share/$(TARGET)/examples/
|
||||
+ ${BSD_INSTALL_PROGRAM} $(TARGET) $(INSTALL_PREFIX)/bin
|
||||
|
||||
uninstall:
|
||||
rm -f $(INSTALL_PREFIX)/bin/$(TARGET)
|
1
security/qtfw/pkg-comment
Normal file
1
security/qtfw/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
A GUI frontend for ipfw utility in FreeBSD
|
5
security/qtfw/pkg-descr
Normal file
5
security/qtfw/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
Qtfw is a Qt gui frontend for ipfw utility in FreeBSD. It helps
|
||||
configuring firewall in FreeBSD with a nice and comprehensive user
|
||||
interface.
|
||||
|
||||
WWW: http://sourceforge.net/projects/qtfw/
|
4
security/qtfw/pkg-plist
Normal file
4
security/qtfw/pkg-plist
Normal file
@ -0,0 +1,4 @@
|
||||
bin/qtfw
|
||||
%%PORTDOCS%%share/examples/qtfw/base.rules
|
||||
%%PORTDOCS%%share/examples/qtfw/client.rules
|
||||
%%PORTDOCS%%@dirrm share/examples/qtfw
|
Loading…
Reference in New Issue
Block a user