MFH: r468546
Regression/bug fix update to e2fsprogs 1.44.1. ChangeLog: <http://e2fsprogs.sourceforge.net/e2fsprogs-release.html#1.44.1> Approved by: ports-secteam (riggs@)
This commit is contained in:
parent
8fdc265f0c
commit
0f4841ed41
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=468755
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= e2fsprogs
|
||||
PORTVERSION= 1.44.0
|
||||
PORTVERSION= 1.44.1
|
||||
PORTREVISION?= 0
|
||||
CATEGORIES?= sysutils
|
||||
MASTER_SITES= KERNEL_ORG/linux/kernel/people/tytso/${PORTNAME}/v${PORTVERSION}
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1521069997
|
||||
SHA256 (e2fsprogs-1.44.0.tar.xz) = a3567042f03fcee0e01db8f923b24cec92e2ba5b11f8e39e245672ad5392723d
|
||||
SIZE (e2fsprogs-1.44.0.tar.xz) = 5325356
|
||||
TIMESTAMP = 1524922817
|
||||
SHA256 (e2fsprogs-1.44.1.tar.xz) = 0ca164c1c87724df904c918b2d7051ef989b51de725db66c67514dbe6dd2b9ef
|
||||
SIZE (e2fsprogs-1.44.1.tar.xz) = 5331960
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- e2fsck/unix.c.orig 2016-09-02 04:17:32 UTC
|
||||
--- e2fsck/unix.c.orig 2018-03-25 02:42:47 UTC
|
||||
+++ e2fsck/unix.c
|
||||
@@ -9,8 +9,6 @@
|
||||
* %End-Header%
|
||||
@ -18,7 +18,7 @@
|
||||
#endif
|
||||
#ifdef HAVE_SYS_TYPES_H
|
||||
#include <sys/types.h>
|
||||
@@ -593,6 +591,24 @@ static int e2fsck_update_progress(e2fsck
|
||||
@@ -595,6 +593,24 @@ static int e2fsck_update_progress(e2fsck
|
||||
return 0;
|
||||
}
|
||||
|
||||
@ -43,7 +43,7 @@
|
||||
#define PATH_SET "PATH=/sbin"
|
||||
|
||||
/*
|
||||
@@ -625,6 +641,17 @@ static void signal_progress_on(int sig E
|
||||
@@ -627,6 +643,17 @@ static void signal_progress_on(int sig E
|
||||
ctx->progress = e2fsck_update_progress;
|
||||
}
|
||||
|
||||
@ -61,7 +61,7 @@
|
||||
static void signal_progress_off(int sig EXT2FS_ATTR((unused)))
|
||||
{
|
||||
e2fsck_t ctx = e2fsck_global_ctx;
|
||||
@@ -1062,6 +1089,10 @@ static errcode_t PRS(int argc, char *arg
|
||||
@@ -1091,6 +1118,10 @@ static errcode_t PRS(int argc, char *arg
|
||||
sigaction(SIGUSR1, &sa, 0);
|
||||
sa.sa_handler = signal_progress_off;
|
||||
sigaction(SIGUSR2, &sa, 0);
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- lib/uuid/gen_uuid.c.orig 2016-09-02 04:17:32 UTC
|
||||
--- lib/uuid/gen_uuid.c.orig 2018-03-25 02:42:47 UTC
|
||||
+++ lib/uuid/gen_uuid.c
|
||||
@@ -92,6 +92,7 @@
|
||||
@@ -94,6 +94,7 @@
|
||||
#ifdef HAVE_SYS_RESOURCE_H
|
||||
#include <sys/resource.h>
|
||||
#endif
|
||||
@ -8,7 +8,7 @@
|
||||
|
||||
#include "uuidP.h"
|
||||
#include "uuidd.h"
|
||||
@@ -301,6 +302,28 @@ static int get_node_id(unsigned char *no
|
||||
@@ -300,6 +301,28 @@ static int get_node_id(unsigned char *no
|
||||
}
|
||||
}
|
||||
close(sd);
|
||||
|
@ -1,4 +1,4 @@
|
||||
--- misc/Makefile.in.orig 2016-09-02 04:52:46 UTC
|
||||
--- misc/Makefile.in.orig 2018-03-25 02:42:47 UTC
|
||||
+++ misc/Makefile.in
|
||||
@@ -34,16 +34,16 @@ INSTALL = @INSTALL@
|
||||
|
||||
@ -22,7 +22,7 @@
|
||||
UMANPAGES+= @FUSE_CMT@ fuse2fs.1
|
||||
|
||||
LPROGS= @E2INITRD_PROG@
|
||||
@@ -144,14 +144,14 @@ profiled:
|
||||
@@ -145,14 +145,14 @@ profiled:
|
||||
|
||||
mke2fs.conf: $(srcdir)/mke2fs.conf.in
|
||||
if test -f $(srcdir)/mke2fs.conf.custom.in ; then \
|
||||
@ -40,7 +40,7 @@
|
||||
> default_profile.c
|
||||
findsuper: findsuper.o
|
||||
$(E) " LD $@"
|
||||
@@ -577,34 +577,9 @@ install: all $(SMANPAGES) $(UMANPAGES) i
|
||||
@@ -593,34 +593,9 @@ install: all $(SMANPAGES) $(UMANPAGES) i
|
||||
(cd $(DESTDIR)$(man5dir); \
|
||||
$(LN) $(LINK_INSTALL_FLAGS) ext4.5 $$i.5); \
|
||||
done
|
||||
|
@ -0,0 +1,13 @@
|
||||
--- tests/f_bigalloc_badinode/script.orig 2018-03-25 02:42:47 UTC
|
||||
+++ tests/f_bigalloc_badinode/script
|
||||
@@ -6,8 +6,8 @@ TEST_DATA="$test_name.tmp"
|
||||
dd if=$TEST_BITS of=$TEST_DATA bs=4k count=2 seek=1> /dev/null 2>&1
|
||||
|
||||
touch $TMPFILE
|
||||
-mke2fs -Fq -t ext4 -O bigalloc -C 16384 $TMPFILE 1M > /dev/null 2>&1
|
||||
-debugfs -w $TMPFILE << EOF > /dev/null 2>&1
|
||||
+$MKE2FS -Fq -t ext4 -O bigalloc -C 16384 $TMPFILE 1M > /dev/null 2>&1
|
||||
+$DEBUGFS -w $TMPFILE << EOF > /dev/null 2>&1
|
||||
write $TEST_DATA testfile
|
||||
set_inode_field testfile i_mode 0120000
|
||||
quit
|
@ -0,0 +1,13 @@
|
||||
--- tests/f_bigalloc_orphan_list/script.orig 2018-03-25 02:42:47 UTC
|
||||
+++ tests/f_bigalloc_orphan_list/script
|
||||
@@ -6,8 +6,8 @@ TEST_DATA="$test_name.tmp"
|
||||
dd if=$TEST_BITS of=$TEST_DATA bs=28k count=1 > /dev/null 2>&1
|
||||
|
||||
touch $TMPFILE
|
||||
-mke2fs -Fq -t ext4 -O bigalloc $TMPFILE 1M > /dev/null 2>&1
|
||||
-debugfs -w $TMPFILE << EOF > /dev/null 2>&1
|
||||
+$MKE2FS -Fq -t ext4 -O bigalloc $TMPFILE 1M > /dev/null 2>&1
|
||||
+$DEBUGFS -w $TMPFILE << EOF > /dev/null 2>&1
|
||||
write $TEST_DATA testfile
|
||||
set_inode_field testfile links_count 0
|
||||
set_inode_field testfile bmap[0] 0
|
@ -1,7 +1,6 @@
|
||||
--- tests/r_inline_xattr/script.orig 2017-04-09 19:31:41 UTC
|
||||
--- tests/r_inline_xattr/script.orig 2018-03-25 02:42:47 UTC
|
||||
+++ tests/r_inline_xattr/script
|
||||
@@ -10,8 +10,8 @@ gunzip < $IMAGE > $TMPFILE
|
||||
echo "resize2fs test" > $OUT
|
||||
@@ -11,7 +11,7 @@ echo "resize2fs test" > $OUT
|
||||
|
||||
# Look at existing inline extended attribute
|
||||
echo "debugfs -R ''stat file'' test.img 2>&1 | grep ''^Inode\|in inode body\|user.name (''" >> $OUT
|
||||
@ -10,8 +9,7 @@
|
||||
status=$?
|
||||
echo Exit status is $status >> $OUT
|
||||
|
||||
@@ -23,8 +23,8 @@ echo Exit status is $status >> $OUT.new
|
||||
sed -f $cmd_dir/filter.sed -e "s;$TMPFILE;test.img;" $OUT.new >> $OUT
|
||||
@@ -24,7 +24,7 @@ sed -f $cmd_dir/filter.sed -e "s;$TMPFIL
|
||||
|
||||
# Look at inline extended attribute in resized fs
|
||||
echo "debugfs -R ''stat file'' test.img 2>&1 | grep ''^Inode\|in inode body\|user.name (''" >> $OUT
|
||||
|
Loading…
Reference in New Issue
Block a user