- Update to 2.9.1

PR:		110811
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Martin Wilke 2007-03-26 11:25:55 +00:00
parent 05c59b761a
commit 0f221d1d14
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=188382
7 changed files with 72 additions and 59 deletions

View File

@ -6,11 +6,14 @@
#
PORTNAME= xtide
PORTVERSION= 2.8.3
PORTVERSION= 2.9.1
CATEGORIES= astro
MASTER_SITES= ftp://ftp.flaterco.com/xtide/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} harmonics-dwf-20060708.tcd.bz2
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
libtcd-2.2.2.tar.bz2 \
harmonics-dwf-20070318.tcd.bz2
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX} \
libtcd-2.2.2.tar.bz2
MAINTAINER= ports@FreeBSD.org
COMMENT= Harmonic tide clock and tide predictor
@ -22,28 +25,42 @@ USE_XLIB= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= tide.1 xtide.1
MAN8= xttpd.8
PLIST_FILES= bin/tide bin/xtide bin/xttpd %%DATADIR%%/harmonics.tcd
PLIST_DIRS= %%DATADIR%%
CPPFLAGS= -I../libtcd-2.2.2 -I${LOCALBASE}/include/libpng
LDFLAGS= -L../libtcd-2.2.2/.libs -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
post-extract:
@${BZCAT} ${DISTDIR}/harmonics-dwf-20060708.tcd.bz2 \
@${BZCAT} ${DISTDIR}/harmonics-dwf-20070318.tcd.bz2 \
> ${WRKSRC}/harmonics.tcd
post-patch:
@${REINPLACE_CMD} -e 's|== yes|= yes|g' ${WRKDIR}/libtcd-2.2.2/configure
@${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/TideContext.cc
.for file in Global.cc HarmonicsPath.cc wvsrtv.cc
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${file}
.endfor
pre-configure:
@cd ${WRKDIR}/libtcd-2.2.2 \
&& ${SETENV} ${MAKE_ENV} ${SH} ./configure --disable-shared \
&& ${MAKE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tide ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/xtide ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/xttpd ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/DOCUMENTATION/tide.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/DOCUMENTATION/xtide.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/DOCUMENTATION/xttpd.8 ${MAN8PREFIX}/man/man8
${INSTALL_MAN} ${WRKSRC}/tide.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/xtide.1 ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/xttpd.8 ${MAN8PREFIX}/man/man8
@${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/harmonics.tcd ${DATADIR}
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -1,6 +1,9 @@
MD5 (xtide-2.8.3.tar.bz2) = 653fd807116290ab96bd5aa1bb974315
SHA256 (xtide-2.8.3.tar.bz2) = cf99652ec24bf1f19745bd3e482adad5ac76c385d91209d7816e8b65401538cd
SIZE (xtide-2.8.3.tar.bz2) = 463382
MD5 (harmonics-dwf-20060708.tcd.bz2) = 7e8acfeb5aa454c1c19fc14bb7263513
SHA256 (harmonics-dwf-20060708.tcd.bz2) = f1f9b44df515b7457684a3da5c34f765ef4fd358f429a1510eeb974697d175df
SIZE (harmonics-dwf-20060708.tcd.bz2) = 477682
MD5 (xtide-2.9.1.tar.bz2) = 7ccc99dcd77ab76df97124c01ae4a7ca
SHA256 (xtide-2.9.1.tar.bz2) = a7ffdeedaa8905181f8053f7a9ab8598755acf93308d63a2f373eefe2af63732
SIZE (xtide-2.9.1.tar.bz2) = 384508
MD5 (libtcd-2.2.2.tar.bz2) = 4780aa7c88d6816e6b4d2a744859d1e7
SHA256 (libtcd-2.2.2.tar.bz2) = f6647891c9c093302da68cb9b8045cd38064973a25067effa74ff0cde8f44e12
SIZE (libtcd-2.2.2.tar.bz2) = 264619
MD5 (harmonics-dwf-20070318.tcd.bz2) = cb00b5ba54c388ee4927a1b990f9220d
SHA256 (harmonics-dwf-20070318.tcd.bz2) = ae268904c20888c1097f3fc577dffbba15634a1a48b6f7195a4ca33a7ccb914b
SIZE (harmonics-dwf-20070318.tcd.bz2) = 487099

View File

@ -0,0 +1,15 @@
--- Global.cc.orig Thu Mar 15 09:58:01 2007
+++ Global.cc Fri Mar 23 02:31:17 2007
@@ -241,10 +241,10 @@
break;
case Error::NO_HFILE_PATH:
text_out += "NO_HFILE_PATH\n\
-If /etc/xtide.conf is not provided, you must set the environment variable\n\
+If %%PREFIX%%/etc/xtide.conf is not provided, you must set the environment variable\n\
HFILE_PATH to point to your harmonics files. Example:\n\
export HFILE_PATH=/usr/local/share/xtide/harmonics.tcd\n\
-Please refer to the documentation for usage of /etc/xtide.conf.";
+Please refer to the documentation for usage of %%PREFIX%%/etc/xtide.conf.";
break;
case Error::NO_HFILE_IN_PATH:
text_out += "NO_HFILE_IN_PATH\n\

View File

@ -0,0 +1,11 @@
--- HarmonicsPath.cc.orig Mon Feb 26 07:51:38 2007
+++ HarmonicsPath.cc Fri Mar 23 02:32:10 2007
@@ -30,7 +30,7 @@
Dstr hfile_path (getenv ("HFILE_PATH"));
if (hfile_path.isNull()) {
FILE *configfile;
- if ((configfile = fopen ("/etc/xtide.conf", "r"))) {
+ if ((configfile = fopen ("%%PREFIX%%/etc/xtide.conf", "r"))) {
hfile_path.getline (configfile);
fclose (configfile);
}

View File

@ -1,31 +0,0 @@
*** TideContext.cc.orig Wed Feb 5 00:53:46 2003
--- TideContext.cc Sun Mar 28 02:09:06 2004
***************
*** 47,59 ****
Dstr hfile_path (getenv ("HFILE_PATH"));
if (hfile_path.isNull()) {
FILE *configfile;
! if ((configfile = fopen ("/etc/xtide.conf", "r"))) {
hfile_path.getline (configfile);
fclose (configfile);
}
}
if (hfile_path.isNull())
! hfile_path = "harmonics.tcd";
harmonicsPath = new HarmonicsPath (hfile_path);
homedir = getenv ("HOME");
--- 47,59 ----
Dstr hfile_path (getenv ("HFILE_PATH"));
if (hfile_path.isNull()) {
FILE *configfile;
! if ((configfile = fopen ("%%PREFIX%%/etc/xtide.conf", "r"))) {
hfile_path.getline (configfile);
fclose (configfile);
}
}
if (hfile_path.isNull())
! hfile_path = "%%PREFIX%%/share/xtide/harmonics.tcd";
harmonicsPath = new HarmonicsPath (hfile_path);
homedir = getenv ("HOME");

View File

@ -1,13 +0,0 @@
--- Makefile.in.orig Mon Dec 20 23:15:05 2004
+++ Makefile.in Sat Jul 16 23:47:26 2005
@@ -11,8 +11,8 @@
# DEFS should include -Dacceptarg3_t=int (replace with the correct data type)
CXX = @CXX@
CC = @CC@
-CXXFLAGS = @extracxxflags@ @DEFS@ -I@includedir@ -Ilibtcd -I@xroot@/include @normalcxxflags@ -c
-LDFLAGS = @extraldflags@ -L@libdir@ -L@xlibdir@ @normalldflags@ -o
+CXXFLAGS = @CXXFLAGS@ @DEFS@ -I@includedir@ -Ilibtcd -I@xroot@/include @extracxxflags@ -c
+LDFLAGS = @LDFLAGS@ -L@libdir@ -L@xlibdir@ @extraldflags@ -o
# Extra switches and libs determined by configure.in
extraswitches=@extraswitches@

View File

@ -0,0 +1,11 @@
--- wvsrtv.cc.orig Thu Jan 4 11:35:43 2007
+++ wvsrtv.cc Fri Mar 23 02:32:59 2007
@@ -651,7 +651,7 @@
}
if (dir[0] == '\0') {
FILE *configfile;
- if ((configfile = fopen ("/etc/xtide.conf", "r"))) {
+ if ((configfile = fopen ("%%PREFIX%%/etc/xtide.conf", "r"))) {
if (!fgets (dir, 512, configfile)) {
fclose (configfile);
return 0;