MFH: r562418
mail/mutt: Security update to 2.0.5
- Update to 2.0.5 with fix for CVE-2021-3181
- Changelog at:
da5e328257/ChangeLog
PR: 252930
Submitted by: Derek Schrock <dereks@lifeofadishwasher.com> (maintainer)
Reviewed by: osa (mentor)
Approved by: osa (mentor)
Security: 387bbade-5d1d-11eb-bf20-4437e6ad11c4
Differential Revision: https://reviews.freebsd.org/D28309
This commit is contained in:
parent
2d3095fb81
commit
0f2063f75b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=562419
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= mutt
|
||||
DISTVERSION= 2.0.3
|
||||
DISTVERSION= 2.0.5
|
||||
CATEGORIES+= mail
|
||||
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
|
||||
https://bitbucket.org/mutt/mutt/downloads/ \
|
||||
@ -178,7 +178,7 @@ QUOTE_PATCH_PATCHFILES= patch-${VVV_PATCH_VERSION}.vvv.initials.xz:vvv \
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
VVV_PATCH_VERSION= 1.13.0
|
||||
GREETING_PATCH_VERSION= 2.0.1
|
||||
GREETING_PATCH_VERSION= 2.0.5
|
||||
|
||||
post-install:
|
||||
${INSTALL_MAN} ${FILESDIR}/mailcap.5 ${STAGEDIR}${MANPREFIX}/man/man5
|
||||
|
@ -1,8 +1,8 @@
|
||||
TIMESTAMP = 1607131693
|
||||
SHA256 (mutt/mutt-2.0.3.tar.gz) = 9c327cafb7acbfd4a57e7c817148fe438720a4545a5f628926f7745bc752c1ed
|
||||
SIZE (mutt/mutt-2.0.3.tar.gz) = 5292808
|
||||
SHA256 (mutt/mutt-2.0.1.vc.greeting) = 28d157df0ca36f2448dcc3d1cd19e34ec0eefe88251ebf1951e080d7178cccd2
|
||||
SIZE (mutt/mutt-2.0.1.vc.greeting) = 4452
|
||||
TIMESTAMP = 1611365285
|
||||
SHA256 (mutt/mutt-2.0.5.tar.gz) = e21d5aec0d3110f89d390929e56a38794a94f5843120d9ff59b21da78fd0004d
|
||||
SIZE (mutt/mutt-2.0.5.tar.gz) = 5294710
|
||||
SHA256 (mutt/mutt-2.0.5.vc.greeting) = cd91af2f8b30019939243cd736309664b0f00f090f0cd1b2dab6747fb07007e3
|
||||
SIZE (mutt/mutt-2.0.5.vc.greeting) = 4452
|
||||
SHA256 (mutt/patch-1.13.0.vvv.initials.xz) = 8b25ad6596bd57d94f6551e7e73ceb8da620468e96fb507b2f51545d5b3eaa02
|
||||
SIZE (mutt/patch-1.13.0.vvv.initials.xz) = 720
|
||||
SHA256 (mutt/patch-1.13.0.vvv.quote.xz) = 788d25d1439d86d6c5007d141d1c219496e77940b5ce37819471c941f78f03e4
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- PATCHES.orig 2020-11-08 20:52:48 UTC
|
||||
--- PATCHES.orig 2021-01-23 01:39:53 UTC
|
||||
+++ PATCHES
|
||||
@@ -0,0 +1 @@
|
||||
+patch-1.5.4.cd.ifdef.1
|
||||
--- init.c.orig 2020-11-03 17:50:37 UTC
|
||||
--- init.c.orig 2021-01-21 20:23:24 UTC
|
||||
+++ init.c
|
||||
@@ -672,6 +672,52 @@ static mbchar_table *parse_mbchar_table (const char *s
|
||||
@@ -678,6 +678,52 @@ static mbchar_table *parse_mbchar_table (const char *s
|
||||
return t;
|
||||
}
|
||||
|
||||
@ -57,7 +57,7 @@
|
||||
static int parse_unignore (BUFFER *buf, BUFFER *s, union pointer_long_t udata, BUFFER *err)
|
||||
{
|
||||
do
|
||||
--- init.h.orig 2020-11-08 20:52:48 UTC
|
||||
--- init.h.orig 2021-01-23 01:39:53 UTC
|
||||
+++ init.h
|
||||
@@ -4705,6 +4705,7 @@ static int parse_lists (BUFFER *, BUFFER *, union poin
|
||||
static int parse_unlists (BUFFER *, BUFFER *, union pointer_long_t, BUFFER *);
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- PATCHES.orig 2020-11-08 20:52:49 UTC
|
||||
--- PATCHES.orig 2021-01-23 01:39:53 UTC
|
||||
+++ PATCHES
|
||||
@@ -0,0 +1 @@
|
||||
+patch-1.5.6.cb.reverse_reply.2
|
||||
--- init.h.orig 2020-11-08 20:52:48 UTC
|
||||
--- init.h.orig 2021-01-23 01:39:53 UTC
|
||||
+++ init.h
|
||||
@@ -3191,6 +3191,13 @@ struct option_t MuttVars[] = {
|
||||
** In either case, a missing real name will be filled in afterwards
|
||||
@ -18,7 +18,7 @@
|
||||
{ "rfc2047_parameters", DT_BOOL, R_NONE, {.l=OPTRFC2047PARAMS}, {.l=0} },
|
||||
/*
|
||||
** .pp
|
||||
--- mutt.h.orig 2020-11-08 20:52:48 UTC
|
||||
--- mutt.h.orig 2021-01-23 01:39:53 UTC
|
||||
+++ mutt.h
|
||||
@@ -522,6 +522,7 @@ enum
|
||||
OPTREVALIAS,
|
||||
@ -28,7 +28,7 @@
|
||||
OPTRFC2047PARAMS,
|
||||
OPTSAVEADDRESS,
|
||||
OPTSAVEEMPTY,
|
||||
--- protos.h.orig 2020-11-06 22:06:35 UTC
|
||||
--- protos.h.orig 2021-01-21 20:23:24 UTC
|
||||
+++ protos.h
|
||||
@@ -85,6 +85,7 @@ char* mutt_extract_message_id (const char *, const cha
|
||||
ADDRESS *mutt_get_address (ENVELOPE *, char **);
|
||||
@ -38,7 +38,7 @@
|
||||
ADDRESS *mutt_expand_aliases (ADDRESS *);
|
||||
ADDRESS *mutt_parse_adrlist (ADDRESS *, const char *);
|
||||
|
||||
--- send.c.orig 2020-11-03 17:50:37 UTC
|
||||
--- send.c.orig 2021-01-21 20:23:24 UTC
|
||||
+++ send.c
|
||||
@@ -739,6 +739,10 @@ void mutt_fix_reply_recipients (ENVELOPE *env)
|
||||
/* the CC field can get cluttered, especially with lists */
|
||||
@ -51,9 +51,9 @@
|
||||
env->cc = mutt_remove_xrefs (env->to, env->cc);
|
||||
|
||||
if (env->cc && !env->to)
|
||||
--- sendlib.c.orig 2020-11-03 17:50:37 UTC
|
||||
--- sendlib.c.orig 2021-01-21 20:23:24 UTC
|
||||
+++ sendlib.c
|
||||
@@ -3007,6 +3007,35 @@ static void set_noconv_flags (BODY *b, short flag)
|
||||
@@ -3012,6 +3012,35 @@ static void set_noconv_flags (BODY *b, short flag)
|
||||
}
|
||||
}
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user