net-p2p/digitalcoin: cleanup
- Remove Qt build tools from runtime dependencies; - Use qt4-linguisttools instead of qt4-linguist; - Add LICENSE; - Add USES=desktop-file-utils; - Wrap lines at 80 characters; - Regen patches. PR: 201025 Submitted by: s3erios@gmail.com
This commit is contained in:
parent
fef53ed1df
commit
0e8ae25c16
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=392224
@ -3,12 +3,15 @@
|
||||
|
||||
PORTNAME= digitalcoin
|
||||
PORTVERSION= 1.0.0.0b
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= net-p2p
|
||||
|
||||
MAINTAINER= myst3r10n@rocketmail.com
|
||||
COMMENT= Alternative Bitcoin peer-to-peer currency client
|
||||
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
|
||||
libminiupnpc.so:${PORTSDIR}/net/miniupnpc
|
||||
|
||||
@ -16,13 +19,15 @@ USE_GITHUB= yes
|
||||
GH_ACCOUNT= baritus
|
||||
GH_TAGNAME= 96b098a
|
||||
|
||||
USES= gmake
|
||||
USES= desktop-file-utils gmake
|
||||
USE_OPENSSL= yes
|
||||
USE_BDB= yes
|
||||
WANT_BDB_VER= 48
|
||||
USE_QT4= corelib gui qmake_build linguist uic moc rcc
|
||||
USE_QT4= corelib gui qmake_build linguisttools_build uic_build \
|
||||
moc_build rcc_build
|
||||
|
||||
PLIST_FILES= bin/${BINARY} share/applications/digitalcoin-qt.desktop share/pixmaps/digitalcoin.png
|
||||
PLIST_FILES= bin/${BINARY} share/applications/digitalcoin-qt.desktop \
|
||||
share/pixmaps/digitalcoin.png
|
||||
|
||||
BINARY= digitalcoin-qt
|
||||
|
||||
@ -30,9 +35,11 @@ BINARY= digitalcoin-qt
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${SETENV} ${QMAKE_ENV} \
|
||||
${QMAKE} ${QMAKE_ARGS} USE_UPNP=${QMAKE_USE_UPNP} USE_QRCODE=${QMAKE_USE_QRCODE} \
|
||||
QMAKE_LRELEASE=lrelease-qt4 PREFIX=${PREFIX} INCLUDEPATH=${BDB_INCLUDE_DIR} \
|
||||
QMAKE_LIBDIR+=${BDB_LIB_DIR} ${PORTNAME}-qt.pro
|
||||
${QMAKE} ${QMAKE_ARGS} USE_UPNP=${QMAKE_USE_UPNP} \
|
||||
USE_QRCODE=${QMAKE_USE_QRCODE} \
|
||||
QMAKE_LRELEASE=lrelease-qt4 PREFIX=${PREFIX} \
|
||||
INCLUDEPATH=${BDB_INCLUDE_DIR} \
|
||||
QMAKE_LIBDIR+=${BDB_LIB_DIR} ${PORTNAME}-qt.pro
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${PREFIX}/bin
|
||||
@ -42,7 +49,9 @@ do-install:
|
||||
-e 's,Bitcoin,Digitalcoin,g' \
|
||||
-e 's,xpm,png,g' \
|
||||
-e 's,80,,g' ${WRKSRC}/contrib/debian/bitcoin-qt.desktop
|
||||
${INSTALL} ${WRKSRC}/contrib/debian/bitcoin-qt.desktop ${STAGEDIR}${PREFIX}/share/applications/digitalcoin-qt.desktop
|
||||
${INSTALL} ${WRKSRC}/src/qt/res/icons/bitcoin.png ${STAGEDIR}${PREFIX}/share/pixmaps/digitalcoin.png
|
||||
${INSTALL} ${WRKSRC}/contrib/debian/bitcoin-qt.desktop \
|
||||
${STAGEDIR}${PREFIX}/share/applications/digitalcoin-qt.desktop
|
||||
${INSTALL} ${WRKSRC}/src/qt/res/icons/bitcoin.png \
|
||||
${STAGEDIR}${PREFIX}/share/pixmaps/digitalcoin.png
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/net.cpp.orig 2014-01-18 04:31:19.000000000 +0000
|
||||
+++ src/net.cpp 2014-01-18 04:32:57.000000000 +0000
|
||||
@@ -58,7 +58,7 @@
|
||||
--- src/net.cpp.orig 2013-10-13 13:51:25 UTC
|
||||
+++ src/net.cpp
|
||||
@@ -58,7 +58,7 @@ static bool vfReachable[NET_MAX] = {};
|
||||
static bool vfLimited[NET_MAX] = {};
|
||||
static CNode* pnodeLocalHost = NULL;
|
||||
uint64 nLocalHostNonce = 0;
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- src/qt/qtipcserver.cpp.orig 2014-01-18 05:21:31.335425774 +0000
|
||||
+++ src/qt/qtipcserver.cpp 2014-01-18 05:22:33.976421840 +0000
|
||||
@@ -21,7 +21,7 @@
|
||||
--- src/qt/qtipcserver.cpp.orig 2013-10-13 13:51:25 UTC
|
||||
+++ src/qt/qtipcserver.cpp
|
||||
@@ -21,7 +21,7 @@ using namespace boost::posix_time;
|
||||
|
||||
static void ipcThread2(void* pArg);
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ./src/serialize.h.orig 2013-09-24 01:50:35.661706153 +0000
|
||||
+++ ./src/serialize.h 2013-09-24 01:50:52.913703572 +0000
|
||||
@@ -895,19 +895,6 @@
|
||||
--- src/serialize.h.orig 2013-10-13 13:51:25 UTC
|
||||
+++ src/serialize.h
|
||||
@@ -809,19 +809,6 @@ public:
|
||||
iterator insert(iterator it, const char& x=char()) { return vch.insert(it, x); }
|
||||
void insert(iterator it, size_type n, const char& x) { vch.insert(it, n, x); }
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user