Approved by:	portmgr@ (blanket approval)
This commit is contained in:
Vanilla I. Shu 2014-06-29 14:45:47 +00:00
parent a55b724678
commit 0e5f539f3f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=359769
2 changed files with 19 additions and 7 deletions

View File

@ -9,11 +9,8 @@ MASTER_SITES= http://shlang.com/stmpclean/
MAINTAINER= shalunov@shlang.com
COMMENT= Remove old files from temporary directories
MAN8= stmpclean.8
MANCOMPRESSED= no
PLIST_FILES= sbin/stmpclean
PLIST_FILES= sbin/stmpclean man/man8/stmpclean.8.gz
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s/-O6//g" ${WRKSRC}/Makefile

View File

@ -1,11 +1,26 @@
--- Makefile.orig Mon Sep 29 07:01:15 2003
+++ Makefile Mon Sep 29 07:01:23 2003
--- Makefile.orig 2003-03-22 05:58:00.000000000 +0800
+++ Makefile 2014-06-29 22:39:49.234628215 +0800
@@ -2,7 +2,7 @@
# Written by Stanislav Shalunov.
# $Id: Makefile,v 1.4 1999/08/04 18:30:02 shalunov Exp $
# $Id: Makefile,v 1.6 2003/03/21 21:58:00 shalunov Exp $
-PREFIX=/usr/local
+PREFIX?=/usr/local
BINDIR=$(PREFIX)/sbin
MANDIR=$(PREFIX)/man/man8
@@ -11,10 +11,10 @@ CFLAGS += -O6 -Wall -W -pedantic
all: stmpclean stmpclean.0
install: all
- if [ ! -d $(BINDIR) ] ; then mkdir -p -m 0755 $(BINDIR); fi
- if [ ! -d $(MANDIR) ] ; then mkdir -p -m 0755 $(MANDIR); fi
- install -c -o 0 -g 0 -m 0555 stmpclean $(BINDIR)/
- install -c -o 0 -g 0 -m 0444 stmpclean.8 $(MANDIR)/
+ if [ ! -d $(DESTDIR)$(BINDIR) ] ; then mkdir -p -m 0755 $(DESTDIR)$(BINDIR); fi
+ if [ ! -d $(DESTDIR)$(MANDIR) ] ; then mkdir -p -m 0755 $(DESTDIR)$(MANDIR); fi
+ install -c -o 0 -g 0 -m 0555 stmpclean $(DESTDIR)$(BINDIR)/
+ install -c -o 0 -g 0 -m 0444 stmpclean.8 $(DESTDIR)$(MANDIR)/
stmpclean.o: stmpclean.c