comms/fldigi: Update to 4.1.19

N.B. C-Media and udev patched out for now as very Linux specific ATM

2021-06-24  dave-w1hkj  <w1hkj@bellsouth.net>

	4032048a8: Version 4.1.19
	887420331: C-Media PTT support
	8cdda8274: LNW macro tag
	439cc2c9c: Notes
	d396d4970: lower case tx

2021-05-01  John Phelps  <kl4yfd@gmail.com>

	d2efc4f77: Vestigial AFC fixes  * Fix OFDM and 8PSK AFC jumping randomly to noise-signals
This commit is contained in:
Diane Bruce 2021-07-01 20:48:03 -04:00
parent 3e85158b5f
commit 0e0f2f5444
8 changed files with 137 additions and 4 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= fldigi
PORTVERSION= 4.1.18
PORTVERSION= 4.1.19
CATEGORIES= comms hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1611941586
SHA256 (fldigi-4.1.18.tar.gz) = 3c7fd84ab3a84ba4525b251e9d56120daee626a3831684a974fdad476f90270d
SIZE (fldigi-4.1.18.tar.gz) = 4847091
TIMESTAMP = 1625157394
SHA256 (fldigi-4.1.19.tar.gz) = 8715e7109d2a674d80b742c97743fe7cb8997166b3c6ddef622c8cd8779d6e7f
SIZE (fldigi-4.1.19.tar.gz) = 4900636

View File

@ -0,0 +1,14 @@
--- configure.ac.orig 2021-07-01 20:36:20 UTC
+++ configure.ac
@@ -309,11 +309,6 @@ AC_FLDIGI_INTL
# Set ac_cv_udev to yes/no
# Define USE_LIBHID in config.h
# Substitute LIBHID_CFLAGS and LIBHID_LIBS in Makefile
-#if test "x$ac_cv_want_fldigi" = "xyes"; then
-#AC_FLDIGI_PKG_CHECK([libhid], [libhid], [no], [no],
-# [use udev libraries @<:@autodetect@:>@],
-# [ENABLE_LIBHID])
-#fi
### asciidoc
# substitute ASCIIDOC and A2X in doc/Makefile

View File

@ -0,0 +1,11 @@
--- m4/build.m4.orig 2021-07-01 21:41:53 UTC
+++ m4/build.m4
@@ -94,7 +94,7 @@ $BFD_CFLAGS -pipe -Wall -fexceptions $OPT_CFLAGS $DEBU
else if test "x$target_mingw32" = "xyes"; then
FLDIGI_BUILD_LDADD="$FLDIGI_BUILD_LDADD -lsetupapi -lhid"
else
- FLDIGI_BUILD_LDADD="$FLDIGI_BUILD_LDADD -ludev"
+ FLDIGI_BUILD_LDADD="$FLDIGI_BUILD_LDADD"
fi
fi

View File

@ -0,0 +1,29 @@
--- src/Makefile.am.orig 2021-06-24 11:46:05 UTC
+++ src/Makefile.am
@@ -503,8 +503,6 @@ clean-local:
# Sources that we build. It is OK to have headers here.
fldigi_SOURCES += \
- cmedia/cmedia.cxx \
- cmedia/hid.cxx \
combo/combo.cxx \
config_script/create_default_script.cxx \
config_script/run_script.h \
@@ -707,9 +705,6 @@ fldigi_SOURCES += \
EXTRA_fldigi_SOURCES += \
blank/blank.cxx \
blank/blank.h \
- cmedia/hid_lin.cxx \
- cmedia/hid_mac.cxx \
- cmedia/hid_win.cxx \
dialogs/fl_digi_main.cxx \
dxcluster/arc-help.cxx \
dxcluster/CCC_Commands.cxx \
@@ -762,7 +757,6 @@ EXTRA_fldigi_SOURCES += \
include/calendar.h \
include/charsetdistiller.h \
include/charsetlist.h \
- include/cmedia.h \
include/colorbox.h \
include/combo.h \
include/complex.h \

View File

@ -0,0 +1,29 @@
--- src/dialogs/confdialog.cxx.orig 2021-06-24 11:46:05 UTC
+++ src/dialogs/confdialog.cxx
@@ -7447,7 +7447,7 @@ btn_init_cmedia_PTT->labelcolor(FL_RED);
btn_init_cmedia_PTT->redraw();
} else {
progdefaults.cmedia_ptt = false;
-close_cmedia();
+//close_cmedia();
}
progdefaults.changed = true;
}
@@ -7455,7 +7455,7 @@ progdefaults.changed = true;
Fl_ComboBox *inp_cmedia_dev=(Fl_ComboBox *)0;
static void cb_inp_cmedia_dev(Fl_ComboBox* o, void*) {
- close_cmedia();
+// close_cmedia();
progdefaults.cmedia_device = o->value();
btn_init_cmedia_PTT->labelcolor(FL_RED);
btn_init_cmedia_PTT->redraw();
@@ -7479,7 +7479,7 @@ progdefaults.changed = true;
Fl_Button *btn_test_cmedia=(Fl_Button *)0;
static void cb_btn_test_cmedia(Fl_Button*, void*) {
- test_hid_ptt();
+// test_hid_ptt();
}
Fl_File_Input *inp_wav_fname_regex=(Fl_File_Input *)0;

View File

@ -0,0 +1,11 @@
--- src/main.cxx.orig 2021-07-01 19:46:20 UTC
+++ src/main.cxx
@@ -1165,7 +1165,7 @@ int main(int argc, char ** argv)
setTabColors();
progdefaults.testCommPorts();
- init_hids();
+ //init_hids();
#if USE_HAMLIB
xcvr = new Rig();

View File

@ -0,0 +1,39 @@
--- src/rigcontrol/ptt.cxx.orig 2021-07-01 19:51:31 UTC
+++ src/rigcontrol/ptt.cxx
@@ -69,7 +69,7 @@
#include "n3fjp_logger.h"
-#include "cmedia.h"
+//#include "cmedia.h"
LOG_FILE_SOURCE(debug::LOG_RIGCONTROL);
@@ -116,9 +116,11 @@ void PTT::reset(ptt_t dev)
case PTT_TTY:
open_tty();
break;
+#if 0
case PTT_CMEDIA:
cmedia_fd = open_cmedia(progdefaults.cmedia_device);
break;
+#endif
default:
break; // nothing to open
}
@@ -174,6 +176,7 @@ void PTT::set(bool ptt)
set_uhrouter(ptt);
break;
#endif
+#if 0
case PTT_CMEDIA:
if (cmedia_fd != -1) {
int bitnbr = 2;
@@ -184,6 +187,7 @@ void PTT::set(bool ptt)
set_cmedia(bitnbr, ptt);
}
break;
+#endif
default:
{
set_gpio(ptt);