- Move net-im/gaim-hotkeys -> net-im/pidgin-hotkeys because project was renamed
according the rename of gaim project to pidgin - Update to 0.2.3 Repocopied by: marcus@
This commit is contained in:
parent
bcb6b89911
commit
0debb1dc46
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=192180
1
MOVED
1
MOVED
@ -2961,4 +2961,5 @@ x11-servers/xorg-fontserver|x11-fonts/xfs|2007-05-19|Rename to follow X.org name
|
||||
x11/xlibs|xorg-libraries|2007-05-25|Replaced by x11/xorg-libraries
|
||||
multimedia/ffmpeg-devel|multimedia/ffmpeg|2007-05-25|Merged multimedia/ffmpeg-devel into multimedia/ffmpeg
|
||||
devel/wfut||2007-05-27|Obsolete
|
||||
net-im/gaim-hotkeys|net-im/pidgin-hotkeys|2007-05-28|Project renamed
|
||||
|
||||
|
@ -27,7 +27,6 @@
|
||||
SUBDIR += gaim-bangexec
|
||||
SUBDIR += gaim-extprefs
|
||||
SUBDIR += gaim-guifications
|
||||
SUBDIR += gaim-hotkeys
|
||||
SUBDIR += gaim-ignorance
|
||||
SUBDIR += gaim-latex
|
||||
SUBDIR += gaim-openq
|
||||
@ -96,6 +95,7 @@
|
||||
SUBDIR += p5-POE-Component-Client-MSN
|
||||
SUBDIR += pebrot
|
||||
SUBDIR += pidgin
|
||||
SUBDIR += pidgin-hotkeys
|
||||
SUBDIR += pork
|
||||
SUBDIR += py-msnp
|
||||
SUBDIR += py-pyxmpp
|
||||
|
@ -1,27 +0,0 @@
|
||||
# New ports collection makefile for: gaim-hotkeys
|
||||
# Date created: 2006-11-23
|
||||
# Whom: garga
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gaim-hotkeys
|
||||
PORTVERSION= 0.2.2
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net-im
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= garga@FreeBSD.org
|
||||
COMMENT= A gaim plugin that allows user to assign global hotkeys
|
||||
|
||||
LIB_DEPENDS= purple.0:${PORTSDIR}/net-im/libpurple
|
||||
BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
|
||||
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
|
||||
|
||||
USE_GNOME= pkgconfig gtk20
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
PLIST_FILES= lib/pidgin/hotkeys.so \
|
||||
lib/pidgin/hotkeys.la
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (gaim-hotkeys-0.2.2.tar.gz) = 9c413e3e1a4a56f004792794a277cae0
|
||||
SHA256 (gaim-hotkeys-0.2.2.tar.gz) = 2004a89f45af5fc8eb01c53a3def935a59e9ee296bafe26e755fb4bcecda6239
|
||||
SIZE (gaim-hotkeys-0.2.2.tar.gz) = 341544
|
@ -1,12 +0,0 @@
|
||||
--- ../gaim-hotkeys-0.2.2.orig/configure Mon May 7 09:02:50 2007
|
||||
+++ configure Mon May 7 09:03:46 2007
|
||||
@@ -19868,7 +19868,7 @@
|
||||
|
||||
|
||||
gtk_modules="gtk+-2.0 >= 2.4.0"
|
||||
-gaim_modules="gaim >= 2.0.0"
|
||||
+gaim_modules="pidgin >= 2.0.0"
|
||||
|
||||
|
||||
if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
||||
diff -ruN ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c ./src/hotkeys.c
|
@ -1,11 +0,0 @@
|
||||
--- ../gaim-hotkeys-0.2.2.orig/src/Makefile.in Mon May 7 09:02:50 2007
|
||||
+++ src/Makefile.in Mon May 7 09:20:48 2007
|
||||
@@ -220,7 +220,7 @@
|
||||
target_cpu = @target_cpu@
|
||||
target_os = @target_os@
|
||||
target_vendor = @target_vendor@
|
||||
-plugindir = $(libdir)/gaim
|
||||
+plugindir = $(libdir)/pidgin
|
||||
hotkeys_la_LDFLAGS = -module -avoid-version $(am__append_1)
|
||||
hotkeys_la_LIBADD = $(GAIM_LIBS) $(GTK_LIBS) $(am__append_2)
|
||||
plugin_LTLIBRARIES = hotkeys.la
|
@ -1,34 +0,0 @@
|
||||
--- ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c Mon May 7 09:02:50 2007
|
||||
+++ src/hotkeys.c Mon May 7 09:20:48 2007
|
||||
@@ -22,15 +22,21 @@
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
|
||||
#define GAIM_PLUGINS
|
||||
-#include <gaim.h>
|
||||
-#include <gaim/version.h>
|
||||
-#include <gaim/debug.h>
|
||||
-#include <gaim/gtkblist.h>
|
||||
-#include <gaim/gtkplugin.h>
|
||||
-#include <gaim/gtkutils.h>
|
||||
-#include <gaim/gtkdialogs.h>
|
||||
-#include <gaim/gtkprefs.h>
|
||||
-#include <gaim/gtkaccount.h>
|
||||
+#include <pidgin.h>
|
||||
+
|
||||
+#include <libpurple/gaim-compat.h>
|
||||
+#include <libpurple/conversation.h>
|
||||
+#include <libpurple/debug.h>
|
||||
+#include <libpurple/version.h>
|
||||
+
|
||||
+#include <pidgin/gtkgaim-compat.h>
|
||||
+#include <pidgin/gtkconv.h>
|
||||
+#include <pidgin/gtkblist.h>
|
||||
+#include <pidgin/gtkplugin.h>
|
||||
+#include <pidgin/gtkutils.h>
|
||||
+#include <pidgin/gtkdialogs.h>
|
||||
+#include <pidgin/gtkprefs.h>
|
||||
+#include <pidgin/gtkaccount.h>
|
||||
|
||||
#ifdef GDK_WINDOWING_X11
|
||||
#include <X11/keysym.h>
|
||||
diff -ruN ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c ./src/hotkeys.c
|
@ -1,6 +0,0 @@
|
||||
A gaim plugin that allows user to assign global hotkeys (e.g. Ctrl+Alt+g) for
|
||||
togglling buddy list and reading queued message. When "Toggle List" hotkey is
|
||||
enabled, it makes the buddy list hidden from your taskbar and task switcher
|
||||
(similar to ICQ).
|
||||
|
||||
WWW: http://sourceforge.net/projects/gaim-hotkeys/
|
@ -1,15 +1,15 @@
|
||||
# New ports collection makefile for: gaim-hotkeys
|
||||
# New ports collection makefile for: pidgin-hotkeys
|
||||
# Date created: 2006-11-23
|
||||
# Whom: garga
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= gaim-hotkeys
|
||||
PORTVERSION= 0.2.2
|
||||
PORTREVISION= 2
|
||||
PORTNAME= pidgin-hotkeys
|
||||
PORTVERSION= 0.2.3
|
||||
CATEGORIES= net-im
|
||||
MASTER_SITES= SF
|
||||
MASTER_SITE_SUBDIR= gaim-hotkeys
|
||||
|
||||
MAINTAINER= garga@FreeBSD.org
|
||||
COMMENT= A gaim plugin that allows user to assign global hotkeys
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (gaim-hotkeys-0.2.2.tar.gz) = 9c413e3e1a4a56f004792794a277cae0
|
||||
SHA256 (gaim-hotkeys-0.2.2.tar.gz) = 2004a89f45af5fc8eb01c53a3def935a59e9ee296bafe26e755fb4bcecda6239
|
||||
SIZE (gaim-hotkeys-0.2.2.tar.gz) = 341544
|
||||
MD5 (pidgin-hotkeys-0.2.3.tar.gz) = d52990ef934f396424dc61b5bc33d97d
|
||||
SHA256 (pidgin-hotkeys-0.2.3.tar.gz) = 007a20d14a54d4bf6f36c1060db26bff0532b65be866a524ecf668301864297a
|
||||
SIZE (pidgin-hotkeys-0.2.3.tar.gz) = 340170
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- ../gaim-hotkeys-0.2.2.orig/configure Mon May 7 09:02:50 2007
|
||||
+++ configure Mon May 7 09:03:46 2007
|
||||
@@ -19868,7 +19868,7 @@
|
||||
|
||||
|
||||
gtk_modules="gtk+-2.0 >= 2.4.0"
|
||||
-gaim_modules="gaim >= 2.0.0"
|
||||
+gaim_modules="pidgin >= 2.0.0"
|
||||
|
||||
|
||||
if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
|
||||
diff -ruN ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c ./src/hotkeys.c
|
@ -1,11 +0,0 @@
|
||||
--- ../gaim-hotkeys-0.2.2.orig/src/Makefile.in Mon May 7 09:02:50 2007
|
||||
+++ src/Makefile.in Mon May 7 09:20:48 2007
|
||||
@@ -220,7 +220,7 @@
|
||||
target_cpu = @target_cpu@
|
||||
target_os = @target_os@
|
||||
target_vendor = @target_vendor@
|
||||
-plugindir = $(libdir)/gaim
|
||||
+plugindir = $(libdir)/pidgin
|
||||
hotkeys_la_LDFLAGS = -module -avoid-version $(am__append_1)
|
||||
hotkeys_la_LIBADD = $(GAIM_LIBS) $(GTK_LIBS) $(am__append_2)
|
||||
plugin_LTLIBRARIES = hotkeys.la
|
@ -1,34 +0,0 @@
|
||||
--- ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c Mon May 7 09:02:50 2007
|
||||
+++ src/hotkeys.c Mon May 7 09:20:48 2007
|
||||
@@ -22,15 +22,21 @@
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
|
||||
#define GAIM_PLUGINS
|
||||
-#include <gaim.h>
|
||||
-#include <gaim/version.h>
|
||||
-#include <gaim/debug.h>
|
||||
-#include <gaim/gtkblist.h>
|
||||
-#include <gaim/gtkplugin.h>
|
||||
-#include <gaim/gtkutils.h>
|
||||
-#include <gaim/gtkdialogs.h>
|
||||
-#include <gaim/gtkprefs.h>
|
||||
-#include <gaim/gtkaccount.h>
|
||||
+#include <pidgin.h>
|
||||
+
|
||||
+#include <libpurple/gaim-compat.h>
|
||||
+#include <libpurple/conversation.h>
|
||||
+#include <libpurple/debug.h>
|
||||
+#include <libpurple/version.h>
|
||||
+
|
||||
+#include <pidgin/gtkgaim-compat.h>
|
||||
+#include <pidgin/gtkconv.h>
|
||||
+#include <pidgin/gtkblist.h>
|
||||
+#include <pidgin/gtkplugin.h>
|
||||
+#include <pidgin/gtkutils.h>
|
||||
+#include <pidgin/gtkdialogs.h>
|
||||
+#include <pidgin/gtkprefs.h>
|
||||
+#include <pidgin/gtkaccount.h>
|
||||
|
||||
#ifdef GDK_WINDOWING_X11
|
||||
#include <X11/keysym.h>
|
||||
diff -ruN ../gaim-hotkeys-0.2.2.orig/src/hotkeys.c ./src/hotkeys.c
|
@ -1,4 +1,4 @@
|
||||
A gaim plugin that allows user to assign global hotkeys (e.g. Ctrl+Alt+g) for
|
||||
A pidgin plugin that allows user to assign global hotkeys (e.g. Ctrl+Alt+g) for
|
||||
togglling buddy list and reading queued message. When "Toggle List" hotkey is
|
||||
enabled, it makes the buddy list hidden from your taskbar and task switcher
|
||||
(similar to ICQ).
|
||||
|
Loading…
Reference in New Issue
Block a user