Remove expired port:

2017-09-21 mail/milter-greylist-devel: mail/milter-greylist provides same version and options
This commit is contained in:
Rene Ladan 2017-09-22 10:19:41 +00:00
parent 1a77a24dca
commit 0de6f9f672
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450348
10 changed files with 1 additions and 260 deletions

1
MOVED
View File

@ -9546,3 +9546,4 @@ devel/cmake-modules||2017-09-14|Deleted, merged into devel/cmake
devel/cargo|lang/rust|2017-09-15|Merged with lang/rust
sysutils/filelight-kde4|sysutils/filelight|2017-09-16|Renamed to sysutils/filelight
security/gnupg22|security/gnupg|2017-09-19|Removed, security/gnupg is now gnupg22
mail/milter-greylist-devel|mail/milter-greylist|2017-09-22|Has expired: mail/milter-greylist provides same version and options

View File

@ -238,7 +238,6 @@
SUBDIR += milter-bogom
SUBDIR += milter-callback
SUBDIR += milter-greylist
SUBDIR += milter-greylist-devel
SUBDIR += milter-manager
SUBDIR += milter-regex
SUBDIR += milter-skem

View File

@ -1,121 +0,0 @@
# Created by: Cyril Guibourg
# $FreeBSD$
PORTNAME= milter-greylist
PORTVERSION= 4.6.2
CATEGORIES= mail
MASTER_SITES= ftp://ftp.espci.fr/pub/milter-greylist/ \
http://fossies.org/unix/privat/ \
ftp://ftpmirror.uk/freebsd-ports/milter-greylist/
PKGNAMESUFFIX= -devel
MAINTAINER= freebsd-ports@dan.me.uk
COMMENT= Unstable (dev) greylist milter for sendmail and postfix
LICENSE= BSD3CLAUSE
CONFLICTS= milter-greylist-[0-9]*.*
PKGMESSAGE= ${WRKDIR}/pkg-message
DEPRECATED= mail/milter-greylist provides same version and options
EXPIRATION_DATE= 2017-09-21
USES= tar:tgz
MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= DKIM SPF GEOIP CURL LDAP P0F POSTFIX DOCS EXAMPLES
OPTIONS_DEFAULT=DKIM SPF GEOIP CURL
DKIM_DESC= Include DKIM support
SPF_DESC= Include SPF support
CURL_DESC= curl support
P0F_DESC= P0F support
POSTFIX_DESC= Use Postfix instead of Sendmail
DKIM_LIB_DEPENDS+= libopendkim.so:mail/opendkim
P0F_RUN_DEPENDS+= p0f:net-mgmt/p0f
SPF_LIB_DEPENDS+= libspf2.so:mail/libspf2
CURL_LIB_DEPENDS+= libcurl.so:ftp/curl
GEOIP_LIB_DEPENDS+= libGeoIP.so:net/GeoIP
POSTFIX_CONFIGURE_ENABLE= postfix
P0F_CONFIGURE_ENABLE= p0f306
.include <bsd.port.options.mk>
##
# Use the following quirks to choose which sendmail to use (ports or system):
#
# WITH_SENDMAIL_BASE=yes
# or
# WITH_SENDMAIL_PORT=yes
#
# If unspecified, check for an up-to-date system version but give an
# installed port preference over it.
##
.if ${PORT_OPTIONS:MDKIM}
CONFIGURE_ARGS+= --with-libopendkim=${LOCALBASE}
USES+= ssl
.endif
.if ${PORT_OPTIONS:MSPF}
CONFIGURE_ARGS+= --with-libspf2=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MGEOIP}
CONFIGURE_ARGS+= --with-libGeoIP=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MCURL}
CONFIGURE_ARGS+= --with-libcurl=${LOCALBASE}
.endif
.if ${PORT_OPTIONS:MLDAP}
# We can't use LDAP_CONFIGURE_WITH because configure script is buggy
CONFIGURE_ARGS+= --with-openldap
USE_OPENLDAP= yes
.endif
.if ! ${PORT_OPTIONS:MPOSTFIX}
LDFLAGS+= ${SENDMAIL_LDFLAGS}
LIBS+= ${SENDMAIL_LDADD}
.endif
LIBS+= -lpthread
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-user=mailnull \
--with-libmilter=${MILTERBASE} \
--enable-dnsrbl \
--with-thread-safe-resolver \
--with-dumpfile=/var/milter-greylist/greylist.db
ALL_TARGET= milter-greylist
SUB_FILES+= pkg-message
USE_RC_SUBR= milter-greylist
PORTDOCS= README
PORTEXAMPLES= greylist.conf
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/mail
${INSTALL_MAN} ${WRKSRC}/greylist.conf.5 \
${STAGEDIR}${PREFIX}/man/man5
${INSTALL_MAN} ${WRKSRC}/milter-greylist.8 \
${STAGEDIR}${PREFIX}/man/man8
${INSTALL_PROGRAM} ${WRKSRC}/milter-greylist \
${STAGEDIR}${PREFIX}/libexec/
${INSTALL_DATA} ${WRKSRC}/greylist.conf \
${STAGEDIR}${PREFIX}/etc/mail/greylist.conf.sample
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/greylist.conf ${STAGEDIR}${EXAMPLESDIR}
.endif
@${MKDIR} ${STAGEDIR}/var/milter-greylist
.include "${.CURDIR}/../sendmail/bsd.milter.mk"
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1481015765
SHA256 (milter-greylist-4.6.2.tgz) = 5405a71bc8273848a1e14cecc010b95491e754307b005c96d35081ab2f9b8bd5
SIZE (milter-greylist-4.6.2.tgz) = 255102

View File

@ -1,33 +0,0 @@
#!/bin/sh
# $FreeBSD$
# PROVIDE: miltergreylist
# REQUIRE: LOGIN
# BEFORE: sendmail
# KEYWORD: milter-greylist
# Define these miltergreylist_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/miltergreylist
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
. /etc/rc.subr
name="miltergreylist"
rcvar=miltergreylist_enable
command="%%PREFIX%%/libexec/milter-greylist"
load_rc_config $name
miltergreylist_enable=${miltergreylist_enable-"NO"}
miltergreylist_runas=${miltergreylist_runas-"smmsp"}
miltergreylist_pidfile=${miltergreylist_pidfile-"/var/run/milter-greylist.pid"}
miltergreylist_sockfile=${miltergreylist_sockfile-"/var/milter-greylist/milter-greylist.sock"}
miltergreylist_cfgfile=${miltergreylist_cfgfile-"%%PREFIX%%/etc/mail/greylist.conf"}
miltergreylist_flags=${miltergreylist_flags-"-P $miltergreylist_pidfile \
-f $miltergreylist_cfgfile -p $miltergreylist_sockfile -u $miltergreylist_runas"}
run_rc_command "$1"

View File

@ -1,47 +0,0 @@
--- greylist.conf.orig 2013-08-13 13:45:08.000000000 +0100
+++ greylist.conf 2015-07-21 22:04:55.635321889 +0100
@@ -9,8 +9,10 @@
socket "/var/milter-greylist/milter-greylist.sock"
dumpfile "/var/milter-greylist/greylist.db" 600
dumpfreq 1
-user "smmsp"
-
+user "mailnull"
+# If you're using GeoIP, uncomment below to point to the GeoIP database to use
+# this one is from the net/GeoIP port/package:
+#geoipdb "/usr/local/share/GeoIP/GeoIP.dat"
# Log milter-greylist activity to a file
#stat ">>/var/milter-greylist/greylist.log" \
@@ -108,6 +110,13 @@
user3@example.com \
}
+# Example GeoIP exceptions (remember to enable it in the access list section too)
+#list "whitelist_countries" geoip { \
+# "GB" \
+# "UK" \
+# "IE" \
+#}
+
# Give this a try if you enabled DNSRBL
#dnsrbl "SORBS DUN" dnsbl.sorbs.net 127.0.0.10
#dnsrbl "SBL" sbl-xbl.spamhaus.org 127.0.0.2
@@ -129,6 +138,9 @@
# And here is the access list
racl whitelist list "my network"
racl whitelist list "broken mta"
+#racl whitelist list "whitelist_countries"
+# To disable greylisting for SPF pass emails, uncomment below:
+#racl whitelist spf pass
#racl whitelist dnsrbl "MTAWL"
#racl blacklist urlcheck "userpref" $usrRBL "CBL" dnsrbl "CBL" \
# msg "Sender IP caught in CBL blacklist"
@@ -143,3 +155,7 @@
# Example of content filtering for fighting image SPAM
#dacl blacklist body /src[:blank:]*=(3D)?[:blank:]*["']?[:blank:]*cid:/ \
# msg "Sorry, We do not accept images embedded in HTML"
+
+# Example whitelist for DKIM passed messages (uncomment below)
+#dacl whitelist dkim pass
+

View File

@ -1,25 +0,0 @@
--- ldapcheck.c.orig 2009-04-09 05:26:46.000000000 +0200
+++ ldapcheck.c 2009-10-23 23:57:42.000000000 +0200
@@ -58,6 +58,22 @@
#include "prop.h"
#include "ldapcheck.h"
+#ifndef SIMPLEQ_HEAD
+# define SIMPLEQ_HEAD STAILQ_HEAD
+# define SIMPLEQ_HEAD_INITIALIZER STAILQ_HEAD_INITIALIZER
+# define SIMPLEQ_ENTRY STAILQ_ENTRY
+# define SIMPLEQ_INIT STAILQ_INIT
+# define SIMPLEQ_INSERT_HEAD STAILQ_INSERT_HEAD
+# define SIMPLEQ_INSERT_TAIL STAILQ_INSERT_TAIL
+# define SIMPLEQ_INSERT_AFTER STAILQ_INSERT_AFTER
+# define SIMPLEQ_REMOVE_HEAD STAILQ_REMOVE_HEAD
+# define SIMPLEQ_FOREACH STAILQ_FOREACH
+# define SIMPLEQ_EMPTY STAILQ_EMPTY
+# define SIMPLEQ_FIRST STAILQ_FIRST
+# define SIMPLEQ_NEXT STAILQ_NEXT
+# define SIMPLEQ_REMOVE STAILQ_REMOVE
+#endif
+
struct ldapconf_entry {
char *lc_url;
char *lc_dn;

View File

@ -1,14 +0,0 @@
------------------------------------------------------------------------
IMPORTANT NOTE
A sample configuration file has been installed in %%PREFIX%%/etc/mail
directory. Copy and edit it to suit your needs before launching
milter-greylist.
To run milter-greylist from startup, add miltergreylist_enable="YES"
in your /etc/rc.conf or your /etc/rc.conf.local
See %%DOCSDIR%%/README for operation details.
------------------------------------------------------------------------

View File

@ -1,11 +0,0 @@
This is a port of Emmanuel Dreyfus' milter-greylist.
Grey listing is a wonderful spam filtering technique, which uses a behavior
trick: spammers never resend a message when they get a temporary error,
whereas real MTA do. The idea is to refuse any mail on first attempt, and
accept it after some time has elapsed.
milter-greylist is a stand-alone milter written in C that implement grey
listing.
WWW: http://hcpnet.free.fr/milter-greylist/

View File

@ -1,5 +0,0 @@
libexec/milter-greylist
man/man5/greylist.conf.5.gz
man/man8/milter-greylist.8.gz
etc/mail/greylist.conf.sample
@dir(mailnull,mailnull,) /var/milter-greylist