Update to 1.8.3.
PR: 210792 Submitted by: tkato432 yahoo com Sponsored by: Absolight
This commit is contained in:
parent
d0008d15a2
commit
0dcd0ddaf0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418022
@ -2,94 +2,50 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= tuxtype
|
||||
PORTVERSION= 1.8.1
|
||||
PORTREVISION= 7
|
||||
PORTVERSION= 1.8.3
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= http://alioth.debian.org/frs/download.php/3270/ \
|
||||
http://alioth.debian.org/frs/download.php/3540/:t4k_common
|
||||
DISTFILES= ${PORTNAME}_w_fonts-${PORTVERSION}${EXTRACT_SUFX} \
|
||||
${T4K_DISTFILE}:t4k_common
|
||||
MASTER_SITES= DEBIAN_POOL
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Educational typing tutor starring Tux the Linux Penguin
|
||||
|
||||
BROKEN= unfetchable
|
||||
DEPRECATED= Broken for more than 6 months
|
||||
EXPIRATION_DATE= 2016-07-04
|
||||
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
BUILD_DEPENDS= gsed:textproc/gsed
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}_w_fonts-${PORTVERSION}
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
USES= gmake iconv perl5 pkgconfig
|
||||
USES= autoreconf gettext gmake iconv localbase perl5 pkgconfig
|
||||
USE_GNOME= libxml2
|
||||
USE_SDL= image mixer net pango sdl
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --localstatedir=/var/games
|
||||
CONFIGURE_ENV= T4K_COMMON_CFLAGS="-I${T4K_WRKSRC}/src" \
|
||||
T4K_COMMON_LIBS="${T4K_WRKSRC}/src/.libs/libt4k_common.a" \
|
||||
ac_cv_lib_m_csin=yes
|
||||
CONFIGURE_ENV= ac_cv_lib_m_csin=yes
|
||||
|
||||
CPPFLAGS+= $$(pkg-config --cflags SDL_Pango) -I${LOCALBASE}/include \
|
||||
-DHAVE_ALPHASORT -DHAVE_SCANDIR -DHAVE_FSYNC -DICONV_CONST=""
|
||||
LDFLAGS+= $$(pkg-config --libs SDL_Pango) -L${LOCALBASE}/lib ${ICONV_LIB}
|
||||
CPPFLAGS+= -I${ICONV_INCLUDE_PATH}
|
||||
LDFLAGS+= ${ICONV_LIB_PATH}
|
||||
|
||||
OPTIONS_DEFINE= DOCS NLS SVG
|
||||
DESKTOP_ENTRIES="TuxType" "" "${DATADIR}/images/icons/icon.png" \
|
||||
"tuxtype" "" ""
|
||||
|
||||
OPTIONS_DEFINE= DOCS SVG
|
||||
OPTIONS_DEFAULT= SVG
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
NLS_USES= gettext
|
||||
NLS_CONFIGURE_ENABLE= nls
|
||||
SVG_USE_GNOME= librsvg2
|
||||
SVG_USE= gnome=librsvg2
|
||||
SVG_CONFIGURE_WITH= rsvg
|
||||
|
||||
T4K_NAME= t4k_common
|
||||
T4K_VERSION= 0.1.1
|
||||
T4K_DISTFILE= ${T4K_NAME}-${T4K_VERSION}${EXTRACT_SUFX}
|
||||
T4K_WRKSRC= ${WRKDIR}/${T4K_NAME}-${T4K_VERSION}
|
||||
|
||||
post-extract:
|
||||
@${LN} -sf ${T4K_WRKSRC} ${WRKDIR}/${T4K_NAME}
|
||||
|
||||
post-patch:
|
||||
.for i in convert_utf.h mysetenv.h practice.c
|
||||
@${ECHO_CMD} >> ${WRKSRC}/src/${i}
|
||||
.endfor
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/-R$$found_dir/s|^|#|' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/[[:blank:]]VERSION/d' ${WRKSRC}/config.h.in
|
||||
@${REINPLACE_CMD} -e \
|
||||
'/doc[[:blank:]]/d' ${WRKSRC}/Makefile.in
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|/bin/bash|/bin/sh| ; \
|
||||
s|^sed |gsed |' ${WRKSRC}/data/scripts/sed-linux.sh
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|-Wall -g |-Wall | ; \
|
||||
s|-DDEBUG ||' ${WRKSRC}/src/Makefile.in
|
||||
@${REINPLACE_CMD} -e \
|
||||
's|<iconv.h>|"config.h"| ; \
|
||||
/<libintl.h>/d' ${WRKSRC}/src/globals.h
|
||||
@${FIND} ${WRKSRC}/data -name "sed-linux.sh" | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|/bin/bash|/bin/sh|; s|^sed |gsed |'
|
||||
@${REINPLACE_CMD} -e 's|\.\.\/ABOUT-NLS ||; s|COPYING ||; s|INSTALL ||' \
|
||||
${WRKSRC}/doc/Makefile.am
|
||||
@${REINPLACE_CMD} -e 's|-Wall -g |-Wall |; s|-DDEBUG ||' \
|
||||
${WRKSRC}/src/Makefile.am
|
||||
|
||||
pre-configure:
|
||||
@(cd ${T4K_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./configure \
|
||||
--disable-shared ${CONFIGURE_ARGS} CC="${CC}" CXX="${CXX}" \
|
||||
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" \
|
||||
CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}")
|
||||
|
||||
pre-build:
|
||||
@(cd ${T4K_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
|
||||
${MAKEFILE} -j${MAKE_JOBS_NUMBER} ${ALL_TARGET})
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for i in AUTHORS ChangeLog OFL README TODO
|
||||
(cd ${WRKSRC}/doc && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
|
||||
.endfor
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}/en
|
||||
(cd ${WRKSRC}/doc/en && ${INSTALL_DATA} *.html ${STAGEDIR}${DOCSDIR}/en)
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's|-R${LOCALBASE}/lib||' ${WRKSRC}/src/Makefile
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,4 +1,2 @@
|
||||
SHA256 (tuxtype_w_fonts-1.8.1.tar.gz) = 2687b858679b4f0b4f42204211d162234568198544bd95a9b71ec96e788d1481
|
||||
SIZE (tuxtype_w_fonts-1.8.1.tar.gz) = 11528002
|
||||
SHA256 (t4k_common-0.1.1.tar.gz) = 42c155816dae2c5dad560faa50edaa1ca84536530283d37859c4b91e82675110
|
||||
SIZE (t4k_common-0.1.1.tar.gz) = 629215
|
||||
SHA256 (tuxtype_1.8.3.orig.tar.gz) = e720b0a3131764630a8b8d0bd108e0aed6f72572222a3529a4cbed04f94c8fb3
|
||||
SIZE (tuxtype_1.8.3.orig.tar.gz) = 11964078
|
||||
|
@ -1,15 +1,17 @@
|
||||
--- Makefile.in.orig 2014-12-02 21:50:06.000000000 +0300
|
||||
+++ Makefile.in 2014-12-02 21:52:09.000000000 +0300
|
||||
@@ -776,10 +776,9 @@
|
||||
--- Makefile.am.orig 2014-08-20 03:55:27 UTC
|
||||
+++ Makefile.am
|
||||
@@ -44,12 +44,10 @@ uninstall-local:
|
||||
# on upgrade?:
|
||||
install-data-hook:
|
||||
# Global configuration (e.g. /etc/tuxtype):
|
||||
$(MKDIR_P) -m 755 $(DESTDIR)$(pkgsysconfdir)
|
||||
- $(MKDIR_P) -m 755 $(DESTDIR)$(pkgsysconfdir)
|
||||
+ $(MKDIR_P) $(DESTDIR)$(pkgsysconfdir)
|
||||
# Global sites for game state data (e.g. /var/games/tuxtype):
|
||||
- $(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir)
|
||||
- $(MKDIR_P) -m 2755 $(DESTDIR)$(pkglocalstatedir)/words
|
||||
+ $(MKDIR_P) $(DESTDIR)$(pkglocalstatedir)
|
||||
+ $(MKDIR_P) $(DESTDIR)$(pkglocalstatedir)/words
|
||||
# chown root:games $(DESTDIR)$(pkglocalstatedir)
|
||||
- chown root:games $(DESTDIR)$(pkglocalstatedir)/words
|
||||
|
||||
|
||||
uninstall-hook:
|
||||
rm -rf $(DESTDIR)$(pkglocalstatedir)/words
|
26
games/tuxtype/files/patch-configure.ac
Normal file
26
games/tuxtype/files/patch-configure.ac
Normal file
@ -0,0 +1,26 @@
|
||||
--- configure.ac.orig 2014-08-20 03:55:27 UTC
|
||||
+++ configure.ac
|
||||
@@ -246,23 +246,6 @@ LIBS="$LIBS $XML2_LIBS"
|
||||
|
||||
|
||||
|
||||
-dnl libt4kcommon is now required: --------------------------------------------
|
||||
-
|
||||
-PKG_CHECK_MODULES([T4K_COMMON],
|
||||
- [t4k_common],
|
||||
- [],
|
||||
- [AC_MSG_NOTICE([t4k_common not located by pkg-config, checking with AC CHECK LIB:])
|
||||
- AC_CHECK_LIB([t4k_common],
|
||||
- [InitT4KCommon],
|
||||
- [],
|
||||
- [AC_MSG_ERROR([libt4k_common is required: git://git.debian.org/tux4kids/t4kcommon.git])])])
|
||||
-
|
||||
-AC_DEFINE([HAVE_LIBT4K_COMMON],[1],[Define to 1 if you have the `t4k_common` library])
|
||||
-CFLAGS="$CFLAGS $T4K_COMMON_CFLAGS"
|
||||
-LIBS="$LIBS $T4K_COMMON_LIBS"
|
||||
-
|
||||
-
|
||||
-
|
||||
# --------------------------------------------------------------------------------------
|
||||
# Checks for header files.
|
||||
# --------------------------------------------------------------------------------------
|
@ -1,18 +0,0 @@
|
||||
--- ../t4k_common/src/t4k_loaders.c.orig 2011-04-08 11:46:07.000000000 +0900
|
||||
+++ ../t4k_common/src/t4k_loaders.c 2012-06-17 18:57:09.000000000 +0900
|
||||
@@ -1028,12 +1028,9 @@
|
||||
{
|
||||
png_init_io(png_ptr, fi);
|
||||
|
||||
- info_ptr->width = surf->w;
|
||||
- info_ptr->height = surf->h;
|
||||
- info_ptr->bit_depth = 8;
|
||||
- info_ptr->color_type = PNG_COLOR_TYPE_RGB_ALPHA;
|
||||
- info_ptr->interlace_type = 1;
|
||||
- info_ptr->valid = 0; /* will be updated by various png_set_FOO() functions */
|
||||
+ png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8,
|
||||
+ PNG_COLOR_TYPE_RGB_ALPHA, 1,
|
||||
+ PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
|
||||
|
||||
png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr,
|
||||
PNG_sRGB_INTENT_PERCEPTUAL);
|
@ -4,47 +4,56 @@
|
||||
%%PORTDOCS%%%%DOCSDIR%%/OFL
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/en/howtotheme.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/en/lesson_scripting_reference.html
|
||||
%%NLS%%share/locale/ar/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/as/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/ast/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/ca/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/cs/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/da/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/de/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/el/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/en@boldquot/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/en@quot/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/en_GB/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/es/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/eu/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/fi/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/fr/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/gu/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/hi/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/it/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/ja/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/kn/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/lt/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/ml/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/nb/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/ne/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/nl/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/nn/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/or/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/pt/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/ru/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/sv/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/sw/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/ta/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/te/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/tr/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/wo/LC_MESSAGES/tuxtype.mo
|
||||
%%NLS%%share/locale/zh_N/LC_MESSAGES/tuxtype.mo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TuxType_port_Mac.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/howtotheme.html
|
||||
%%PORTDOCS%%%%DOCSDIR%%/lesson_scripting_reference.html
|
||||
share/locale/ar/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/as/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ast/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/be/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ca/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/cs/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/da/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/de/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/el/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/en@boldquot/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/en@quot/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/en_GB/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/es/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/eu/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/fi/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/fr/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/gu/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/he/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/hi/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/hu/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/it/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ja/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/kn/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ko/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/lt/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ml/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/nb/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ne/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/nl/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/nn/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/or/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/pt/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ro/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ru/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/sv/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/sw/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/ta/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/te/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/th_TH/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/tr/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/uk/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/wo/LC_MESSAGES/tuxtype.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/tuxtype.mo
|
||||
%%DATADIR%%/fonts/AndikaDesRevG.ttf
|
||||
%%DATADIR%%/fonts/DoulosSILR.ttf
|
||||
%%DATADIR%%/fonts/Kedage-n.ttf
|
||||
%%DATADIR%%/fonts/Loma.ttf
|
||||
%%DATADIR%%/fonts/Rachana_w01.ttf
|
||||
%%DATADIR%%/fonts/Vemana.ttf
|
||||
%%DATADIR%%/fonts/lohit_bn.ttf
|
||||
@ -128,6 +137,7 @@
|
||||
%%DATADIR%%/images/icons/icon.png
|
||||
%%DATADIR%%/images/icons/tuxtype.icns
|
||||
%%DATADIR%%/images/icons/tuxtype.ico
|
||||
%%DATADIR%%/images/icons/tuxtype.svg
|
||||
%%DATADIR%%/images/insert1.png
|
||||
%%DATADIR%%/images/kcas0.jpg
|
||||
%%DATADIR%%/images/kcas1.jpg
|
||||
@ -508,6 +518,74 @@
|
||||
%%DATADIR%%/themes/assamese/words/words1.txt
|
||||
%%DATADIR%%/themes/assamese/words/words2.txt
|
||||
%%DATADIR%%/themes/assamese/words/words3.txt
|
||||
%%DATADIR%%/themes/asturian/images/map.png
|
||||
%%DATADIR%%/themes/asturian/images/photo.png
|
||||
%%DATADIR%%/themes/asturian/keyboard.lst
|
||||
%%DATADIR%%/themes/asturian/scripts/cascade.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/laser.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_01.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_02.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_03.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_04.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_05.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_06.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_07.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_08.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_09.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_10.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_11.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_12.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_13.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_14.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_15.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_16.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_17.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_18.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_19.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_20.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_21.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_22.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_23.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_24.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_25.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_26.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_27.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_28.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_29.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_30.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_31.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_32.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_33.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_34.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_35.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_36.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_37.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_38.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_39.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_40.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_41.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/lleicion_basica_42.xml
|
||||
%%DATADIR%%/themes/asturian/scripts/projectInfo.xml
|
||||
%%DATADIR%%/themes/asturian/settings.txt
|
||||
%%DATADIR%%/themes/asturian/words/alphabet.txt
|
||||
%%DATADIR%%/themes/asturian/words/animals.txt
|
||||
%%DATADIR%%/themes/asturian/words/astronomy.txt
|
||||
%%DATADIR%%/themes/asturian/words/colors.txt
|
||||
%%DATADIR%%/themes/asturian/words/fingers.txt
|
||||
%%DATADIR%%/themes/asturian/words/fruit.txt
|
||||
%%DATADIR%%/themes/asturian/words/geography.txt
|
||||
%%DATADIR%%/themes/asturian/words/numbers.txt
|
||||
%%DATADIR%%/themes/asturian/words/plants.txt
|
||||
%%DATADIR%%/themes/asturian/words/shapes.txt
|
||||
%%DATADIR%%/themes/asturian/words/trees.txt
|
||||
%%DATADIR%%/themes/asturian/words/words1.txt
|
||||
%%DATADIR%%/themes/asturian/words/words2.txt
|
||||
%%DATADIR%%/themes/asturian/words/words3.txt
|
||||
%%DATADIR%%/themes/belarussian/keyboard.lst
|
||||
%%DATADIR%%/themes/belarussian/settings.txt
|
||||
%%DATADIR%%/themes/belarussian/words/words1.txt
|
||||
%%DATADIR%%/themes/belarussian/words/words2.txt
|
||||
%%DATADIR%%/themes/belarussian/words/words3.txt
|
||||
%%DATADIR%%/themes/bokmal/images/map.png
|
||||
%%DATADIR%%/themes/bokmal/images/splat0.png
|
||||
%%DATADIR%%/themes/bokmal/images/status/score.png
|
||||
@ -603,20 +681,148 @@
|
||||
%%DATADIR%%/themes/french/words/words3.txt
|
||||
%%DATADIR%%/themes/french/words/words4.txt
|
||||
%%DATADIR%%/themes/greek/keyboard.lst
|
||||
%%DATADIR%%/themes/greek/phrases.txt
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_01.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_02.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_03.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_04.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_05.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_06.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_07.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_08.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_09.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_10.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_11.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_12.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_13.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_14.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_15.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_16.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_17.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_18.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_19.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_20.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_21.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_22.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_23.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_24.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_25.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_26.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_27.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_28.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_29.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_30.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_31.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_32.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_33.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_34.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_35.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_36.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_37.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_38.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_39.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_40.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_41.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_42.xml
|
||||
%%DATADIR%%/themes/greek/scripts/basic_lesson_43.xml
|
||||
%%DATADIR%%/themes/greek/scripts/cascade.xml
|
||||
%%DATADIR%%/themes/greek/scripts/laser.xml
|
||||
%%DATADIR%%/themes/greek/scripts/projectInfo.xml
|
||||
%%DATADIR%%/themes/greek/settings.txt
|
||||
%%DATADIR%%/themes/greek/words/easy.txt
|
||||
%%DATADIR%%/themes/greek/words/alphabet.txt
|
||||
%%DATADIR%%/themes/greek/words/animals.txt
|
||||
%%DATADIR%%/themes/greek/words/astronomy.txt
|
||||
%%DATADIR%%/themes/greek/words/colors.txt
|
||||
%%DATADIR%%/themes/greek/words/fingers.txt
|
||||
%%DATADIR%%/themes/greek/words/fruit.txt
|
||||
%%DATADIR%%/themes/greek/words/geography.txt
|
||||
%%DATADIR%%/themes/greek/words/numbers.txt
|
||||
%%DATADIR%%/themes/greek/words/plants.txt
|
||||
%%DATADIR%%/themes/greek/words/shapes.txt
|
||||
%%DATADIR%%/themes/greek/words/trees.txt
|
||||
%%DATADIR%%/themes/greek/words/words1.txt
|
||||
%%DATADIR%%/themes/greek/words/words2.txt
|
||||
%%DATADIR%%/themes/greek/words/words3.txt
|
||||
%%DATADIR%%/themes/gujarati/alphabet.txt
|
||||
%%DATADIR%%/themes/gujarati/keyboard.lst
|
||||
%%DATADIR%%/themes/gujarati/settings.txt
|
||||
%%DATADIR%%/themes/gujarati/words/words1.txt
|
||||
%%DATADIR%%/themes/gujarati/words/words2.txt
|
||||
%%DATADIR%%/themes/gujarati/words/words3.txt
|
||||
%%DATADIR%%/themes/hebrew/keyboard.lst
|
||||
%%DATADIR%%/themes/hebrew/settings.txt
|
||||
%%DATADIR%%/themes/hebrew/words/family.txt
|
||||
%%DATADIR%%/themes/hebrew/words/months.txt
|
||||
%%DATADIR%%/themes/hebrew/words/numbers.txt
|
||||
%%DATADIR%%/themes/hebrew/words/verbs.txt
|
||||
%%DATADIR%%/themes/hebrew/words/words1.txt
|
||||
%%DATADIR%%/themes/hindi/alphabet.txt
|
||||
%%DATADIR%%/themes/hindi/keyboard.lst
|
||||
%%DATADIR%%/themes/hindi/settings.txt
|
||||
%%DATADIR%%/themes/hindi/words/words1.txt
|
||||
%%DATADIR%%/themes/hindi/words/words2.txt
|
||||
%%DATADIR%%/themes/hindi/words/words3.txt
|
||||
%%DATADIR%%/themes/hungarian/images/photo.png
|
||||
%%DATADIR%%/themes/hungarian/keyboard.lst
|
||||
%%DATADIR%%/themes/hungarian/phrases.txt
|
||||
%%DATADIR%%/themes/hungarian/scripts/0.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/1.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/2.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/3.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/4.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/5.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/6.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/7.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/8.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/9.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/a.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/aposztrof.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/b.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/c.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/cascade.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/d.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/e.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/egyenloseg.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/f.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/g.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/h.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/i.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/j.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/k.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/kotojel.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/l.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/laser.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/m.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/n.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/o.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/p.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/per.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/pont.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/pontosvesszo.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/projectInfo.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/q.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/r.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/s.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/t.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/u.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/v.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/vesszo.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/w.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/x.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/y.xml
|
||||
%%DATADIR%%/themes/hungarian/scripts/z.xml
|
||||
%%DATADIR%%/themes/hungarian/settings.txt
|
||||
%%DATADIR%%/themes/hungarian/words/allatok.txt
|
||||
%%DATADIR%%/themes/hungarian/words/fogasgyakorlatok.txt
|
||||
%%DATADIR%%/themes/hungarian/words/freq.txt
|
||||
%%DATADIR%%/themes/hungarian/words/nemzetek.txt
|
||||
%%DATADIR%%/themes/hungarian/words/nevek.txt
|
||||
%%DATADIR%%/themes/hungarian/words/novenyek.txt
|
||||
%%DATADIR%%/themes/hungarian/words/varosok.txt
|
||||
%%DATADIR%%/themes/hungarian/words/word1.txt
|
||||
%%DATADIR%%/themes/hungarian/words/word2.txt
|
||||
%%DATADIR%%/themes/hungarian/words/word3.txt
|
||||
%%DATADIR%%/themes/hungarian/words/word4.txt
|
||||
%%DATADIR%%/themes/italian/images/map.png
|
||||
%%DATADIR%%/themes/italian/images/photo.png
|
||||
%%DATADIR%%/themes/italian/keyboard.lst
|
||||
@ -649,6 +855,18 @@
|
||||
%%DATADIR%%/themes/kannada/words/words1.txt
|
||||
%%DATADIR%%/themes/kannada/words/words2.txt
|
||||
%%DATADIR%%/themes/kannada/words/words3.txt
|
||||
%%DATADIR%%/themes/korean/images/map.png
|
||||
%%DATADIR%%/themes/korean/images/photo.png
|
||||
%%DATADIR%%/themes/korean/keyboard.lst
|
||||
%%DATADIR%%/themes/korean/phrases.txt
|
||||
%%DATADIR%%/themes/korean/settings.txt
|
||||
%%DATADIR%%/themes/korean/words/alphabet.txt
|
||||
%%DATADIR%%/themes/korean/words/animals.txt
|
||||
%%DATADIR%%/themes/korean/words/colors.txt
|
||||
%%DATADIR%%/themes/korean/words/fruit.txt
|
||||
%%DATADIR%%/themes/korean/words/geography.txt
|
||||
%%DATADIR%%/themes/korean/words/numbers.txt
|
||||
%%DATADIR%%/themes/korean/words/plants.txt
|
||||
%%DATADIR%%/themes/lithuanian/images/status/gameover.png
|
||||
%%DATADIR%%/themes/lithuanian/images/status/score.png
|
||||
%%DATADIR%%/themes/lithuanian/images/status/wave.png
|
||||
@ -734,6 +952,11 @@
|
||||
%%DATADIR%%/themes/punjabi/words/words1.txt
|
||||
%%DATADIR%%/themes/punjabi/words/words2.txt
|
||||
%%DATADIR%%/themes/punjabi/words/words3.txt
|
||||
%%DATADIR%%/themes/romanian/keyboard.lst
|
||||
%%DATADIR%%/themes/romanian/settings.txt
|
||||
%%DATADIR%%/themes/romanian/words/words1.txt
|
||||
%%DATADIR%%/themes/romanian/words/words2.txt
|
||||
%%DATADIR%%/themes/romanian/words/words3.txt
|
||||
%%DATADIR%%/themes/russian/images/splat0.png
|
||||
%%DATADIR%%/themes/russian/images/status/score.png
|
||||
%%DATADIR%%/themes/russian/images/status/wave.png
|
||||
@ -770,6 +993,29 @@
|
||||
%%DATADIR%%/themes/telugu/words/words1.txt
|
||||
%%DATADIR%%/themes/telugu/words/words2.txt
|
||||
%%DATADIR%%/themes/telugu/words/words3.txt
|
||||
%%DATADIR%%/themes/thai/authors.txt
|
||||
%%DATADIR%%/themes/thai/keyboard.lst
|
||||
%%DATADIR%%/themes/thai/settings.txt
|
||||
%%DATADIR%%/themes/thai/words/Animals.txt
|
||||
%%DATADIR%%/themes/thai/words/Colors.txt
|
||||
%%DATADIR%%/themes/thai/words/Fruit.txt
|
||||
%%DATADIR%%/themes/thai/words/Thai_Alphabet.txt
|
||||
%%DATADIR%%/themes/ukrainian/keyboard.lst
|
||||
%%DATADIR%%/themes/ukrainian/settings.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/alphabet.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/animals.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/astronomy.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/colors.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/fingers.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/fruit.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/geography.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/numbers.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/plants.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/shapes.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/trees.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/words1.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/words2.txt
|
||||
%%DATADIR%%/themes/ukrainian/words/words3.txt
|
||||
%%DATADIR%%/themes/wolof/images/map.png
|
||||
%%DATADIR%%/themes/wolof/images/photo.png
|
||||
%%DATADIR%%/themes/wolof/keyboard.lst
|
||||
@ -785,6 +1031,7 @@
|
||||
%%DATADIR%%/words/animals.txt
|
||||
%%DATADIR%%/words/astronomy.txt
|
||||
%%DATADIR%%/words/colors.txt
|
||||
%%DATADIR%%/words/elements.txt
|
||||
%%DATADIR%%/words/fingers.txt
|
||||
%%DATADIR%%/words/fruit.txt
|
||||
%%DATADIR%%/words/geography.txt
|
||||
@ -795,6 +1042,6 @@
|
||||
%%DATADIR%%/words/words1.txt
|
||||
%%DATADIR%%/words/words2.txt
|
||||
%%DATADIR%%/words/words3.txt
|
||||
@dir(,games,775) /var/games/tuxtype/words
|
||||
@dir(,games,775) /var/games/tuxtype
|
||||
@dir(,games,2775) /var/games/tuxtype/words
|
||||
@dir(,games,2775) /var/games/tuxtype
|
||||
@dir %%ETCDIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user