- Update to 1.0.7
- Update LICENSE PR: 223675 Submitted by: takefu@airport.fm
This commit is contained in:
parent
efa97484d2
commit
0d82c4fe62
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=457491
@ -2,23 +2,21 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= sxml
|
||||
PORTVERSION= 1.0.6
|
||||
PORTVERSION= 1.0.7
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= http://www.MysticWALL.COM/download/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= takefu@airport.fm
|
||||
COMMENT= Skimpy XML parsing and grafting library for C language
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE= BSD2CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= tar:bzip2
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
USES= tar:bzip2
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsxml*.so
|
||||
do-test: build
|
||||
cd ${BUILD_WRKSRC}/examples && ${MAKE} all
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (sxml-1.0.6.tar.bz2) = e26a960bd6c24021dd83c4da4d2a8006ed3b92e0a9ac85b17358e473000260d0
|
||||
SIZE (sxml-1.0.6.tar.bz2) = 82316
|
||||
TIMESTAMP = 1497916868
|
||||
SHA256 (sxml-1.0.7.tar.bz2) = b7ed703252976074488044e49de070bc01a9f3eff7633c772dac05f089825470
|
||||
SIZE (sxml-1.0.7.tar.bz2) = 83491
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.in.orig
|
||||
--- Makefile.in.orig 2010-03-26 07:56:17 UTC
|
||||
+++ Makefile.in
|
||||
@@ -30,11 +30,11 @@
|
||||
@@ -30,11 +30,11 @@ CTAGS=@CTAGS@
|
||||
EDITOR=@EDITOR@
|
||||
|
||||
INSTALL=@INSTALL@
|
||||
@ -9,12 +9,12 @@
|
||||
INSTALL_DATA=@INSTALL_DATA@
|
||||
|
||||
DEFS= @DEFS@
|
||||
-OPTS= -fforce-mem -fforce-addr -fstrength-reduce -funroll-loops -finline-functions
|
||||
-OPTS= -fforce-addr -fstrength-reduce -funroll-loops -finline-functions
|
||||
+OPTS= -fstrength-reduce -funroll-loops -finline-functions
|
||||
CPPFLAGS= -I@srcdir@
|
||||
CFLAGS= ${DEFS} ${CPPFLAGS} ${OPTS} @CFLAGS@
|
||||
|
||||
@@ -121,43 +121,43 @@
|
||||
@@ -121,43 +121,43 @@ libsxmlrpc.dylib: ${SXMLRPC_SOBJ}
|
||||
install:: check-dirs install-libsxml install-libsxmlrpc
|
||||
|
||||
install-libsxml::
|
||||
@ -33,7 +33,7 @@
|
||||
if [ -f ${SXML_SLIB} ]; then \
|
||||
- ${INSTALL} ${SXML_SLIB} ${libdir}; \
|
||||
- (cd ${libdir}; ${LN_S} ${SXML_SLIB} ${SXML_LIB}); \
|
||||
+ ${INSTALL} ${SXML_SLIB} ${DESTDIR}${libdir}; \
|
||||
+ ${INSTALL_PROGRAM} ${SXML_SLIB} ${DESTDIR}${libdir}; \
|
||||
+ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXML_SLIB} ${SXML_LIB}); \
|
||||
fi
|
||||
if [ -f ${SXML_DYLIB} ]; then \
|
||||
@ -61,7 +61,7 @@
|
||||
if [ -f ${SXMLRPC_SLIB} ]; then \
|
||||
- ${INSTALL} ${SXMLRPC_SLIB} ${libdir}; \
|
||||
- (cd ${libdir}; ${LN_S} ${SXMLRPC_SLIB} ${SXMLRPC_LIB}); \
|
||||
+ ${INSTALL} ${SXMLRPC_SLIB} ${DESTDIR}${libdir}; \
|
||||
+ ${INSTALL_PROGRAM} ${SXMLRPC_SLIB} ${DESTDIR}${libdir}; \
|
||||
+ (cd ${DESTDIR}${libdir}; ${LN_S} ${SXMLRPC_SLIB} ${SXMLRPC_LIB}); \
|
||||
fi
|
||||
if [ -f ${SXMLRPC_DYLIB} ]; then \
|
||||
@ -77,9 +77,9 @@
|
||||
- @if [ ! -d ${prefix} ]; then ${MKDIR} ${prefix}; fi
|
||||
- @if [ ! -d ${libdir} ]; then ${MKDIR} ${libdir}; fi
|
||||
- @if [ ! -d ${includedir} ]; then ${MKDIR} ${includedir}; fi
|
||||
+ @if [ ! -d ${DESTDIR}${prefix} ]; then ${MKDIR} ${DESTDIR}${prefix}; fi
|
||||
+ @if [ ! -d ${DESTDIR}${libdir} ]; then ${MKDIR} ${DESTDIR}${libdir}; fi
|
||||
+ @if [ ! -d ${DESTDIR}${includedir} ]; then ${MKDIR} ${DESTDIR}${includedir}; fi
|
||||
+ @if [ ! -d ${prefix} ]; then ${MKDIR} ${DESTDIR}${prefix}; fi
|
||||
+ @if [ ! -d ${libdir} ]; then ${MKDIR} ${DESTDIR}${libdir}; fi
|
||||
+ @if [ ! -d ${includedir} ]; then ${MKDIR} ${DESTDIR}${includedir}; fi
|
||||
|
||||
###############################################################################
|
||||
|
||||
|
11
textproc/sxml/files/patch-examples_Makefile.in
Normal file
11
textproc/sxml/files/patch-examples_Makefile.in
Normal file
@ -0,0 +1,11 @@
|
||||
--- examples/Makefile.in.orig 2008-02-05 14:03:37 UTC
|
||||
+++ examples/Makefile.in
|
||||
@@ -34,7 +34,7 @@ INSTALL_PROGRAM=@INSTALL_PROGRAM@ -s
|
||||
INSTALL_DATA=@INSTALL_DATA@
|
||||
|
||||
DEFS= @DEFS@
|
||||
-OPTS= -fforce-mem -fforce-addr -fstrength-reduce -funroll-loops -finline-functions
|
||||
+OPTS= -fstrength-reduce -funroll-loops -finline-functions
|
||||
CPPFLAGS= -I.. -L..
|
||||
CFLAGS= ${DEFS} ${CPPFLAGS} ${OPTS} @CFLAGS@
|
||||
|
@ -1,4 +1,5 @@
|
||||
SXML is a skimpy XML parsing and grafting C library that you can use
|
||||
to read and write XML-like configuration file for your application.
|
||||
SXML is a skimpy XML parsing and grafting C library that you can use to read
|
||||
and write XML-like configuration file for your application.
|
||||
|
||||
Author: Kouichi ABE (WALL) <kouichi@MysticWALL.COM>
|
||||
WWW: http://www.MysticWALL.COM/software/sxml/index.html
|
||||
|
Loading…
Reference in New Issue
Block a user