Add smoke 0.5.1, vector graphics OpenGL renderer.

PR:		62411
Submitted by:	Igor Pokrovsky <tiamat@comset.net>
This commit is contained in:
Thierry Thomas 2004-05-29 17:52:41 +00:00
parent 32127bb038
commit 0d72ddb92f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=110303
8 changed files with 120 additions and 0 deletions

View File

@ -396,6 +396,7 @@
SUBDIR += showimg
SUBDIR += simage
SUBDIR += skencil
SUBDIR += smoke
SUBDIR += sng
SUBDIR += sodipodi
SUBDIR += springgraph

65
graphics/smoke/Makefile Normal file
View File

@ -0,0 +1,65 @@
# New ports collection makefile for: smoke
# Date created: 05 Feb 2004
# Whom: Igor Pokrovsky <tiamat@comset.net>
#
# $FreeBSD$
#
PORTNAME= smoke
PORTVERSION= 0.5.1
CATEGORIES= graphics
MASTER_SITES= http://www.chem.pwf.cam.ac.uk/~jdh30/programming/opengl/smoke/code/
MAINTAINER= tiamat@comset.net
COMMENT= Vector graphics OpenGL renderer
BUILD_DEPENDS= ${LOCALBASE}/bin/tmake:${PORTSDIR}/devel/tmake
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_REINPLACE= yes
USE_SDL= yes
USE_GL= yes
USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
TMAKE?= ${LOCALBASE}/bin/tmake
TMAKEPATH?= ${LOCALBASE}/share/tmake/freebsd-g++
PORTDOCS= README
.include <bsd.port.pre.mk>
.if exists(${FREETYPE_CONFIG})
FREETYPE_INCLUDEPATH!= ${FREETYPE_CONFIG} --cflags | ${SED} -e 's|-I||g'
.endif
.if exists(${SDL_CONFIG})
SDL_INCLUDEPATH!= ${SDL_CONFIG} --cflags | ${SED} -e 's|-I||g; s|-D[[:graph:]]*||g'
.endif
post-patch:
@${REINPLACE_CMD} -e 's|%%FREETYPE_CONFIG%%|${FREETYPE_CONFIG}|g; \
s|%%SDL_CONFIG%%|${SDL_CONFIG}|g; \
s|%%FREETYPE_INCLUDEPATH%%|${FREETYPE_INCLUDEPATH}|g; \
s|%%SDL_INCLUDEPATH%%|${SDL_INCLUDEPATH}|g; \
s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
${WRKSRC}/project
pre-build:
${SETENV} TMAKEPATH=${TMAKEPATH} \
${TMAKE} ${WRKSRC}/project >${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/smoke ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
@${MKDIR} ${EXAMPLESDIR}/tests
${INSTALL_DATA} ${WRKSRC}/tests/tiger.* ${EXAMPLESDIR}/tests
.ifndef (NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>

2
graphics/smoke/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (smoke-0.5.1.tar.bz2) = c0e46c652a5fcccd7b511fbb056a1fae
SIZE (smoke-0.5.1.tar.bz2) = 192646

View File

@ -0,0 +1,11 @@
--- project.orig Thu Feb 5 19:06:25 2004
+++ project Thu Feb 5 19:08:56 2004
@@ -2,6 +2,6 @@
HEADERS = src/*.h
SOURCES = src/bound.cc src/caches.cc src/colour.cc src/editing.h src/fill_types.cc src/geometry.cc src/gldisplaylist.cc src/load.cc src/main.cc src/scene.cc src/segments.cc src/store.h src/stroke.cc src/tesselate.cc src/test.cc src/tree.cc src/vecmat.cc src/viewport.cc src/usec_timer.cc src/utility.cc
TARGET = smoke
-INCLUDEPATH = /usr/local/include
+INCLUDEPATH = %%FREETYPE_INCLUDEPATH%% %%SDL_INCLUDEPATH%%
DEFINES = _REENTRANT
-LIBS = `freetype-config --libs` -lSDL -lpthread -lXxf86dga -lXxf86vm -lXv
+LIBS = `%%FREETYPE_CONFIG%% --libs` `%%SDL_CONFIG%% --libs` %%PTHREAD_LIBS%% -lXxf86dga -lXxf86vm -lXv

View File

@ -0,0 +1,11 @@
--- src/main.cc.orig Thu Feb 5 20:36:50 2004
+++ src/main.cc Thu Feb 5 20:36:58 2004
@@ -36,7 +36,7 @@
#include <string>
#include <GL/gl.h>
#include <GL/glu.h>
-#include <SDL/SDL.h>
+#include <SDL.h>
using namespace std; // Lots of IO

View File

@ -0,0 +1,13 @@
--- src/store.h.orig Sat May 17 15:34:24 2003
+++ src/store.h Mon May 24 22:08:54 2004
@@ -32,8 +32,8 @@
#include <string>
#include <map>
-#include <freetype/freetype.h>
-
+#include <ft2build.h>
+#include FT_FREETYPE_H
class Store

12
graphics/smoke/pkg-descr Normal file
View File

@ -0,0 +1,12 @@
Smoke is a development version of a vector graphics engine capable of storing,
manipulating and rendering vector graphics.
A vector graphic image is represented by sets of lines and implicit curves.
These lines and curves are defined only by their coordinates on an imaginary
canvas. Thus a vector graphics image is resolution independent and can be
drawn into a pixmap of any size.
WWW: http://www.chem.pwf.cam.ac.uk/~jdh30/programming/opengl/smoke/
- Igor Pokrovsky
tiamat@comset.net

5
graphics/smoke/pkg-plist Normal file
View File

@ -0,0 +1,5 @@
bin/smoke
%%EXAMPLESDIR%%/tests/tiger.smoke
%%EXAMPLESDIR%%/tests/tiger.svg
@dirrm %%EXAMPLESDIR%%/tests
@dirrm %%EXAMPLESDIR%%