Delete py-pychess, new BROKEN port

With hat:	portmgr
This commit is contained in:
Antoine Brodin 2020-04-10 18:04:49 +00:00
parent 756ea1e2d8
commit 0d551e6611
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531336
6 changed files with 0 additions and 78 deletions

View File

@ -720,7 +720,6 @@
SUBDIR += py-cbeams
SUBDIR += py-fife
SUBDIR += py-mnemosyne
SUBDIR += py-pychess
SUBDIR += py-sgflib
SUBDIR += py-sgfsummary
SUBDIR += pyfa

View File

@ -1,33 +0,0 @@
# Created by: Nicola Vitale <nivit@FreeBSD.org>
# $FreeBSD$
PORTNAME= pychess
PORTVERSION= 1.0.0
CATEGORIES= games python
MASTER_SITES= https://github.com/pychess/pychess/releases/download/${PORTVERSION}/
MAINTAINER= mi@aldan.algebra.com
COMMENT= GTK chess client written in Python
LICENSE= GPLv3
COMMON_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pexpect>0:misc/py-pexpect@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy*>1.:databases/py-sqlalchemy13@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}psutil*>0.:sysutils/py-psutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}gobject*>2:devel/py-gobject3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}websockets*>7.:devel/py-websockets@${PY_FLAVOR}
RUN_DEPENDS= ${COMMON_DEPENDS}
BUILD_DEPENDS= ${COMMON_DEPENDS}
.if defined(PACKAGE_BUILDING)
BROKEN= fails to install: Unable to init server: Could not connect to 127.0.0.1: Connection refused
.endif
USES= desktop-file-utils display gettext gnome python:3.3+
USE_GSTREAMER1= yes
USE_PYTHON= distutils autoplist
USE_GNOME= gtksourceview3:run glib20 gtk30 librsvg2 introspection
INSTALLS_ICONS= yes
PYDISTUTILS_INSTALLNOSINGLE= nope
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1586042912
SHA256 (pychess-1.0.0.tar.gz) = cf6c326068b11287cb656eb30ad99a3026b7827d33e6a73b7d2cc09317dddabc
SIZE (pychess-1.0.0.tar.gz) = 12853354

View File

@ -1,9 +0,0 @@
--- setup.py 2019-03-10 06:22:01.000000000 -0400
+++ setup.py 2020-04-05 12:09:51.478233000 -0400
@@ -343,5 +343,4 @@
scripts=['pychess'],
options={"build_exe": build_exe_options,
- "bdist_msi": bdist_msi_options},
- executables=executables
+ "bdist_msi": bdist_msi_options}
)

View File

@ -1,22 +0,0 @@
PyChess is a gnome-inspired chess client written in Python.
Features
* CECP and UCI Engine support
* Free on-line play on the FICS chess servers
* Read and writes the PGN, EPD and FEN chess file formats
* Built-in Python based engine
* Undo and pause functions
* Board and piece animation
* Drag and drop
* Tabbed interface
* Hints and spy arrows
* Opening book side panel using sqlite
* Scoreplot side panel
* "Enter game" in pgn dialog
* Internationalised or figure pieces in notation
* Optional sounds
* Legal move highlighting
* A nice and accessible look
WWW: http://www.pychess.org/

View File

@ -1,10 +0,0 @@
PyChess can let you play against others online.
To play against your own computer, install one or more of the
game-engines:
* games/crafty
* games/gnuchess
* games/phalanx
* games/sjeng
* games/stockfish