Update from 2.4.13 to 2.4.14.

<ChangeLog>

UPGRADE URGENCY: high, many non trivial bugs fixed in this release.

* [BUGFIX] Fixed issue #518 (Redis 99% CPU when master down).
* [BUGFIX] Fixed issue #516 (ZINTERSTORE mixing sets and zsets).
* [BUGFIX] Fixed a bug in install_server.sh when using chkconfig
* [BUGFIX] Fixes to --test-memory implementation.
* [BUGFIX] Allow PREFIX to be overridden in Makefile.
* [BUGFIX] The test is now more reliable on slow computers.
* redis-cli --pipe mode, see http://redis.io/topics/mass-insert
* Much better expired keys collection algorithm that makes the server much
  more responsive when a lot of keys are expiring at the same time.

</ChangeLog>
This commit is contained in:
Sergey A. Osokin 2012-05-28 07:23:16 +00:00
parent bf2aa23152
commit 0d32f8a129
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=297573
3 changed files with 7 additions and 7 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= redis
PORTVERSION= 2.4.13
PORTVERSION= 2.4.14
CATEGORIES= databases
MASTER_SITES= GOOGLE_CODE

View File

@ -1,2 +1,2 @@
SHA256 (redis-2.4.13.tar.gz) = b6e057b6b5cd5946f8b46b2427401400686ed4f6c4af446eb1f0ec170d3f87be
SIZE (redis-2.4.13.tar.gz) = 625464
SHA256 (redis-2.4.14.tar.gz) = 4f26ae8cad0f9143ef30b9bb9565a1618570654eb86ee911c20966971660cc7e
SIZE (redis-2.4.14.tar.gz) = 627494

View File

@ -1,5 +1,5 @@
--- src/Makefile.orig 2011-11-28 14:22:08.000000000 +0400
+++ src/Makefile 2011-11-30 16:33:17.000000000 +0400
--- src/Makefile.orig 2012-05-28 11:14:39.000000000 +0400
+++ src/Makefile 2012-05-28 11:15:45.000000000 +0400
@@ -28,6 +28,9 @@
CFLAGS?=-std=c99 -pedantic $(OPTIMIZATION) -Wall -W -D__EXTENSIONS__ -D_XPG6
CCLINK?=-ldl -lnsl -lsocket -lm -lpthread
@ -17,8 +17,8 @@
-CCOPT= $(CFLAGS) $(ARCH) $(PROF)
+CCOPT= $(CFLAGS) $(PROF)
-PREFIX= /usr/local
-PREFIX?=/usr/local
+PREFIX:= ${PREFIX}
INSTALL_BIN= $(PREFIX)/bin
INSTALL= cp -p
INSTALL= cp -pf