graphics/colmap: unbreak OPENMP=off after r446135
src/ext/PBA/SparseBundleCPU.cpp:1208:7: error: non-constant-expression cannot be narrowed from type 'size_t' (aka 'unsigned long') to 'int' in initializer list [-Wc++11-narrowing] RUN_THREAD(ComputeProjection, threads[i], last - first, camera, point, ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/ext/PBA/SparseBundleCPU.cpp:933:3: note: expanded from macro 'RUN_THREAD' DECLEAR_THREAD_DATA(X, __VA_ARGS__); \ ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ src/ext/PBA/SparseBundleCPU.cpp:908:30: note: expanded from macro 'DECLEAR_THREAD_DATA' X##_STRUCT<Float> tdata = {i, __VA_ARGS__}; \ ^ src/ext/PBA/SparseBundleCPU.cpp:1537:68: error: non-constant-expression cannot be narrowed from type 'size_t' (aka 'unsigned long') to 'int' in initializer list [-Wc++11-narrowing] intrinsic_fixed, radial_distortion, shuffle, jct, first); ^~~~~ src/ext/PBA/SparseBundleCPU.cpp:933:26: note: expanded from macro 'RUN_THREAD' DECLEAR_THREAD_DATA(X, __VA_ARGS__); \ ^~~~~~~~~~~ src/ext/PBA/SparseBundleCPU.cpp:908:33: note: expanded from macro 'DECLEAR_THREAD_DATA' X##_STRUCT<Float> tdata = {i, __VA_ARGS__}; \ ^~~~~~~~~~~ src/ext/PBA/SparseBundleCPU.cpp:1537:68: note: insert an explicit cast to silence this issue intrinsic_fixed, radial_distortion, shuffle, jct, first); ^~~~~ static_cast<int>(
This commit is contained in:
parent
6cf98c7381
commit
0d2a2751d4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461466
@ -2,14 +2,13 @@ build: don't force SSE on i386
|
||||
|
||||
--- src/ext/PBA/CMakeLists.txt.orig 2017-06-15 14:32:01 UTC
|
||||
+++ src/ext/PBA/CMakeLists.txt
|
||||
@@ -1,7 +1,3 @@
|
||||
-if(NOT IS_MSVC)
|
||||
@@ -1,5 +1,5 @@
|
||||
if(NOT IS_MSVC)
|
||||
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -O3 -pthread -march=core2 -mfpmath=sse -Wno-c++11-narrowing")
|
||||
-endif()
|
||||
-
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-c++11-narrowing")
|
||||
endif()
|
||||
|
||||
if(CUDA_ENABLED)
|
||||
# Fix for Ubuntu 16.04.
|
||||
add_definitions("-D_FORCE_INLINES")
|
||||
--- src/ext/PBA/SparseBundleCPU.cpp.orig 2017-06-15 14:32:01 UTC
|
||||
+++ src/ext/PBA/SparseBundleCPU.cpp
|
||||
@@ -52,15 +52,16 @@ using std::max;
|
||||
|
Loading…
Reference in New Issue
Block a user