Remove expired sysutils/bbcp
The port was reported broken one year ago, and no acceptable fix was provide in the meantime. An expiration date was set 4 months ago, and now it's time to proceed and remove it. PR: 229115
This commit is contained in:
parent
6256522c14
commit
0cdec4b37e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=507966
1
MOVED
1
MOVED
@ -12858,3 +12858,4 @@ devel/ddd||2019-07-31|Has expired: does not work with modern gdb
|
||||
devel/py-pip-tools2|devel/py-pip-tools|2019-07-31|Has expired: Use devel/py-pip-tools instead
|
||||
lang/cint|lang/cling|2019-07-31|Has expired: Abandonware; superseded by lang/cling
|
||||
emulators/pearpc||2019-08-01|Has expired: Abandonware
|
||||
sysutils/bbcp||2019-08-03|Has expired: the port is broken for more than a year
|
||||
|
@ -97,7 +97,6 @@
|
||||
SUBDIR += batmon
|
||||
SUBDIR += battmond
|
||||
SUBDIR += battray
|
||||
SUBDIR += bbcp
|
||||
SUBDIR += bchunk
|
||||
SUBDIR += beadm
|
||||
SUBDIR += beadm-devel
|
||||
|
@ -1,38 +0,0 @@
|
||||
# Created by: John Hein <jhein@symmetricom.com>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= bbcp
|
||||
PORTVERSION= 20150116
|
||||
CATEGORIES= sysutils net
|
||||
MASTER_SITES= http://BSDforge.com/projects/source/sysutils/bbcp/
|
||||
|
||||
MAINTAINER= portmaster@BSDforge.com
|
||||
COMMENT= Secure, fast, and IPv6 capable Copy utility
|
||||
|
||||
LICENSE= LGPL20
|
||||
LICENSE_FILE= ${WRKSRC}/src/COPYING.LESSER
|
||||
|
||||
BROKEN= fails to build
|
||||
DEPRECATED= Broken for more than 6 months
|
||||
EXPIRATION_DATE= 2019-05-08
|
||||
|
||||
USES= tar:xz
|
||||
|
||||
PLIST_FILES= bin/bbcp
|
||||
PORTDOCS= ${PORTNAME}.pdf
|
||||
|
||||
BUILD_WRKSRC= ${WRKSRC}/src
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|g++|${CXX}|' -e 's|gcc|${CC}|' \
|
||||
${WRKSRC}/src/Makefile
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/FreeBSD/bbcp ${STAGEDIR}${PREFIX}/bin
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.pdf \
|
||||
${STAGEDIR}${DOCSDIR}/${PORTNAME}.pdf
|
||||
|
||||
.include <bsd.port.mk>
|
@ -1,2 +0,0 @@
|
||||
SHA256 (bbcp-20150116.tar.xz) = 3411cbbb3f611c9568be5c83199bd630191f69628c9aa9fc28d47d573e765ba7
|
||||
SIZE (bbcp-20150116.tar.xz) = 991864
|
@ -1,20 +0,0 @@
|
||||
--- src/bbcp_Args.C.orig 2015-01-16 13:16:09.000000000 -0800
|
||||
+++ src/bbcp_Args.C 2015-01-16 13:17:22.000000000 -0800
|
||||
@@ -58,7 +58,7 @@
|
||||
bbcp_Opt *p = this;
|
||||
do if (i <= p->Optmaxl && i >= p->Optminl &&
|
||||
!strncmp(p->Optword, optarg, i)) return p->Optvalu;
|
||||
- while(p = p->Optnext);
|
||||
+ while((p = p->Optnext));
|
||||
return 0;
|
||||
}
|
||||
|
||||
@@ -203,7 +203,7 @@
|
||||
if (optspec[1] == '.')
|
||||
{if (argval && *argval == '-')
|
||||
if (inStream) arg_stream.RetToken();
|
||||
- else Aloc--;
|
||||
+ }else{ Aloc--;
|
||||
argval = 0;
|
||||
return *optspec;
|
||||
}
|
@ -1,28 +0,0 @@
|
||||
--- src/bbcp_BuffPool.C.orig 2015-01-16 13:30:31.000000000 -0800
|
||||
+++ src/bbcp_BuffPool.C 2015-01-16 13:33:14.000000000 -0800
|
||||
@@ -32,7 +32,7 @@
|
||||
#include <inttypes.h>
|
||||
#include <sys/mman.h>
|
||||
|
||||
-#if defined(MACOS) || defined(AIX)
|
||||
+#if defined(MACOS) || defined(AIX) || defined(FREEBSD)
|
||||
#define memalign(pgsz,amt) valloc(amt)
|
||||
#else
|
||||
#include <malloc.h>
|
||||
@@ -84,14 +84,14 @@
|
||||
|
||||
// Free all of the buffers in the empty queue
|
||||
//
|
||||
- while(currp = last_empty)
|
||||
+ while((currp = last_empty))
|
||||
{last_empty = last_empty->next; delete currp;}
|
||||
//cerr <<bbcp_Debug.Who <<"Bdestroy num " <<j++ <<" @ " <<hex <<(int)currp <<dec <<endl;
|
||||
|
||||
// Free all full buffers
|
||||
//
|
||||
FullPool.Lock();
|
||||
- while(currp = next_full)
|
||||
+ while((currp = next_full))
|
||||
{next_full = next_full->next; delete currp;}
|
||||
FullPool.UnLock();
|
||||
}
|
@ -1,39 +0,0 @@
|
||||
--- src/bbcp_Config.C.orig 2015-01-16 13:59:00.000000000 -0800
|
||||
+++ src/bbcp_Config.C 2015-01-16 14:04:21.000000000 -0800
|
||||
@@ -265,7 +265,7 @@
|
||||
|
||||
// Process the options
|
||||
//
|
||||
- while (c=arglist.getopt())
|
||||
+ while ((c=arglist.getopt()))
|
||||
{ switch(c)
|
||||
{
|
||||
case 'a': Options |= bbcp_APPEND | bbcp_ORDER;
|
||||
@@ -775,8 +775,8 @@
|
||||
|
||||
// Use the config file, if present
|
||||
//
|
||||
- if (ConfigFN = getenv("bbcp_CONFIGFN"))
|
||||
- {if (retc = Configure(ConfigFN)) return retc;}
|
||||
+ if ((ConfigFN = getenv("bbcp_CONFIGFN")))
|
||||
+ {if ((retc = Configure(ConfigFN))) return retc;}
|
||||
else {
|
||||
// Use configuration file in the home directory, if any
|
||||
//
|
||||
@@ -786,7 +786,7 @@
|
||||
strcpy(ConfigFN, homedir); strcat(ConfigFN, cfn);
|
||||
if (stat(ConfigFN, &buf))
|
||||
{retc = 0; free(ConfigFN); ConfigFN = 0;}
|
||||
- else if (retc = Configure(ConfigFN)) return retc;
|
||||
+ else if ((retc = Configure(ConfigFN))) return retc;
|
||||
}
|
||||
|
||||
// Establish the FD limit
|
||||
@@ -1361,7 +1361,7 @@
|
||||
if (*hn == ':' && hn++ && *hn)
|
||||
{errno = 0;
|
||||
pnum = strtol(hn, (char **)NULL, 10);
|
||||
- if (!pnum && errno || pnum > 65535)
|
||||
+ if ((!pnum && errno) || pnum > 65535)
|
||||
{bbcp_Fmsg("Config",what,"port invalid -", hn); return -1;}
|
||||
}
|
@ -1,20 +0,0 @@
|
||||
--- src/bbcp_File.C.orig 2015-01-15 18:41:10.000000000 -0800
|
||||
+++ src/bbcp_File.C 2015-01-15 18:43:04.000000000 -0800
|
||||
@@ -44,7 +44,7 @@
|
||||
|
||||
#ifdef FREEBSD
|
||||
#undef ENODATA
|
||||
-#define ENODATA ENOATTRR
|
||||
+#define ENODATA ENOATTR
|
||||
#endif
|
||||
|
||||
/******************************************************************************/
|
||||
@@ -153,7 +153,7 @@
|
||||
|
||||
// Find a buffer
|
||||
//
|
||||
- if (bp = nextbuff)
|
||||
+ if ((bp = nextbuff))
|
||||
while(bp && bp->boff != offset) {pp = bp; bp = bp->next;}
|
||||
|
||||
// If we found a buffer, unchain it
|
@ -1,38 +0,0 @@
|
||||
--- src/bbcp_FileSpec.C.orig 2015-01-16 14:34:11.000000000 -0800
|
||||
+++ src/bbcp_FileSpec.C 2015-01-16 14:36:54.000000000 -0800
|
||||
@@ -174,7 +174,7 @@
|
||||
|
||||
// Get the current state of the file or directory
|
||||
//
|
||||
- if (retc = FSp->Stat(targpath, &Targ)) targetsz = 0;
|
||||
+ if ((retc = FSp->Stat(targpath, &Targ))) targetsz = 0;
|
||||
else if (Targ.Otype == 'p' && (bbcp_Config.Options & bbcp_XPIPE))
|
||||
{targetsz = 0; return 0;}
|
||||
else if (Targ.Otype != 'f') {targetsz = -1; return 0;}
|
||||
@@ -211,7 +211,7 @@
|
||||
// in the directory. This will later be set to the true mode if it differs.
|
||||
//
|
||||
DEBUG("Make link " <<targpath <<" -> " <<Info.SLink);
|
||||
- if (retc = FSp->MKLnk(Info.SLink, targpath))
|
||||
+ if ((retc = FSp->MKLnk(Info.SLink, targpath)))
|
||||
return bbcp_Emsg("Create_Link", retc, "creating link", targpath);
|
||||
|
||||
// All done
|
||||
@@ -232,7 +232,7 @@
|
||||
// in the directory. This will later be set to the true mode if it differs.
|
||||
//
|
||||
DEBUG("Make path " <<Info.mode <<' ' <<targpath);
|
||||
- if (retc = FSp->MKDir(targpath, bbcp_Config.ModeDC))
|
||||
+ if ((retc = FSp->MKDir(targpath, bbcp_Config.ModeDC)))
|
||||
if (retc == -EEXIST) return 0;
|
||||
else return bbcp_Emsg("Create_Path", retc, "creating path", targpath);
|
||||
|
||||
@@ -764,7 +764,7 @@
|
||||
else bbcp_Config.srcPath = PS_New;
|
||||
PS_Prv = PS_New; PS_Cur = PS_New->next;
|
||||
}
|
||||
- if (*cp = delim) cp++;
|
||||
+ if ((*cp = delim)) cp++;
|
||||
}
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/bbcp_NetAddr.C.orig 2015-01-14 12:13:30.000000000 -0800
|
||||
+++ src/bbcp_NetAddr.C 2015-01-14 12:25:34.000000000 -0800
|
||||
@@ -49,7 +49,7 @@
|
||||
#ifndef s6_addr32
|
||||
#if defined(SUN)
|
||||
#define s6_addr32 _S6_un._S6_u32
|
||||
-#elif defined(MACOS)
|
||||
+#elif defined(MACOS) || defined(FREEBSD)
|
||||
#define s6_addr32 __u6_addr.__u6_addr32
|
||||
#endif
|
||||
#endif
|
@ -1,11 +0,0 @@
|
||||
--- src/bbcp_NetAddrInfo.C.orig 2015-01-14 12:14:07.000000000 -0800
|
||||
+++ src/bbcp_NetAddrInfo.C 2015-01-14 12:26:37.000000000 -0800
|
||||
@@ -67,7 +67,7 @@
|
||||
#ifndef s6_addr32
|
||||
#if defined(SUN)
|
||||
#define s6_addr32 _S6_un._S6_u32
|
||||
-#elif defined(MACOS)
|
||||
+#elif defined(MACOS) || defined(FREEBSD)
|
||||
#define s6_addr32 __u6_addr.__u6_addr32
|
||||
#endif
|
||||
#endif
|
@ -1,76 +0,0 @@
|
||||
--- src/bbcp_Node.C.orig 2015-01-15 22:20:08.000000000 -0800
|
||||
+++ src/bbcp_Node.C 2015-01-15 22:31:02.000000000 -0800
|
||||
@@ -94,7 +94,7 @@
|
||||
bbcp_Link *link;
|
||||
int retc;
|
||||
|
||||
- if (link = bbcp_Net.Connect(bbcp_Config.CBhost, bbcp_Config.CBport))
|
||||
+ if ((link = bbcp_Net.Connect(bbcp_Config.CBhost, bbcp_Config.CBport)))
|
||||
{if ((retc = protocol->Login(link, 0)) < 0)
|
||||
{delete link; link = 0;}
|
||||
}
|
||||
@@ -354,8 +354,8 @@
|
||||
oflag = O_WRONLY | O_CREAT | O_TRUNC;
|
||||
}
|
||||
else if (bbcp_Config.Options & bbcp_APPEND)
|
||||
- {if (retc = fp->WriteSigFile()) return retc;
|
||||
- if (startoff = fp->targetsz) oflag = O_WRONLY;
|
||||
+ {if ((retc = fp->WriteSigFile())) return retc;
|
||||
+ if ((startoff = fp->targetsz)) oflag = O_WRONLY;
|
||||
else oflag = O_CREAT | O_WRONLY;
|
||||
}
|
||||
else oflag = O_WRONLY | O_CREAT | O_EXCL;
|
||||
@@ -368,7 +368,7 @@
|
||||
|
||||
// Tell the user what we are bout to do
|
||||
//
|
||||
- if (bbcp_Config.Options & bbcp_BLAB | bbcp_Config.Progint)
|
||||
+ if ((bbcp_Config.Options & bbcp_BLAB) | bbcp_Config.Progint)
|
||||
if (bbcp_Config.Options & bbcp_APPEND)
|
||||
{char buff[32];
|
||||
sprintf(buff, "%lld", startoff);
|
||||
@@ -464,7 +464,7 @@
|
||||
// Wait for the expansion thread to end
|
||||
//
|
||||
if (bbcp_Config.Options & bbcp_COMPRESS)
|
||||
- {if (tretc = (long)bbcp_Thread_Wait(cxp->TID)) retc = 128;
|
||||
+ {if ((tretc = (long)bbcp_Thread_Wait(cxp->TID))) retc = 128;
|
||||
DEBUG("File expansion ended; rc=" <<tretc);
|
||||
}
|
||||
|
||||
@@ -478,7 +478,7 @@
|
||||
// Make sure each thread has terminated normally
|
||||
//
|
||||
for (i = 0; i < dlcount; i++)
|
||||
- {if (tretc = (long)bbcp_Thread_Wait(link_tid[i])) retc = 128;
|
||||
+ {if ((tretc = (long)bbcp_Thread_Wait(link_tid[i]))) retc = 128;
|
||||
DEBUG("Thread " <<link_tid[i] <<" stream " <<i <<" ended; rc=" <<tretc);
|
||||
}
|
||||
|
||||
@@ -618,7 +618,7 @@
|
||||
// Wait for compression thread to end
|
||||
//
|
||||
if (bbcp_Config.Options & bbcp_COMPRESS)
|
||||
- {if (tretc = (long)bbcp_Thread_Wait(cxp->TID)) retc = 128;
|
||||
+ {if ((tretc = (long)bbcp_Thread_Wait(cxp->TID))) retc = 128;
|
||||
DEBUG("File compression ended; rc=" <<tretc);
|
||||
delete cxp;
|
||||
}
|
||||
@@ -626,7 +626,7 @@
|
||||
// Make sure each link thread has terminated normally.
|
||||
//
|
||||
for (i = 0; i < iocount; i++)
|
||||
- {if (tretc = (long)bbcp_Thread_Wait(link_tid[i])) retc = 128;
|
||||
+ {if ((tretc = (long)bbcp_Thread_Wait(link_tid[i]))) retc = 128;
|
||||
DEBUG("Thread " <<link_tid[i] <<" stream " <<i <<" ended; rc=" <<tretc);
|
||||
}
|
||||
|
||||
@@ -735,7 +735,7 @@
|
||||
|
||||
// Establish the control connection first
|
||||
//
|
||||
- if (link = bbcp_Net.Connect(bbcp_Config.CBhost, bbcp_Config.CBport, 3))
|
||||
+ if ((link = bbcp_Net.Connect(bbcp_Config.CBhost, bbcp_Config.CBport, 3)))
|
||||
if ((retc = protocol->Login(link, 0)) < 0)
|
||||
{delete link; link = 0;}
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- src/bbcp_ProcMon.C.orig 2015-01-15 22:40:09.000000000 -0800
|
||||
+++ src/bbcp_ProcMon.C 2015-01-15 22:41:33.000000000 -0800
|
||||
@@ -132,7 +132,7 @@
|
||||
|
||||
// Run a thread to start the monitor
|
||||
//
|
||||
- if (retc = bbcp_Thread_Run(bbcp_MonProc, (void *)this, &mytid))
|
||||
+ if ((retc = bbcp_Thread_Run(bbcp_MonProc, (void *)this, &mytid)))
|
||||
{DEBUG("Error " <<retc <<" starting MonProc thread.");}
|
||||
else {DEBUG("Thread " <<mytid <<" monitoring process " <<monPID);}
|
||||
return;
|
||||
@@ -154,7 +154,7 @@
|
||||
|
||||
// Run a thread to start the monitor
|
||||
//
|
||||
- if (retc = bbcp_Thread_Run(bbcp_MonProc, (void *)this, &mytid))
|
||||
+ if ((retc = bbcp_Thread_Run(bbcp_MonProc, (void *)this, &mytid)))
|
||||
{DEBUG("Error " <<retc <<" starting buffpool monitor thread.");}
|
||||
else {DEBUG("Thread " <<mytid <<" monitoring buffpool.");}
|
||||
return;
|
@ -1,11 +0,0 @@
|
||||
--- src/bbcp_ProgMon.C.orig 2015-01-15 22:47:57.000000000 -0800
|
||||
+++ src/bbcp_ProgMon.C 2015-01-15 22:49:27.000000000 -0800
|
||||
@@ -146,7 +146,7 @@
|
||||
|
||||
// Run a thread to start the monitor
|
||||
//
|
||||
- if (retc = bbcp_Thread_Run(bbcp_MonProg, (void *)this, &mytid))
|
||||
+ if ((retc = bbcp_Thread_Run(bbcp_MonProg, (void *)this, &mytid)))
|
||||
{DEBUG("Error " <<retc <<" starting progress monitor thread.");}
|
||||
else {DEBUG("Thread " <<mytid <<" monitoring progress.");}
|
||||
return;
|
@ -1,77 +0,0 @@
|
||||
--- src/bbcp_Protocol.C.orig 2015-01-16 11:37:43.000000000 -0800
|
||||
+++ src/bbcp_Protocol.C 2015-01-16 11:41:33.000000000 -0800
|
||||
@@ -86,7 +86,7 @@
|
||||
|
||||
// Start-up the first node
|
||||
//
|
||||
- if (retc = Fnode->Run(Ffs->username, Ffs->hostname, Fcmd, Ftype))
|
||||
+ if ((retc = Fnode->Run(Ffs->username, Ffs->hostname, Fcmd, Ftype)))
|
||||
return retc;
|
||||
|
||||
// Determine additional options
|
||||
@@ -101,15 +101,15 @@
|
||||
|
||||
// Send the arguments
|
||||
//
|
||||
- if (retc = SendArgs(Fnode, Ffs, (char *)"none", 0, addOpt[0])) return retc;
|
||||
+ if ((retc = SendArgs(Fnode, Ffs, (char *)"none", 0, addOpt[0]))) return retc;
|
||||
|
||||
// Get the callback port from the first host
|
||||
//
|
||||
- if (retc = getCBPort(Fnode)) return retc;
|
||||
+ if ((retc = getCBPort(Fnode))) return retc;
|
||||
|
||||
// Start the second node
|
||||
//
|
||||
- if (retc = Lnode->Run(Lfs->username, Lfs->hostname, Lcmd, Ltype))
|
||||
+ if ((retc = Lnode->Run(Lfs->username, Lfs->hostname, Lcmd, Ltype)))
|
||||
return retc;
|
||||
|
||||
// Compute callback hostname and reset callback port
|
||||
@@ -152,7 +152,7 @@
|
||||
|
||||
// The remote program should hve started, get the call back port
|
||||
//
|
||||
- if (wp = Node->GetLine())
|
||||
+ if ((wp = Node->GetLine()))
|
||||
{if ((wp = Node->GetToken()) && !strcmp(wp, "200")
|
||||
&& (wp = Node->GetToken()) && !strcmp(wp, "Port:")
|
||||
&& (wp = Node->GetToken())
|
||||
@@ -408,7 +408,7 @@
|
||||
|
||||
// Get the optional offset
|
||||
//
|
||||
- if (wp = Remote->GetToken())
|
||||
+ if ((wp = Remote->GetToken()))
|
||||
{if (bbcp_Config.a2ll("file offset", wp, foffset, 0, -1)) return 22;
|
||||
if (foffset > fp->Info.size)
|
||||
{char buff[128];
|
||||
@@ -447,7 +447,7 @@
|
||||
// Get the first line of the login stream
|
||||
//
|
||||
if (!(np->GetLine()))
|
||||
- {if (retc = np->LastError())
|
||||
+ {if ((retc = np->LastError()))
|
||||
return bbcp_Emsg("Process_Login", retc, "processing login from",
|
||||
Net->LinkName());
|
||||
return bbcp_Fmsg("Process_Login", "Bad login from", Net->LinkName());
|
||||
@@ -549,8 +549,8 @@
|
||||
if (texists && bbcp_Config.snkSpec->Info.Otype == 'd')
|
||||
tdir = bbcp_Config.snkSpec->pathname;
|
||||
else {int plen;
|
||||
- if (plen = bbcp_Config.snkSpec->filename -
|
||||
- bbcp_Config.snkSpec->pathname)
|
||||
+ if ((plen = bbcp_Config.snkSpec->filename -
|
||||
+ bbcp_Config.snkSpec->pathname))
|
||||
strncpy(buff, bbcp_Config.snkSpec->pathname, plen-1);
|
||||
else {buff[0] = '.'; plen = 2;}
|
||||
tdir = buff; buff[plen-1] = '\0';
|
||||
@@ -562,7 +562,7 @@
|
||||
tdir_id = bbcp_Config.snkSpec->Info.fileid;
|
||||
else {bbcp_FileInfo Tinfo;
|
||||
if (!fs_obj || (!(retc = fs_obj->Stat(tdir, &Tinfo))
|
||||
- && Tinfo.Otype != 'd') && outDir) retc = ENOTDIR;
|
||||
+ && (Tinfo.Otype != 'd') && outDir)) retc = ENOTDIR;
|
||||
if (retc) {bbcp_Fmsg("Request","Target directory",
|
||||
bbcp_Config.snkSpec->pathname,"not found");
|
||||
return Request_exit(2, dRM);
|
@ -1,20 +0,0 @@
|
||||
--- src/bbcp_Pthread.C.orig 2015-01-16 13:38:06.000000000 -0800
|
||||
+++ src/bbcp_Pthread.C 2015-01-16 13:39:48.000000000 -0800
|
||||
@@ -128,7 +128,7 @@
|
||||
/* C o n d W a i t */
|
||||
/******************************************************************************/
|
||||
|
||||
-#if defined(MACOS) || defined(AIX)
|
||||
+#if defined(MACOS) || defined(AIX) || defined(FREEBSD)
|
||||
|
||||
int bbcp_Semaphore::CondWait()
|
||||
{
|
||||
@@ -215,7 +215,7 @@
|
||||
void *bbcp_Thread_Wait(pthread_t tid)
|
||||
{long retc;
|
||||
void *tstat;
|
||||
- if (retc = pthread_join(tid, (void **)&tstat)) tstat = (void *)retc;
|
||||
+ if ((retc = pthread_join(tid, (void **)&tstat))) tstat = (void *)retc;
|
||||
return tstat;
|
||||
}
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/bbcp_Pthread.h.orig 2015-01-16 13:41:31.000000000 -0800
|
||||
+++ src/bbcp_Pthread.h 2015-01-16 13:42:14.000000000 -0800
|
||||
@@ -108,7 +108,7 @@
|
||||
bbcp_Mutex *monMutex;
|
||||
};
|
||||
|
||||
-#if defined(MACOS) || defined(AIX)
|
||||
+#if defined(MACOS) || defined(AIX) || defined(FREEBSD)
|
||||
class bbcp_Semaphore
|
||||
{
|
||||
public:
|
@ -1,20 +0,0 @@
|
||||
--- src/bbcp_Stream.C.orig 2015-01-16 11:52:58.000000000 -0800
|
||||
+++ src/bbcp_Stream.C 2015-01-16 11:55:23.000000000 -0800
|
||||
@@ -206,7 +206,7 @@
|
||||
return bbcp_Emsg("Exec",errno,"creating a pipe for",parm[0]);
|
||||
Child_In=fildes_In[0]; Child_Out=fildes_Out[1]; Child_Err=fildes_Err[1];
|
||||
fildes_Out[1] = (inrd ? fildes_In[1] : -1);
|
||||
- if (retc = Attach(fildes_Out)) return retc;
|
||||
+ if ((retc = Attach(fildes_Out))) return retc;
|
||||
}
|
||||
|
||||
// Fork a process first so we can pick up the next request.
|
||||
@@ -436,7 +436,7 @@
|
||||
// If we have a token, return it
|
||||
//
|
||||
xline = 1;
|
||||
- if (wp = GetToken(lowcase)) return wp;
|
||||
+ if ((wp = GetToken(lowcase))) return wp;
|
||||
|
||||
// If no continuation allowed, return a null (but only once)
|
||||
//
|
@ -1,47 +0,0 @@
|
||||
--- src/bbcp_System.C.orig 2015-01-16 11:58:47.000000000 -0800
|
||||
+++ src/bbcp_System.C 2015-01-16 12:01:30.000000000 -0800
|
||||
@@ -108,7 +108,7 @@
|
||||
// Convert the group name to a gid
|
||||
//
|
||||
Glookup.Lock();
|
||||
- if (gp = getgrnam(group)) gid = gp->gr_gid;
|
||||
+ if ((gp = getgrnam(group))) gid = gp->gr_gid;
|
||||
else gid = (gid_t)-1;
|
||||
Glookup.UnLock();
|
||||
return gid;
|
||||
@@ -126,7 +126,7 @@
|
||||
// Get the group name
|
||||
//
|
||||
Glookup.Lock();
|
||||
- if (gp = getgrgid(gid)) gnmp = gp->gr_name;
|
||||
+ if ((gp = getgrgid(gid))) gnmp = gp->gr_name;
|
||||
else gnmp = (char *)"nogroup";
|
||||
Glookup.UnLock();
|
||||
|
||||
@@ -151,7 +151,7 @@
|
||||
|
||||
// Get the password entry for this uid
|
||||
//
|
||||
- if (pwp = getpwuid(myuid)) homedir = pwp->pw_dir;
|
||||
+ if ((pwp = getpwuid(myuid))) homedir = pwp->pw_dir;
|
||||
else homedir = (char *)"/tmp";
|
||||
|
||||
// Return a copy of the directory
|
||||
@@ -170,7 +170,7 @@
|
||||
int rc, grandpa;
|
||||
|
||||
sprintf(cmd, PS_CMD, getppid());
|
||||
- if (rc = cmdstream.Exec(cmd)) rc = cmdstream.LastError();
|
||||
+ if ((rc = cmdstream.Exec(cmd))) rc = cmdstream.LastError();
|
||||
else if (!cmdstream.GetLine() || !(lp = cmdstream.GetLine())) rc = -33;
|
||||
else {errno = 0;
|
||||
grandpa = strtol(lp, (char **)NULL, 10);
|
||||
@@ -218,7 +218,7 @@
|
||||
|
||||
// Get the password entry for this uid
|
||||
//
|
||||
- if (pwp = getpwuid(myuid)) uname = pwp->pw_name;
|
||||
+ if ((pwp = getpwuid(myuid))) uname = pwp->pw_name;
|
||||
else uname = (char *)"anonymous";
|
||||
|
||||
// Return a copy of the directory
|
@ -1,11 +0,0 @@
|
||||
--- src/bbcp_ZCX.C.orig 2015-01-16 12:06:04.000000000 -0800
|
||||
+++ src/bbcp_ZCX.C 2015-01-16 12:06:59.000000000 -0800
|
||||
@@ -144,7 +144,7 @@
|
||||
|
||||
// If we have gotten here then all went well so far flush output
|
||||
//
|
||||
- if (obp->blen = outsz - ZStream.avail_out)
|
||||
+ if ((obp->blen = outsz - ZStream.avail_out))
|
||||
{obp->boff = outbytes; outbytes += obp->blen;
|
||||
Obuff->putFullBuff(obp);
|
||||
if (!(obp = Obuff->getEmptyBuff())) return ENOBUFS;
|
@ -1,4 +0,0 @@
|
||||
Securely, and quickly copy data from Source to Target over
|
||||
IPv4 and IPv6 networks.
|
||||
|
||||
WWW: http://www.slac.stanford.edu/~abh/bbcp/
|
Loading…
Reference in New Issue
Block a user