Add the qt-mysql-plugin, whix provides easy access to MySQL Databases from
Qt Applications PR: 52131 Submitted by: Kay Lehmann <kay_lehmann@web.de>, Lauri Watts <lauri@kde.org>, lofi Reviewed by: kde
This commit is contained in:
parent
b754f52652
commit
0cb2bb1b9c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86375
@ -164,6 +164,7 @@
|
||||
SUBDIR += py-pyPgSQL
|
||||
SUBDIR += py-sqlrelay
|
||||
SUBDIR += pydbdesigner
|
||||
SUBDIR += qt-mysql-plugin
|
||||
SUBDIR += rdb
|
||||
SUBDIR += rdfdb
|
||||
SUBDIR += ruby-bdb
|
||||
|
39
databases/qt-mysql-plugin/Makefile
Normal file
39
databases/qt-mysql-plugin/Makefile
Normal file
@ -0,0 +1,39 @@
|
||||
# -*-mode: makefile-*-
|
||||
# New ports collection makefile for: qt-mysql-plugin
|
||||
# Date created: 20 April 2003
|
||||
# Whom: Kay Lehmann <kay_lehmann@web.de>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= qt-mysql-plugin
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= databases x11-toolkits
|
||||
PKGNAMESUFFIX= -mysql-plugin
|
||||
|
||||
MAINTAINER= kay_lehmann@web.de
|
||||
COMMENT= A plugin for QT to connect to MySQL-Databases
|
||||
|
||||
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
|
||||
|
||||
USE_QT_VER= 3
|
||||
QT_NONSTANDARD= yes
|
||||
|
||||
LDCONFIG_DIRS= %%PREFIX%%/lib/plugins/sqldrivers
|
||||
CONFIGURE_ARGS= -plugin-sql-mysql -fast
|
||||
CONFIGURE_ENV= ${ECHO} yes | MOC="${MOC}" CPPFLAGS="${QTCPPFLAGS}" \
|
||||
LIBS="${QTCFGLIBS}" LOCALBASE="${LOCALBASE}"
|
||||
|
||||
BUILD_PLUGIN_ONLY= yes
|
||||
|
||||
|
||||
do-build:
|
||||
cd ${WRKSRC}/plugins/src/sqldrivers/mysql; \
|
||||
${SETENV} ${MAKE_ENV} ${GMAKE}
|
||||
|
||||
do-install:
|
||||
${MKDIR} ${PREFIX}/lib/plugins/sqldrivers
|
||||
${INSTALL_DATA} ${WRKSRC}/plugins/sqldrivers/libqsqlmysql.so \
|
||||
${PREFIX}/lib/plugins/sqldrivers/
|
||||
|
||||
.include "../../x11-toolkits/qt31/Makefile"
|
1
databases/qt-mysql-plugin/distinfo
Normal file
1
databases/qt-mysql-plugin/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (KDE/qt-x11-free-3.1.2.tar.bz2) = 156591717687799c69cf3f8b64a898f2
|
10
databases/qt-mysql-plugin/files/patch-mysql.pro
Normal file
10
databases/qt-mysql-plugin/files/patch-mysql.pro
Normal file
@ -0,0 +1,10 @@
|
||||
--- plugins/src/sqldrivers/mysql/mysql.pro.orig Wed Aug 6 13:21:58 2003
|
||||
+++ plugins/src/sqldrivers/mysql/mysql.pro Wed Aug 6 13:22:46 2003
|
||||
@@ -10,6 +10,7 @@
|
||||
!contains( LIBS, .*mysql.* ) {
|
||||
LIBS *= -lmysqlclient
|
||||
}
|
||||
+ INCLUDEPATH += ${LOCALBASE}/include/mysql
|
||||
}
|
||||
win32 {
|
||||
OBJECTS_DIR = obj
|
4
databases/qt-mysql-plugin/pkg-descr
Normal file
4
databases/qt-mysql-plugin/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
The MySQL-Plugin from Qt 3, which provides an easy access
|
||||
method from within Qt applications.
|
||||
|
||||
WWW: http://www.trolltech.com/products/qt/database.html
|
2
databases/qt-mysql-plugin/pkg-plist
Normal file
2
databases/qt-mysql-plugin/pkg-plist
Normal file
@ -0,0 +1,2 @@
|
||||
lib/plugins/sqldrivers/libqsqlmysql.so
|
||||
@dirrm lib/plugins/sqldrivers
|
Loading…
Reference in New Issue
Block a user