Update to version 4.5.37.

PR:		12781 (18 of 19)
Submitted by:	Ade Lovett <ade@lovett.com>
This commit is contained in:
Steve Price 1999-08-22 04:04:36 +00:00
parent 2491d2d1ee
commit 0caf05d3b9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=20875
5 changed files with 54 additions and 28 deletions

View File

@ -1,13 +1,13 @@
# New ports collection makefile for: gnomemc
# Version required: 4.5.31
# Version required: 4.5.37
# Date created: 26 January 1999
# Whom: Jeremy Lea <reg@shale.csir.co.za>
#
# $Id: Makefile,v 1.5 1999/05/09 17:16:07 steve Exp $
# $Id: Makefile,v 1.6 1999/05/30 03:57:33 steve Exp $
#
DISTNAME= mc-4.5.31
PKGNAME= gnomemc-4.5.31
DISTNAME= mc-4.5.37
PKGNAME= gnomemc-4.5.37
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/mc

View File

@ -1 +1 @@
MD5 (mc-4.5.31.tar.gz) = ac1e86c7cba7584c7ab7dd1ef5fc28cf
MD5 (mc-4.5.37.tar.gz) = cb2b962d8e349ad579598a31f48a5276

View File

@ -1,6 +1,6 @@
--- configure.orig Tue Feb 16 05:58:53 1999
+++ configure Tue Feb 23 00:58:48 1999
@@ -3269,15 +3269,15 @@
--- configure.orig Tue Jul 13 05:57:18 1999
+++ configure Sun Jul 18 02:09:53 1999
@@ -3383,15 +3383,15 @@
fi
@ -11,8 +11,8 @@
DATADIRNAME=share
- INTLDEPS='$(top_builddir)/intl/libintl.a'
+ INTLDEPS='-lintl'
INTLLIBS=$INTLDEPS
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
INTLLIBS=$INTLDEPS
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
- nls_cv_header_intl=intl/libintl.h
- nls_cv_header_libgt=intl/libgettext.h
+# nls_cv_header_intl=intl/libintl.h
@ -20,7 +20,7 @@
fi
if test "$XGETTEXT" != ":"; then
@@ -10553,7 +10553,7 @@
@@ -10731,7 +10731,7 @@
if test -f /usr/include/ncurses.h
then
echo "$ac_t""Found ncurses on /usr/include/ncurses.h" 1>&6
@ -29,7 +29,7 @@
CURSES_INCLUDEDIR=""
search_ncurses=false
screen_manager="ncurses on /usr/include"
@@ -10681,6 +10681,8 @@
@@ -10859,6 +10859,8 @@
fi
fi
@ -38,3 +38,14 @@
if $search_ncurses
then
@@ -12224,10 +12226,6 @@
*) # Relative path.
ac_sub_cache_file="$ac_dots$cache_file" ;;
esac
- case "$ac_given_INSTALL" in
- [/$]*) INSTALL="$ac_given_INSTALL" ;;
- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
- esac
echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
# The eval makes quoting arguments work.

View File

@ -1,15 +1,15 @@
--- Makefile.in.orig Sat Apr 10 21:38:29 1999
+++ Makefile.in Thu May 6 08:59:05 1999
--- Makefile.in.orig Wed Jul 7 01:43:31 1999
+++ Makefile.in Thu Jul 15 11:26:56 1999
@@ -5,7 +5,7 @@
@MCFGR@@MCF@
foreigndirs=pc
-codedirs=vfs lib doc slang gtkedit edit src gnome new_icons icons idl syntax
-codedirs=vfs lib doc doc-gnome doc-gnome/C doc-gnome/C/figs slang gtkedit edit src gnome new_icons icons idl syntax
+codedirs=vfs lib gtkedit gnome new_icons icons idl syntax
unixdirs=intl $(codedirs) @POSUB@
alldirs=$(unixdirs) $(foreigndirs)
subdirs=$(alldirs)
@@ -46,8 +46,6 @@
@@ -45,8 +45,6 @@
install: installdirs
@for I in $(unixdirs); do cd $$I; $(MAKE) DESTDIR=$(DESTDIR) $@ || exit 1; cd ..; done
$(INSTALL_DATA) $(srcdir)/FAQ $(DESTDIR)$(mclibdir)/FAQ
@ -18,22 +18,24 @@
@echo "Please verify that the configuration values are correctly"
@echo "set in the mc.ext file in $(mclibdir)"
@@ -58,9 +56,8 @@
@@ -58,12 +56,9 @@
installdirs:
$(MKINSTALLDIRS) $(DESTDIR)$(bindir) $(DESTDIR)$(mclibdir)
$(MKINSTALLDIRS) $(DESTDIR)$(mandir) $(DESTDIR)$(man8dir)
- $(MKINSTALLDIRS) $(DESTDIR)$(icondir) $(DESTDIR)$(suppbindir)
- $(MKINSTALLDIRS) $(DESTDIR)$(tidir) $(DESTDIR)$(extfsdir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(icondir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(extfsdir)
$(MKINSTALLDIRS) $(DESTDIR)$(idldir) $(DESTDIR)$(syntaxdir)
+ $(MKINSTALLDIRS) $(DESTDIR)$(icondir) $(DESTDIR)$(extfsdir)
-
-mcfninstall:
- -/bin/sh ./mcfn_install
mcfninstall:
-/bin/sh ./mcfn_install
--- lib/Makefile.in.orig Sat Apr 10 21:38:30 1999
+++ lib/Makefile.in Thu May 6 08:56:26 1999
@@ -16,7 +16,6 @@
uninstall:
@for I in $(unixdirs); do cd $$I; $(MAKE) $@ || exit 1; cd ..; done
--- lib/Makefile.in.orig Tue Mar 30 08:34:36 1999
+++ lib/Makefile.in Wed Apr 7 22:36:45 1999
@@ -16,12 +16,10 @@
LIBFILES_OUT = mc.ext mc-gnome.ext
LIBFILES_CONST = mc.hint mc.lib mc.menu
DESKTOP_FILES = startup.links README.desktop
@ -41,7 +43,12 @@
DISTLIB = \
$(LIBFILES_IN) \
@@ -57,8 +56,6 @@
$(LIBFILES_CONST) \
- $(TIFILES) \
$(DESKTOP_FILES) \
Makefile.in tdiff \
xnc.hlp ncurses.h \
@@ -57,8 +55,6 @@
do $(INSTALL_DATA) $(srcdir)/$$I $(DESTDIR)$(mclibdir)/$$I; done
for I in $(LIBFILES_OUT); \
do $(INSTALL_DATA) $(builddir)/lib/$$I $(DESTDIR)$(mclibdir)/$$I; done

View File

@ -117,22 +117,30 @@ share/gnome/pixmaps/mc/i-regular.png
share/gnome/pixmaps/mc/i-sock.png
share/gnome/pixmaps/mc/i-stalled.png
share/gnome/pixmaps/mc/i-symlink.png
share/gnome/pixmaps/mc/i-zipdisk.png
share/gnome/pixmaps/mc/i-zipdisk2.png
share/gnome/pixmaps/mc/makefile.xpm
share/gnome/pixmaps/mc/sound.xpm
share/gnome/pixmaps/mc/trash.xpm
share/locale/ca/LC_MESSAGES/mc.mo
share/locale/cs/LC_MESSAGES/mc.mo
share/locale/da/LC_MESSAGES/mc.mo
share/locale/de/LC_MESSAGES/mc.mo
share/locale/es/LC_MESSAGES/mc.mo
share/locale/es_ES/LC_MESSAGES/mc.mo
share/locale/fi/LC_MESSAGES/mc.mo
share/locale/fr/LC_MESSAGES/mc.mo
share/locale/hu/LC_MESSAGES/mc.mo
share/locale/it/LC_MESSAGES/mc.mo
share/locale/ja/LC_MESSAGES/mc.mo
share/locale/ko/LC_MESSAGES/mc.mo
share/locale/no/LC_MESSAGES/mc.mo
share/locale/pl/LC_MESSAGES/mc.mo
share/locale/ro/LC_MESSAGES/mc.mo
share/locale/ru/LC_MESSAGES/mc.mo
share/locale/wa/LC_MESSAGES/mc.mo
share/locale/zh_TW.Big5/LC_MESSAGES/mc.mo
@dirrm share/gnome/pixmaps/mc
@dirrm share/gnome/mc/desktop-scripts
@dirrm share/gnome/mc/extfs
@dirrm share/gnome/mc/syntax
@dirrm share/gnome/mc/extfs
@dirrm share/gnome/mc/desktop-scripts