Update thrift ports to 0.11.0.

PR:		225798
Approved by:	maintainer timeout
This commit is contained in:
David Thiel 2018-02-24 20:40:27 +00:00
parent 4f87476727
commit 0ca553a5f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=462862
12 changed files with 33 additions and 26 deletions

View File

@ -3,7 +3,6 @@
PORTNAME= thrift
PORTVERSION= ${THRIFT_PORTVERSION}
PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= APACHE/thrift/${PORTVERSION}
PKGNAMEPREFIX= node-

View File

@ -29,6 +29,8 @@ lib/node_modules/thrift/lib/thrift/framed_transport.js
lib/node_modules/thrift/lib/thrift/http_connection.js
lib/node_modules/thrift/lib/thrift/index.js
lib/node_modules/thrift/lib/thrift/input_buffer_underrun_error.js
lib/node_modules/thrift/lib/thrift/int64_util.js
lib/node_modules/thrift/lib/thrift/json_parse.js
lib/node_modules/thrift/lib/thrift/json_protocol.js
lib/node_modules/thrift/lib/thrift/log.js
lib/node_modules/thrift/lib/thrift/multiplexed_processor.js

View File

@ -3,7 +3,6 @@
PORTNAME= Thrift
PORTVERSION= ${THRIFT_PORTVERSION} # need to keep this in sync with ../thrift see ../thrift/bsd.thrift.mk
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel perl5
PKGNAMEPREFIX= p5-

View File

@ -1,6 +1,7 @@
%%SITE_PERL%%/Thrift.pm
%%SITE_PERL%%/Thrift/BinaryProtocol.pm
%%SITE_PERL%%/Thrift/BufferedTransport.pm
%%SITE_PERL%%/Thrift/Exception.pm
%%SITE_PERL%%/Thrift/FramedTransport.pm
%%SITE_PERL%%/Thrift/HttpClient.pm
%%SITE_PERL%%/Thrift/MemoryBuffer.pm
@ -15,3 +16,6 @@
%%SITE_PERL%%/Thrift/ServerSocket.pm
%%SITE_PERL%%/Thrift/Socket.pm
%%SITE_PERL%%/Thrift/Transport.pm
%%SITE_PERL%%/Thrift/Type.pm
%%SITE_PERL%%/Thrift/UnixServerSocket.pm
%%SITE_PERL%%/Thrift/UnixSocket.pm

View File

@ -1,2 +1,3 @@
SHA256 (rubygem/thrift-0.9.3.0.gem) = 2b8cb950cacd6265ea3d93ef716a5394c6d5de1f560b665098eba2d06fa1574d
SIZE (rubygem/thrift-0.9.3.0.gem) = 72192
TIMESTAMP = 1518214128
SHA256 (rubygem/thrift-0.11.0.0.gem) = 9b6a5489b79f6843abc4f3d9acd4ece6b50ea254fbb5eb0c9c569ecee701e10a
SIZE (rubygem/thrift-0.11.0.0.gem) = 85504

View File

@ -3,7 +3,6 @@
PORTNAME= thrift
PORTVERSION= ${THRIFT_PORTVERSION} # to keep in sync with thrift
PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= APACHE/thrift/${PORTVERSION}

View File

@ -1,11 +1,17 @@
@comment bin/thrift
include/thrift/c_glib/config.h
include/thrift/c_glib/processor/thrift_dispatch_processor.h
include/thrift/c_glib/processor/thrift_multiplexed_processor.h
include/thrift/c_glib/processor/thrift_processor.h
include/thrift/c_glib/protocol/thrift_binary_protocol.h
include/thrift/c_glib/protocol/thrift_binary_protocol_factory.h
include/thrift/c_glib/protocol/thrift_compact_protocol.h
include/thrift/c_glib/protocol/thrift_compact_protocol_factory.h
include/thrift/c_glib/protocol/thrift_multiplexed_protocol.h
include/thrift/c_glib/protocol/thrift_protocol.h
include/thrift/c_glib/protocol/thrift_protocol_decorator.h
include/thrift/c_glib/protocol/thrift_protocol_factory.h
include/thrift/c_glib/protocol/thrift_stored_message_protocol.h
include/thrift/c_glib/server/thrift_server.h
include/thrift/c_glib/server/thrift_simple_server.h
include/thrift/c_glib/thrift.h
@ -13,12 +19,15 @@ include/thrift/c_glib/thrift_application_exception.h
include/thrift/c_glib/thrift_struct.h
include/thrift/c_glib/transport/thrift_buffered_transport.h
include/thrift/c_glib/transport/thrift_buffered_transport_factory.h
include/thrift/c_glib/transport/thrift_fd_transport.h
include/thrift/c_glib/transport/thrift_framed_transport.h
include/thrift/c_glib/transport/thrift_framed_transport_factory.h
include/thrift/c_glib/transport/thrift_memory_buffer.h
include/thrift/c_glib/transport/thrift_platform_socket.h
include/thrift/c_glib/transport/thrift_server_socket.h
include/thrift/c_glib/transport/thrift_server_transport.h
include/thrift/c_glib/transport/thrift_socket.h
include/thrift/c_glib/transport/thrift_ssl_socket.h
include/thrift/c_glib/transport/thrift_transport.h
include/thrift/c_glib/transport/thrift_transport_factory.h
lib/libthrift_c_glib.a

View File

@ -3,7 +3,6 @@
PORTNAME= thrift
PORTVERSION= ${THRIFT_PORTVERSION} # to keep in sync with thrift
PORTREVISION= 12
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= APACHE/thrift/${PORTVERSION}
@ -38,6 +37,7 @@ OPTIONS_SUB= yes
CONFIGURE_ARGS+= \
--without-c_glib \
--with-cpp \
--with-boost-libdir="${LOCALBASE}/lib" \
--without-csharp \
--without-erlang \
--without-haskell \

View File

@ -1,13 +0,0 @@
--- lib/cpp/src/thrift/transport/TSSLSocket.cpp.orig 2015-09-25 02:24:34 UTC
+++ lib/cpp/src/thrift/transport/TSSLSocket.cpp
@@ -139,8 +139,10 @@ static char uppercase(char c);
SSLContext::SSLContext(const SSLProtocol& protocol) {
if (protocol == SSLTLS) {
ctx_ = SSL_CTX_new(SSLv23_method());
+#ifndef OPENSSL_NO_SSL3
} else if (protocol == SSLv3) {
ctx_ = SSL_CTX_new(SSLv3_method());
+#endif
} else if (protocol == TLSv1_0) {
ctx_ = SSL_CTX_new(TLSv1_method());
} else if (protocol == TLSv1_1) {

View File

@ -1,5 +1,6 @@
@comment bin/thrift
include/thrift/TApplicationException.h
include/thrift/TBase.h
include/thrift/TDispatchProcessor.h
include/thrift/TLogging.h
include/thrift/TOutput.h
@ -30,7 +31,6 @@ include/thrift/concurrency/ThreadManager.h
include/thrift/concurrency/TimerManager.h
include/thrift/concurrency/Util.h
include/thrift/config.h
include/thrift/cxxfunctional.h
include/thrift/processor/PeekProcessor.h
include/thrift/processor/StatsProcessor.h
include/thrift/processor/TMultiplexedProcessor.h
@ -40,12 +40,14 @@ include/thrift/protocol/TBinaryProtocol.tcc
include/thrift/protocol/TCompactProtocol.h
include/thrift/protocol/TCompactProtocol.tcc
include/thrift/protocol/TDebugProtocol.h
include/thrift/protocol/THeaderProtocol.h
include/thrift/protocol/TJSONProtocol.h
include/thrift/protocol/TMultiplexedProtocol.h
include/thrift/protocol/TProtocol.h
include/thrift/protocol/TProtocolDecorator.h
include/thrift/protocol/TProtocolException.h
include/thrift/protocol/TProtocolTap.h
include/thrift/protocol/TProtocolTypes.h
include/thrift/protocol/TVirtualProtocol.h
include/thrift/qt/TQIODeviceTransport.h
include/thrift/qt/TQTcpServer.h
@ -56,14 +58,19 @@ include/thrift/server/TServerFramework.h
include/thrift/server/TSimpleServer.h
include/thrift/server/TThreadPoolServer.h
include/thrift/server/TThreadedServer.h
include/thrift/stdcxx.h
include/thrift/thrift-config.h
include/thrift/transport/PlatformSocket.h
include/thrift/transport/TBufferTransports.h
include/thrift/transport/TFDTransport.h
include/thrift/transport/TFileTransport.h
include/thrift/transport/THeaderTransport.h
include/thrift/transport/THttpClient.h
include/thrift/transport/THttpServer.h
include/thrift/transport/THttpTransport.h
include/thrift/transport/TNonblockingSSLServerSocket.h
include/thrift/transport/TNonblockingServerSocket.h
include/thrift/transport/TNonblockingServerTransport.h
include/thrift/transport/TPipe.h
include/thrift/transport/TPipeServer.h
include/thrift/transport/TSSLServerSocket.h
@ -79,7 +86,7 @@ include/thrift/transport/TTransportException.h
include/thrift/transport/TTransportUtils.h
include/thrift/transport/TVirtualTransport.h
include/thrift/transport/TZlibTransport.h
lib/libthrift-0.9.3.so
lib/libthrift-%%PORTVERSION%%.so
lib/libthrift.a
lib/libthrift.so
lib/libthrift.so.0
@ -91,7 +98,7 @@ lib/libthriftnb.so.0
%%QT4%%lib/libthriftqt.a
%%QT4%%lib/libthriftqt.so
%%QT4%%lib/libthriftqt.so.0
lib/libthriftz-0.9.3.so
lib/libthriftz-%%PORTVERSION%%.so
lib/libthriftz.a
lib/libthriftz.so
lib/libthriftz.so.0

View File

@ -5,8 +5,7 @@
# in your makefile, set:
# PORTVERSION= ${THRIFT_PORTVERSION}
# see $PORTSDIR/devel/thrift for examples
THRIFT_PORTVERSION= 0.9.3
THRIFT_PORTREVISION= 1
THRIFT_PORTVERSION= 0.11.0
CONFIGURE_ARGS+= \
--without-tests

View File

@ -1,2 +1,3 @@
SHA256 (thrift-0.9.3.tar.gz) = b0740a070ac09adde04d43e852ce4c320564a292f26521c46b78e0641564969e
SIZE (thrift-0.9.3.tar.gz) = 8897936
TIMESTAMP = 1518215832
SHA256 (thrift-0.11.0.tar.gz) = c4ad38b6cb4a3498310d405a91fef37b9a8e79a50cd0968148ee2524d2fa60c2
SIZE (thrift-0.11.0.tar.gz) = 3667154