Add json-c 0.6, a JSON (Javascript Object Notation) implementation in C.

PR:		ports/99391
Submitted by:	gno_at_yahoo-inc.com
This commit is contained in:
Vanilla I. Shu 2006-06-24 10:04:04 +00:00
parent 9582a037cb
commit 0c9f5c2ff9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=166184
7 changed files with 69 additions and 0 deletions

View File

@ -434,6 +434,7 @@
SUBDIR += jep
SUBDIR += jrtplib
SUBDIR += jsap
SUBDIR += json-c
SUBDIR += jude-community
SUBDIR += judy
SUBDIR += kaptain

22
devel/json-c/Makefile Normal file
View File

@ -0,0 +1,22 @@
# New ports collection makefile for: json-c
# Date created: June 23 2006
# Whom: gno@yahoo-inc.com
#
# $FreeBSD$
#
PORTNAME= json-c
PORTVERSION= 0.6
CATEGORIES= devel
MASTER_SITES= http://oss.metaparadigm.com/json-c/
MAINTAINER= gno@yahoo-inc.com
COMMENT= A JSON (Javascript Object Notation) implementation in C
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnometarget
#USE_AUTOTOOLS= automake:14
.include <bsd.port.mk>

3
devel/json-c/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (json-c-0.6.tar.gz) = 2d8b899aeeebbbe68158d25adf8a4f1e
SHA256 (json-c-0.6.tar.gz) = 915ee6c4b8f1ffd5313d990875cd44e5e7092a51de259707daca797fd5c42b46
SIZE (json-c-0.6.tar.gz) = 320050

View File

@ -0,0 +1,16 @@
--- Makefile.in.orig Sat Jun 24 18:00:48 2006
+++ Makefile.in Sat Jun 24 18:01:16 2006
@@ -85,11 +85,11 @@
STRIP = @STRIP@
VERSION = @VERSION@
-CFLAGS = -Wall -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+CFLAGS = -Wall -D_GNU_SOURCE -D_REENTRANT
lib_LTLIBRARIES = libjson.la
-pkgconfigdir = $(libdir)/pkgconfig
+pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = json.pc
libjsonincludedir = $(includedir)/json

View File

@ -0,0 +1,8 @@
--- Makefile.am.orig Mon Jun 12 12:17:41 2006
+++ Makefile.am Mon Jun 12 12:17:52 2006
@@ -1,4 +1,4 @@
-CFLAGS = -Wall -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
+CFLAGS = -Wall -D_GNU_SOURCE -D_REENTRANT
lib_LTLIBRARIES = libjson.la

5
devel/json-c/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
This is a port of json-c, an implementation of json in C. Json, JavaScript
Object Notation is a lightweight data exchange format and a subset of the
JavaScript programming language.
WWW: http://oss.metaparadigm.com/json-c/

14
devel/json-c/pkg-plist Normal file
View File

@ -0,0 +1,14 @@
lib/libjson.a
lib/libjson.la
lib/libjson.so
lib/libjson.so.0
include/json/arraylist.h
include/json/bits.h
include/json/debug.h
include/json/json.h
include/json/json_object.h
include/json/json_tokener.h
include/json/json_util.h
include/json/linkhash.h
libdata/pkgconfig/json.pc
@dirrm include/json