New port: audio/synthv1-lv2: Old-school polyphonic synthesizer

This commit is contained in:
Yuri Victorovich 2018-10-28 21:22:02 +00:00
parent 68eda17349
commit 0c68bfa1be
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=483356
6 changed files with 76 additions and 0 deletions

View File

@ -815,6 +815,7 @@
SUBDIR += swh-lv2
SUBDIR += swhplugins
SUBDIR += synthpod-lv2
SUBDIR += synthv1-lv2
SUBDIR += taglib
SUBDIR += taglib-extras
SUBDIR += taglib-sharp

View File

@ -0,0 +1,30 @@
# $FreeBSD$
PORTNAME= synthv1
DISTVERSIONPREFIX= ${PORTNAME}_
DISTVERSION= 0_9_3
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
MAINTAINER= yuri@FreeBSD.org
COMMENT= Old-school polyphonic synthesizer
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= lv2>0:audio/lv2
LIB_DEPENDS= libjack.so:audio/jack \
liblo.so:audio/liblo
USES= autoreconf gl gmake pkgconfig qt:5 shared-mime-info
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= rncbc
USE_GL= gl
USE_QT= core gui widgets xml buildtools_build qmake_build
PLIST_SUB= SHL3=${PORTVERSION} SHL2=${PORTVERSION:R}
CONFIGURE_ARGS= --disable-alsa-midi
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1540761275
SHA256 (rncbc-synthv1-synthv1_0_9_3_GH0.tar.gz) = 70f3e3bb5a6a828f7fb4f4225a16360f9738a3c40ffcaad6c51c4c0321c086ca
SIZE (rncbc-synthv1-synthv1_0_9_3_GH0.tar.gz) = 209305

View File

@ -0,0 +1,10 @@
--- src/synthv1_jack.cpp.orig 2018-10-28 21:16:24 UTC
+++ src/synthv1_jack.cpp
@@ -32,6 +32,7 @@
#include <string.h>
#include <math.h>
+#include <unistd.h>
#include <QCoreApplication>
#include <QDir>

View File

@ -0,0 +1,9 @@
synthv1 is an old-school all-digital 4-oscillator subtractive polyphonic
synthesizer with stereo fx.
Features:
* a pure stand-alone JACK client with JACK-session, NSM (Non Session management)
and both JACK MIDI and ALSA MIDI input support;
* a LV2 instrument plug-in.
WWW: https://synthv1.sourceforge.io/

View File

@ -0,0 +1,23 @@
bin/synthv1_jack
lib/libsynthv1.so
lib/libsynthv1.so.0
lib/libsynthv1.so.%%SHL2%%
lib/libsynthv1.so.%%SHL3%%
lib/libsynthv1_ui.so
lib/libsynthv1_ui.so.0
lib/libsynthv1_ui.so.%%SHL2%%
lib/libsynthv1_ui.so.%%SHL3%%
lib/lv2/synthv1.lv2/manifest.ttl
lib/lv2/synthv1.lv2/synthv1.so
lib/lv2/synthv1.lv2/synthv1.ttl
lib/lv2/synthv1.lv2/synthv1_ui.so
lib/lv2/synthv1.lv2/synthv1_ui.ttl
man/man1/synthv1.1.gz
man/man1/synthv1.fr.1.gz
share/applications/synthv1.desktop
share/icons/hicolor/32x32/apps/synthv1.png
share/icons/hicolor/32x32/mimetypes/application-x-synthv1-preset.png
share/icons/hicolor/scalable/apps/synthv1.svg
share/icons/hicolor/scalable/mimetypes/application-x-synthv1-preset.svg
share/metainfo/synthv1.appdata.xml
share/mime/packages/synthv1.xml