Update to 0.10.15.
Submitted by: ahze
This commit is contained in:
parent
680f8376b3
commit
0c56bfb5f0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203167
@ -3,7 +3,7 @@
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/multimedia/gstreamer-plugins/Makefile,v 1.100 2006/09/14 21:02:22 ahze Exp $
|
||||
# $MCom: ports-stable/multimedia/gstreamer-plugins/Makefile,v 1.1 2007/12/02 17:08:48 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= gstreamer
|
||||
@ -31,7 +31,7 @@ LIB_DEPENDS+= gstreamer-0.10.0:${PORTSDIR}/multimedia/gstreamer \
|
||||
|
||||
CFLAGS:= ${CFLAGS} -O2
|
||||
|
||||
BASE_PORTVERSION= 0.10.14
|
||||
BASE_PORTVERSION= 0.10.15
|
||||
BASE_DISTNAME= gst-plugins-base-${BASE_PORTVERSION}
|
||||
BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
|
||||
BAD_PORTVERSION= 0.10.5
|
||||
|
@ -1,5 +1,5 @@
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/multimedia/gstreamer-plugins/Makefile.common,v 1.63 2006/09/29 23:22:28 ahze Exp $
|
||||
# $MCom: ports-stable/multimedia/gstreamer-plugins/Makefile.common,v 1.1 2007/12/02 17:08:48 ahze Exp $
|
||||
# base
|
||||
BASE_GST_ALL_PLUGINS= \
|
||||
alsa \
|
||||
|
@ -1,6 +1,6 @@
|
||||
MD5 (gst-plugins-base-0.10.14.tar.bz2) = ef9bcc88c84e47684a901da339a7c6b3
|
||||
SHA256 (gst-plugins-base-0.10.14.tar.bz2) = ffd88d23227f54aae30fdc0ef60ea8eaffe8cc03c069b234ed23c4ea82dcff46
|
||||
SIZE (gst-plugins-base-0.10.14.tar.bz2) = 1625388
|
||||
MD5 (gst-plugins-base-0.10.15.tar.bz2) = 8449359b465074433fec626778bcf36f
|
||||
SHA256 (gst-plugins-base-0.10.15.tar.bz2) = 143a0fa2c0afffdca6b4707af8cf4cac15b405656272fd1e37db19fdc408fd16
|
||||
SIZE (gst-plugins-base-0.10.15.tar.bz2) = 1783866
|
||||
MD5 (gst-plugins-bad-0.10.5.tar.bz2) = 395f3ed705928e77e5620cccf11a8cff
|
||||
SHA256 (gst-plugins-bad-0.10.5.tar.bz2) = 9ac7eb27c9975d4cd24cd3da9b457e69790e4a8cbec75077f0f42fc8b0060eed
|
||||
SIZE (gst-plugins-bad-0.10.5.tar.bz2) = 1402345
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- gst-libs/gst/sdp/gstsdpmessage.c.orig 2007-12-02 11:51:45.000000000 -0500
|
||||
+++ gst-libs/gst/sdp/gstsdpmessage.c 2007-12-02 11:52:01.000000000 -0500
|
||||
@@ -64,7 +64,7 @@
|
||||
#ifdef HAVE_SYS_TYPES_H
|
||||
#include <sys/types.h>
|
||||
#endif
|
||||
-
|
||||
+#include <netinet/in.h>
|
||||
#include <glib.h> /* for G_OS_WIN32 */
|
||||
|
||||
#ifdef G_OS_WIN32
|
@ -11,6 +11,11 @@ include/gstreamer-%%VERSION%%/gst/audio/mixerutils.h
|
||||
include/gstreamer-%%VERSION%%/gst/audio/multichannel-enumtypes.h
|
||||
include/gstreamer-%%VERSION%%/gst/audio/multichannel.h
|
||||
include/gstreamer-%%VERSION%%/gst/cdda/gstcddabasesrc.h
|
||||
include/gstreamer-%%VERSION%%/gst/fft/gstfft.h
|
||||
include/gstreamer-%%VERSION%%/gst/fft/gstfftf32.h
|
||||
include/gstreamer-%%VERSION%%/gst/fft/gstfftf64.h
|
||||
include/gstreamer-%%VERSION%%/gst/fft/gstffts16.h
|
||||
include/gstreamer-%%VERSION%%/gst/fft/gstffts32.h
|
||||
include/gstreamer-%%VERSION%%/gst/floatcast/floatcast.h
|
||||
include/gstreamer-%%VERSION%%/gst/interfaces/colorbalance.h
|
||||
include/gstreamer-%%VERSION%%/gst/interfaces/colorbalancechannel.h
|
||||
@ -38,6 +43,7 @@ include/gstreamer-%%VERSION%%/gst/rtp/gstbasertpdepayload.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtp/gstbasertppayload.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtp/gstrtcpbuffer.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtp/gstrtpbuffer.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtp/gstrtppayloads.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtsp-enumtypes.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtspbase64.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtspconnection.h
|
||||
@ -49,6 +55,7 @@ include/gstreamer-%%VERSION%%/gst/rtsp/gstrtsptransport.h
|
||||
include/gstreamer-%%VERSION%%/gst/rtsp/gstrtspurl.h
|
||||
include/gstreamer-%%VERSION%%/gst/sdp/gstsdp.h
|
||||
include/gstreamer-%%VERSION%%/gst/sdp/gstsdpmessage.h
|
||||
include/gstreamer-%%VERSION%%/gst/tag/gsttagdemux.h
|
||||
include/gstreamer-%%VERSION%%/gst/tag/tag.h
|
||||
include/gstreamer-%%VERSION%%/gst/video/gstvideofilter.h
|
||||
include/gstreamer-%%VERSION%%/gst/video/gstvideosink.h
|
||||
@ -127,6 +134,10 @@ lib/libgstcdda-%%VERSION%%.a
|
||||
lib/libgstcdda-%%VERSION%%.la
|
||||
lib/libgstcdda-%%VERSION%%.so
|
||||
lib/libgstcdda-%%VERSION%%.so.0
|
||||
lib/libgstfft-%%VERSION%%.a
|
||||
lib/libgstfft-%%VERSION%%.la
|
||||
lib/libgstfft-%%VERSION%%.so
|
||||
lib/libgstfft-%%VERSION%%.so.0
|
||||
lib/libgstinterfaces-%%VERSION%%.a
|
||||
lib/libgstinterfaces-%%VERSION%%.la
|
||||
lib/libgstinterfaces-%%VERSION%%.so
|
||||
@ -166,19 +177,25 @@ lib/libgstvideo-%%VERSION%%.so.0
|
||||
libdata/pkgconfig/gstreamer-plugins-base-%%VERSION%%.pc
|
||||
share/locale/af/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/az/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/bg/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/cs/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/da/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/de/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/en_GB/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/es/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/fi/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/hu/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/it/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/nb/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/nl/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/or/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/pl/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/sq/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/sr/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/sv/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/uk/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/vi/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/video
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/tag
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/sdp
|
||||
@ -189,5 +206,6 @@ share/locale/vi/LC_MESSAGES/gst-plugins-base-%%VERSION%%.mo
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/netbuffer
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/interfaces
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/floatcast
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/fft
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/cdda
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/audio
|
||||
|
@ -3,12 +3,11 @@
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
# $MCom: ports/multimedia/gstreamer/Makefile,v 1.52 2006/09/14 20:51:42 ahze Exp $
|
||||
# $MCom: ports-stable/multimedia/gstreamer/Makefile,v 1.1 2007/12/02 16:39:58 ahze Exp $
|
||||
#
|
||||
|
||||
PORTNAME= gstreamer
|
||||
PORTVERSION= 0.10.14
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.10.15
|
||||
CATEGORIES= multimedia
|
||||
MASTER_SITES= http://gstreamer.freedesktop.org/src/gstreamer/ \
|
||||
${MASTER_SITE_LOCAL}
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (gstreamer-0.10.14.tar.bz2) = eb83767c877990c8a7540693d196c822
|
||||
SHA256 (gstreamer-0.10.14.tar.bz2) = e684179e63262c7271dbc50e64ead205cae013daac7264d8effbf60fed3f2438
|
||||
SIZE (gstreamer-0.10.14.tar.bz2) = 2004318
|
||||
MD5 (gstreamer-0.10.15.tar.bz2) = 09f1c4ea025faef88b566fa26ec24ae0
|
||||
SHA256 (gstreamer-0.10.15.tar.bz2) = 581bc480fadeace5be05291dae634065e56986d13037fbcee0ba126cb9435abb
|
||||
SIZE (gstreamer-0.10.15.tar.bz2) = 2158226
|
||||
|
@ -21,6 +21,7 @@ include/gstreamer-%%VERSION%%/gst/base/gsttypefindhelper.h
|
||||
include/gstreamer-%%VERSION%%/gst/controller/gstcontroller.h
|
||||
include/gstreamer-%%VERSION%%/gst/controller/gstcontrolsource.h
|
||||
include/gstreamer-%%VERSION%%/gst/controller/gstinterpolationcontrolsource.h
|
||||
include/gstreamer-%%VERSION%%/gst/controller/gstlfocontrolsource.h
|
||||
include/gstreamer-%%VERSION%%/gst/dataprotocol/dataprotocol.h
|
||||
include/gstreamer-%%VERSION%%/gst/glib-compat.h
|
||||
include/gstreamer-%%VERSION%%/gst/gst.h
|
||||
@ -32,6 +33,7 @@ include/gstreamer-%%VERSION%%/gst/gstchildproxy.h
|
||||
include/gstreamer-%%VERSION%%/gst/gstclock.h
|
||||
include/gstreamer-%%VERSION%%/gst/gstcompat.h
|
||||
include/gstreamer-%%VERSION%%/gst/gstconfig.h
|
||||
include/gstreamer-%%VERSION%%/gst/gstdebugutils.h
|
||||
include/gstreamer-%%VERSION%%/gst/gstelement.h
|
||||
include/gstreamer-%%VERSION%%/gst/gstelementfactory.h
|
||||
include/gstreamer-%%VERSION%%/gst/gstenumtypes.h
|
||||
@ -111,18 +113,24 @@ libdata/pkgconfig/gstreamer-net-%%VERSION%%.pc
|
||||
share/aclocal/gst-element-check-%%VERSION%%.m4
|
||||
share/locale/af/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/az/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/be/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/bg/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/ca/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/cs/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/da/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/de/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/en_GB/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/es/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/fi/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/fr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/hu/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/it/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/nb/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/nl/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/pl/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/ru/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/rw/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/sk/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/sq/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/sr/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/sv/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
@ -131,6 +139,8 @@ share/locale/uk/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/vi/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/gstreamer-%%VERSION%%.mo
|
||||
@dirrmtry share/locale/rw/LC_MESSAGES
|
||||
@dirrmtry share/locale/rw
|
||||
@dirrm lib/gstreamer-%%VERSION%%
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/net
|
||||
@dirrm include/gstreamer-%%VERSION%%/gst/dataprotocol
|
||||
|
Loading…
Reference in New Issue
Block a user