Update to GDB 6.3. This also requires a patch from Theodore Roth,

see http://sources.redhat.com/ml/gdb-patches/2004-10/msg00324.html
This commit is contained in:
Joerg Wunsch 2005-02-05 22:42:11 +00:00
parent d2734c1894
commit 0c48427350
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128105
4 changed files with 27 additions and 8 deletions

View File

@ -5,26 +5,27 @@
# $FreeBSD$
#
PORTNAME= avr-gdb
PORTVERSION= 5.3
PORTREVISION= 1
PORTNAME= gdb
PORTVERSION= 6.3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= gdb/releases
PKGNAMEPREFIX= avr
DISTNAME= gdb-${PORTVERSION}
MAINTAINER= joerg@FreeBSD.org
COMMENT= GNU GDB 5.2.1 for the AVR target
COMMENT= GNU GDB for the AVR target
USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr --program-prefix=avr
CONFIGURE_ARGS= --target=avr --program-prefix=avr --disable-nls
pre-configure:
cd ${WRKSRC} ; ${RM} -rf dejagnu expect sim tcl texinfo
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb \
${PREFIX}/bin/${PORTNAME}
${PREFIX}/bin/${PKGNAMEPREFIX}-${PORTNAME}
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
MD5 (gdb-5.3.tar.gz) = 1e8566325f222edfbdd93e40c6ae921b
SIZE (gdb-5.3.tar.gz) = 14707600
MD5 (gdb-6.3.tar.bz2) = 05b928f41fa5b482e49ca2c24762a0ae
SIZE (gdb-6.3.tar.bz2) = 13446729

View File

@ -0,0 +1,16 @@
Index: gdb/symfile.c
===================================================================
RCS file: /cvs/src/src/gdb/symfile.c,v
retrieving revision 1.143
diff -u -p -p -r1.143 symfile.c
--- symfile.c 1 Oct 2004 10:23:09 -0000 1.143
+++ symfile.c 19 Oct 2004 20:07:58 -0000
@@ -1405,7 +1405,7 @@ load_section_callback (bfd *abfd, asecti
struct cleanup *old_chain;
CORE_ADDR lma = bfd_section_lma (abfd, asec) + args-&gt;load_offset;
bfd_size_type block_size;
- int err;
+ int err = 0;
const char *sect_name = bfd_get_section_name (abfd, asec);
bfd_size_type sent;

View File

@ -4,3 +4,5 @@ target.
This debugger cannot really be used standalone, but is useful in
connection with either AVaRICE (http://avarice.sourceforge.net/)
or simulavr (http://www.freesoftware.fsf.org/simulavr/).
WWW: http://www.gnu.org/software/gdb/