devel/cpprestsdk: purge bogus patch file and unset WERROR instead

While here, remove needless -Wno-c11-extensions from the CXXFLAGS.
This commit is contained in:
Alexey Dokuchaev 2022-10-08 18:51:40 +00:00
parent 2331f637a4
commit 0c34c5fd80
2 changed files with 1 additions and 14 deletions

View File

@ -18,9 +18,7 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= Microsoft
WRKSRC_SUBDIR= Release
CMAKE_OFF= BUILD_SAMPLES BUILD_TESTS
CXXFLAGS+= -Wno-c11-extensions
CMAKE_OFF= BUILD_SAMPLES BUILD_TESTS WERROR
OPTIONS_DEFINE= BROTLI

View File

@ -1,11 +0,0 @@
--- src/CMakeLists.txt.orig 2022-10-06 15:08:19 UTC
+++ src/CMakeLists.txt
@@ -187,7 +187,7 @@ configure_pch(cpprest stdafx.h pch/stdafx.cpp /Zm120)
if(CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "GNU")
if(WERROR)
- target_compile_options(cpprest PRIVATE -Werror)
+ target_compile_options(cpprest PRIVATE -Wno-error)
endif()
target_compile_options(cpprest PRIVATE -pedantic ${WARNINGS})
elseif(CMAKE_CXX_COMPILER_ID MATCHES "MSVC")