Upgrade to 1.11, and portlint.

This commit is contained in:
Vanilla I. Shu 1998-03-12 02:55:17 +00:00
parent fa18db5a45
commit 0c2179c3af
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=10121
3 changed files with 40 additions and 55 deletions

View File

@ -1,21 +1,21 @@
# Port makefile for: oneko
# Version required: 1pl10
# New ports collection makefile for: xautolock
# Version required: 1pl11
# Date created: 20 Jul 1996
# Whom: Eric Blood <eblood@cs.unr.edu>
#
# $Id: Makefile,v 1.1.1.1 1996/08/16 07:54:26 asami Exp $
# $Id: Makefile,v 1.2 1996/11/18 09:55:42 asami Exp $
#
DISTNAME= xautolock-1pl10
PKGNAME= xautolock-1.10
DISTNAME= xautolock-pl11
PKGNAME= xautolock-1.11
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= applications
DISTFILES= xautolock.pl10.tz
EXTRACT_SUFX= .tz
MAINTAINER= eblood@cs.unr.edu
USE_IMAKE= yes
WRKSRC= ${WRKDIR}/xautolock.pl10
WRKSRC= ${WRKDIR}/xautolock-pl11
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (xautolock.pl10.tz) = eac946325729f6b773e21618704ab5db
MD5 (xautolock-pl11.tz) = 06e0cdd98aa7645366a31f4b895801bc

View File

@ -1,47 +1,32 @@
*** xautolock.c.orig Sat Jul 20 17:32:41 1996
--- xautolock.c Sat Jul 20 17:56:41 1996
***************
*** 196,201 ****
--- 196,203 ----
* with vroot.h, because it needs to know the real root window.
*/
+ #include <sys/param.h>
+
#if defined(hpux) || defined (__hpux)
#ifndef _HPUX_SOURCE
#define _HPUX_SOURCE
***************
*** 235,241 ****
--- 237,247 ----
#endif /* !NOSTDHDRS */
#if !defined (apollo) && !defined (VMS)
+
+ #if !defined (BSD)
#include <malloc.h>
+ #endif /* !BSD */
+
#include <unistd.h>
#endif /* !apollo && !VMS */
***************
*** 1587,1593 ****
#else /* VMS */
if (locker_pid)
{
! #if !defined (UTEKV) && !defined (SYSV) && !defined(SVR4)
union wait status; /* childs process status */
#else /* !UTEKV && !SYSV && !SVR4 */
int status; /* childs process status */
--- 1593,1602 ----
#else /* VMS */
if (locker_pid)
{
!
! #if defined (BSD)
! int status;
! #elif !defined (UTEKV) && !defined (SYSV) && !defined(SVR4)
union wait status; /* childs process status */
#else /* !UTEKV && !SYSV && !SVR4 */
int status; /* childs process status */
--- xautolock.c.orig Thu Oct 30 19:41:58 1997
+++ xautolock.c Thu Mar 12 10:52:02 1998
@@ -248,6 +248,8 @@
* with vroot.h, because it needs to know the real root window.
*/
+#include <sys/param.h>
+
#if defined(hpux) || defined (__hpux)
#ifndef _HPUX_SOURCE
#define _HPUX_SOURCE
@@ -308,7 +310,9 @@
#endif /* !NOSTDHDRS */
#if !defined (apollo) && !defined (VMS)
+#if !defined (BSD)
#include <malloc.h>
+#endif /* !BSD */
#include <unistd.h>
#endif /* !apollo && !VMS */
@@ -1842,7 +1846,9 @@
#else /* VMS */
if (locker_pid)
{
-#if !defined (UTEKV) && !defined (SYSV) && !defined(SVR4)
+#if defined (BSD)
+ int status;
+#elif !defined (UTEKV) && !defined (SYSV) && !defined(SVR4)
union wait status; /* childs process status */
#else /* !UTEKV && !SYSV && !SVR4 */
int status = 0; /* childs process status */