x11-themes/qogir-icon-themes: add new port

A flat colorful design icon theme for linux desktops

https://github.com/vinceliuice/Qogir-icon-theme

PR:		252775
Reviewed by:	tcberner
Differential Revision:	https://reviews.freebsd.org/D28208
This commit is contained in:
Alexander Vereeken 2021-01-02 17:56:19 +00:00 committed by Jan Beich
parent 823dccc5d2
commit 0c158f15bb
6 changed files with 85189 additions and 0 deletions

View File

@ -141,6 +141,7 @@
SUBDIR += pop-icon-theme
SUBDIR += qgnomeplatform
SUBDIR += qogir-gtk-themes
SUBDIR += qogir-icon-themes
SUBDIR += qt5-style-plugins
SUBDIR += qtcurve
SUBDIR += qtcurve-gtk2

View File

@ -0,0 +1,30 @@
# Created by: Alexander Vereeken <Alexander88207@protonmail.com>
PORTNAME= qogir-icon-themes
DISTVERSION= 2020-11-22
CATEGORIES= x11-themes
MAINTAINER= Alexander88207@protonmail.com
COMMENT= Flat colorful design icon theme for linux desktops
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= bash>0:shells/bash \
gsed:textproc/gsed
USES= shebangfix
SHEBANG_FILES= install.sh
INSTALLS_ICONS= yes
USE_GITHUB= yes
GH_ACCOUNT= vinceliuice
GH_PROJECT= Qogir-icon-theme
NO_ARCH= yes
NO_BUILD= yes
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
${WRKSRC}/install.sh -d ${STAGEDIR}${PREFIX}/share/icons
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1609610179
SHA256 (vinceliuice-Qogir-icon-theme-2020-11-22_GH0.tar.gz) = 865af80b101850728ba5bbb3a8e38d15074d2f5f5cb2b13203c51ea4ce45a3c1
SIZE (vinceliuice-Qogir-icon-theme-2020-11-22_GH0.tar.gz) = 6242726

View File

@ -0,0 +1,54 @@
--- install.sh.orig 2020-11-22 14:20:00 UTC
+++ install.sh
@@ -37,34 +37,34 @@ install() {
echo "Installing '${THEME_DIR}'..."
mkdir -p "${THEME_DIR}"
- cp -r "${SRC_DIR}/COPYING" "${THEME_DIR}"
- cp -r "${SRC_DIR}/AUTHORS" "${THEME_DIR}"
- cp -r "${SRC_DIR}/src/index.theme" "${THEME_DIR}"
- cp -r "${SRC_DIR}/src/cursors/dist${theme}${color}/cursors" "${THEME_DIR}"
+ cp -R "${SRC_DIR}/COPYING" "${THEME_DIR}"
+ cp -R "${SRC_DIR}/AUTHORS" "${THEME_DIR}"
+ cp -R "${SRC_DIR}/src/index.theme" "${THEME_DIR}"
+ cp -R "${SRC_DIR}/src/cursors/dist${theme}${color}/cursors" "${THEME_DIR}"
cd "${THEME_DIR}" || exit 1
- sed -i "s/${name}/${name}${theme}${color}/g" index.theme
+ gsed -i "s/${name}/${name}${theme}${color}/g" index.theme
if [[ ${color} == '' ]]; then
- cp -r "${SRC_DIR}"/src/{16,22,24,32,48,96,128,scalable,symbolic} "${THEME_DIR}"
- cp -r "${SRC_DIR}"/links/{16,22,24,32,48,96,128,scalable,symbolic} "${THEME_DIR}"
+ cp -R "${SRC_DIR}"/src/{16,22,24,32,48,96,128,scalable,symbolic} "${THEME_DIR}"
+ cp -R "${SRC_DIR}"/links/{16,22,24,32,48,96,128,scalable,symbolic} "${THEME_DIR}"
[[ ${theme} != '' ]] && \
- cp -r "${SRC_DIR}"/src/theme"${theme}"/* "${THEME_DIR}"
+ cp -R "${SRC_DIR}"/src/theme"${theme}"/* "${THEME_DIR}"
else
mkdir -p "${THEME_DIR}/16"
mkdir -p "${THEME_DIR}/22"
mkdir -p "${THEME_DIR}/24"
- cp -r "${SRC_DIR}"/src/16/{actions,places,devices} "${THEME_DIR}/16"
- cp -r "${SRC_DIR}"/src/22/{actions,places,devices} "${THEME_DIR}/22"
- cp -r "${SRC_DIR}"/src/24/{actions,places,devices} "${THEME_DIR}/24"
+ cp -R "${SRC_DIR}"/src/16/{actions,places,devices} "${THEME_DIR}/16"
+ cp -R "${SRC_DIR}"/src/22/{actions,places,devices} "${THEME_DIR}/22"
+ cp -R "${SRC_DIR}"/src/24/{actions,places,devices} "${THEME_DIR}/24"
- sed -i "s/#5d656b/#d3dae3/g" "${THEME_DIR}"/{16,22,24}/actions/*
- sed -i "s/#5d656b/#d3dae3/g" "${THEME_DIR}"/{16,22,24}/places/*
- sed -i "s/#5d656b/#d3dae3/g" "${THEME_DIR}"/{16,22,24}/devices/*
+ gsed -i "s/#5d656b/#d3dae3/g" "${THEME_DIR}"/{16,22,24}/actions/*
+ gsed -i "s/#5d656b/#d3dae3/g" "${THEME_DIR}"/{16,22,24}/places/*
+ gsed -i "s/#5d656b/#d3dae3/g" "${THEME_DIR}"/{16,22,24}/devices/*
- cp -r "${SRC_DIR}"/links/16/{actions,places,devices} "${THEME_DIR}/16"
- cp -r "${SRC_DIR}"/links/22/{actions,places,devices} "${THEME_DIR}/22"
- cp -r "${SRC_DIR}"/links/24/{actions,places,devices} "${THEME_DIR}/24"
+ cp -R "${SRC_DIR}"/links/16/{actions,places,devices} "${THEME_DIR}/16"
+ cp -R "${SRC_DIR}"/links/22/{actions,places,devices} "${THEME_DIR}/22"
+ cp -R "${SRC_DIR}"/links/24/{actions,places,devices} "${THEME_DIR}/24"
cd "${dest}" || exit 1
ln -sf "../${name}${theme}/scalable" "${name}${theme}-dark/scalable"

View File

@ -0,0 +1,3 @@
A flat colorful design icon theme for linux desktops
WWW: https://github.com/vinceliuice/Qogir-icon-theme

File diff suppressed because it is too large Load Diff