Unbreak build for FreeBSD >= 5.x.
This commit is contained in:
parent
75838a2fb7
commit
0c13fa71e5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=129889
@ -27,10 +27,6 @@ DOCS= HVSC_Update.txt SID_file_format.txt
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 502112
|
||||
BROKEN= "Does not compile on FreeBSD >= 5.x"
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/Update ${PREFIX}/bin/HVSC-Update
|
||||
.if !defined(NOPORTDOCS)
|
||||
|
23
audio/HVSC-Update/files/patch-src-TextFile.h
Normal file
23
audio/HVSC-Update/files/patch-src-TextFile.h
Normal file
@ -0,0 +1,23 @@
|
||||
--- src/TextFile.h.orig Fri Mar 29 19:35:26 2002
|
||||
+++ src/TextFile.h Sun Feb 27 15:03:16 2005
|
||||
@@ -10,12 +10,18 @@
|
||||
#endif
|
||||
#include <ctype.h>
|
||||
#include <fstream.h>
|
||||
-#include <iostream.h>
|
||||
+#include <iostream>
|
||||
+using namespace std;
|
||||
#include <string.h>
|
||||
#if defined(HAVE_STRSTREA_H)
|
||||
#include <strstrea.h>
|
||||
#else
|
||||
-#include <strstream.h>
|
||||
+#include "strstream"
|
||||
+
|
||||
+using std::strstreambuf;
|
||||
+using std::istrstream;
|
||||
+using std::ostrstream;
|
||||
+using std::strstream;
|
||||
#endif
|
||||
|
||||
#include "fformat.h" // strnicmp stuff
|
16
audio/HVSC-Update/files/patch-src-include-fformat.h
Normal file
16
audio/HVSC-Update/files/patch-src-include-fformat.h
Normal file
@ -0,0 +1,16 @@
|
||||
--- src/include/fformat.h.orig Fri Mar 29 19:35:26 2002
|
||||
+++ src/include/fformat.h Sun Feb 27 13:52:05 2005
|
||||
@@ -13,7 +13,12 @@
|
||||
#if defined(HAVE_STRSTREA_H)
|
||||
#include <strstrea.h>
|
||||
#else
|
||||
- #include <strstream.h>
|
||||
+ #include <strstream>
|
||||
+
|
||||
+ using std::strstreambuf;
|
||||
+ using std::istrstream;
|
||||
+ using std::ostrstream;
|
||||
+ using std::strstream;
|
||||
#endif
|
||||
|
||||
#if defined(HAVE_STRCASECMP)
|
Loading…
Reference in New Issue
Block a user