MFH: r563985

e2fsprogs: make build more robust

Depending on external circumstances and options that I have not fully
investigated, several build-time failures occurred that were one of:
- missing symbols in liblzma (static build missed libmd)
  on some versions with LIBUNWIND enabled
- sometimes /bin/csh being pulled up for scripting, breaking in
  various places, reason unclear, possibly artifact of next one:
- questionable BASHTESTS handling cleaned up

As these are fixes for a potentially broken build,
no PORTREVISION bump necessary.
This commit is contained in:
Matthias Andree 2021-02-04 01:51:41 +00:00
parent 7d5350cab3
commit 0bd053c0e5
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=563986
2 changed files with 3 additions and 14 deletions

View File

@ -215,10 +215,10 @@ _CHECK_JOBS=
_checkaddargs=
.if ${PORT_OPTIONS:MBASHTESTS}
_CHECK_SHELL=${SHELL}
_CHECK_SHELL=${LOCALBASE}/bin/bash
_checkaddargs+=--eval SHELL:=${BASH_CMD}
.else
_CHECK_SHELL=${LOCALBASE}/bin/bash
_CHECK_SHELL=${SH}
.endif
.if !defined(TMPDIR)
@ -234,7 +234,7 @@ _check_timeout=180
.endif
.if ${PORT_OPTIONS:MLIBUNWIND}
_staticlibs+=${LOCALBASE}/lib/libunwind.a /usr/lib/liblzma.a
_staticlibs+=${LOCALBASE}/lib/libunwind.a /usr/lib/liblzma.a /usr/lib/libmd.a
.endif
post-build:

View File

@ -1,11 +0,0 @@
--- lib/support/Makefile.in.orig 2021-01-29 05:51:02 UTC
+++ lib/support/Makefile.in
@@ -44,7 +44,7 @@ LIBDIR= support
@MAKEFILE_LIBRARY@
@MAKEFILE_PROFILE@
-COMPILE_ET= _ET_DIR_OVERRIDE=$(srcdir)/../et ../et/compile_et
+COMPILE_ET= /usr/bin/env _ET_DIR_OVERRIDE=$(srcdir)/../et ../et/compile_et
.c.o:
$(E) " CC $<"