- Do not install useless .la files

PR:		35498
Submitted by:	KATO Tsuguru <tkato@prontomail.com>
This commit is contained in:
Patrick Li 2002-03-03 06:44:05 +00:00
parent 5b0cb4432a
commit 0b9b0e3df4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=55450
3 changed files with 44 additions and 6 deletions

View File

@ -8,6 +8,7 @@
PORTNAME= librsync
PORTVERSION= 0.9.5
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= rproxy
@ -19,18 +20,14 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
.endif
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" \
CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include"
CONFIGURE_ARGS= --enable-shared --disable-trace
USE_GMAKE= yes
INSTALLS_SHLIB= yes
MAN1= rdiff.1
MAN3= librsync.3
pre-build:
@${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}
.include <bsd.port.mk>

View File

@ -0,0 +1,42 @@
--- ltmain.sh.orig Fri Sep 7 03:45:46 2001
+++ ltmain.sh Sat Mar 2 15:45:11 2002
@@ -1040,7 +1040,7 @@
# These systems don't actually have a C library (as such)
test "X$arg" = "X-lc" && continue
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
test "X$arg" = "X-lc" && continue
;;
@@ -1048,7 +1048,7 @@
fi
if test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -2439,7 +2439,7 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
;;
*)
@@ -4208,10 +4208,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,6 +1,5 @@
bin/rdiff
include/rsync.h
lib/librsync.a
lib/librsync.la
lib/librsync.so
lib/librsync.so.1