Update to vpopmail-5.4.28.

From the PR - fix the creation of new domains through LDAP.

PR:		131274
Submitted by:	Suzuki <xsuzu@yokohama.riken.jp>
This commit is contained in:
Peter Pentchev 2009-11-26 19:02:19 +00:00
parent 9434a138d9
commit 0b7394b480
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=244800
25 changed files with 300 additions and 225 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= vpopmail
PORTVERSION= 5.4.27
PORTVERSION= 5.4.28
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-devel/${PORTVERSION}
@ -68,6 +68,7 @@ CONFIGURE_ARGS= --enable-qmaildir=${QMAIL_PREFIX} \
# WITHOUT_FPIC - do not add -fPIC to the C compiler flags
# WITH_MAILDROP - enable maildrop as an MDA (see README.maildrop)
# MAILDROP_PORT - the port that provides the bin/maildrop program
# WITH_DOMAIN_QUOTAS - enable non-system domain quotas
#
# Set these to the values you'd prefer
#
@ -231,6 +232,12 @@ CONFIGURE_ARGS+= --enable-maildrop=n
PLIST_SUB+= MAILDROP="@comment "
.endif
.if defined(WITH_DOMAIN_QUOTAS)
CONFIGURE_ARGS+= --enable-domainquotas=y
.else
CONFIGURE_ARGS+= --enable-domainquotas=n
.endif
.if defined(NOPORTDOCS)
EXTRA_PATCHES+= ${FILESDIR}/Makefile.in-noportdocs.patch
.endif
@ -454,7 +461,7 @@ post-install:
.endif
@${TOUCH} ${QMAIL_PREFIX}/control/locals
.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${PREFIX}/vpopmail/doc/
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/doc/,} ${PREFIX}/vpopmail/doc/
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (vpopmail-5.4.27.tar.gz) = 1deaa77ec6841f9aa65c0ea8908a53da
SHA256 (vpopmail-5.4.27.tar.gz) = 8bd6fa09294ae1d450f9e976f04d1ef4661ff01b992aad2fbe41d8ed2651b306
SIZE (vpopmail-5.4.27.tar.gz) = 525807
MD5 (vpopmail-5.4.28.tar.gz) = 8b44fb9c62d4ef96b29143863b577abb
SHA256 (vpopmail-5.4.28.tar.gz) = fa32445f83fa6600f59c11bd3f34325f700378db8bbc242f2779302f3e09ea27
SIZE (vpopmail-5.4.28.tar.gz) = 604340

View File

@ -1,9 +1,12 @@
Do not install the documentation files.
Only applied if NOPORTDOCS is defined during the port's build.
Description: Do not install the documentation files.
Only applied if NOPORTDOCS is defined during the port's build.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/Makefile.in
+++ b/Makefile.in
@@ -998,7 +998,7 @@
@@ -1065,7 +1065,7 @@
@SET_MAKE@
install-exec-am:
@ -12,7 +15,7 @@ Only applied if NOPORTDOCS is defined during the port's build.
if test ! -d $(DESTDIR)@vpopmaildir@/$$d; then \
$(INSTALL) -d -g @vpopgroup@ -m 0755 -o @vpopuser@ \
$(DESTDIR)@vpopmaildir@/$$d ; \
@@ -1054,14 +1054,6 @@
@@ -1126,14 +1126,6 @@
$(DESTDIR)@vpopmaildir@/include/ ; \
done

View File

@ -1,62 +1,15 @@
Install the config files with a -dist extension.
Do not unconditionally add -fPIC, this is done only for shared libs.
Attach backfill.c and authvchkpw.c to the build.
Description: Install config files with -dist, do not add -fPIC.
Install the config files with a -dist extension.
Do not unconditionally add -fPIC, this is done only for shared libs.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/Makefile.in
+++ b/Makefile.in
@@ -44,7 +44,7 @@
valias$(EXEEXT) vuserinfo$(EXEEXT) vmkpasswd$(EXEEXT) \
vipmap$(EXEEXT) vdominfo$(EXEEXT) vconvert$(EXEEXT) \
vkill$(EXEEXT) vmoddomlimits$(EXEEXT) vchangepw$(EXEEXT) \
- dotqmail2valias$(EXEEXT) vpopmaild$(EXEEXT) vlist$(EXEEXT)
+ dotqmail2valias$(EXEEXT) vpopmaild$(EXEEXT) vlist$(EXEEXT) authvchkpw$(EXEEXT)
subdir = .
DIST_COMMON = README $(am__configure_deps) $(noinst_HEADERS) \
$(srcdir)/Makefile.am $(srcdir)/Makefile.in \
@@ -71,7 +71,8 @@
libvpopmail_a-vpalias.$(OBJEXT) libvpopmail_a-seek.$(OBJEXT) \
libvpopmail_a-vlimits.$(OBJEXT) \
libvpopmail_a-maildirquota.$(OBJEXT) \
- libvpopmail_a-vutil.$(OBJEXT) libvpopmail_a-vlistlib.$(OBJEXT)
+ libvpopmail_a-vutil.$(OBJEXT) libvpopmail_a-vlistlib.$(OBJEXT) \
+ libvpopmail_a-backfill.$(OBJEXT)
am_libvpopmail_a_OBJECTS = $(am__objects_1)
libvpopmail_a_OBJECTS = $(am_libvpopmail_a_OBJECTS)
am__installdirs = "$(DESTDIR)$(vpopmailbindir)"
@@ -147,6 +148,9 @@
am_vpopmaild_OBJECTS = vpopmaild.$(OBJEXT)
vpopmaild_OBJECTS = $(am_vpopmaild_OBJECTS)
vpopmaild_DEPENDENCIES = libvpopmail.a
+am_authvchkpw_OBJECTS = authvchkpw.$(OBJEXT) hmac_md5.$(OBJEXT)
+authvchkpw_OBJECTS = $(am_authvchkpw_OBJECTS)
+authvchkpw_DEPENDENCIES = libvpopmail.a
am_vsetuserquota_OBJECTS = vsetuserquota.$(OBJEXT)
vsetuserquota_OBJECTS = $(am_vsetuserquota_OBJECTS)
vsetuserquota_DEPENDENCIES = libvpopmail.a
@@ -170,7 +174,7 @@
$(vlist_SOURCES) $(vmkpasswd_SOURCES) $(vmoddomlimits_SOURCES) \
$(vmoduser_SOURCES) $(vpasswd_SOURCES) $(vpopbull_SOURCES) \
$(vpopmaild_SOURCES) $(vsetuserquota_SOURCES) \
- $(vuserinfo_SOURCES)
+ $(vuserinfo_SOURCES) $(authvchkpw_SOURCES)
DIST_SOURCES = $(libvpopmail_a_SOURCES) $(clearopensmtp_SOURCES) \
$(dotqmail2valias_SOURCES) $(vaddaliasdomain_SOURCES) \
$(vadddomain_SOURCES) $(vadduser_SOURCES) $(valias_SOURCES) \
@@ -181,7 +185,7 @@
$(vlist_SOURCES) $(vmkpasswd_SOURCES) $(vmoddomlimits_SOURCES) \
$(vmoduser_SOURCES) $(vpasswd_SOURCES) $(vpopbull_SOURCES) \
$(vpopmaild_SOURCES) $(vsetuserquota_SOURCES) \
- $(vuserinfo_SOURCES)
+ $(vuserinfo_SOURCES) $(authvchkpw_SOURCES)
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
html-recursive info-recursive install-data-recursive \
install-dvi-recursive install-exec-recursive \
@@ -310,14 +314,13 @@
SUBDIRS = cdb
EXTRA_DIST = README.* cdb/* vcdb.c vldap.c vmysql.c voracle.pc vpgsql.c vsybase.c
@@ -326,12 +326,11 @@
noinst_HEADERS = md5.h vpopmail.h file_lock.h vauth.h vlimits.h maildirquota.h vcdb.h vldap.h vmysql.h voracle.h vpgsql.h vsybase.h vlog.h global.h hmac_md5.h seek.h vutil.h
-COMMONSOURCES = vpopmail.c md5.c bigdir.c vauth.c file_lock.c vpalias.c seek.c vlimits.c maildirquota.c vutil.c vlistlib.c
+COMMONSOURCES = vpopmail.c md5.c bigdir.c vauth.c file_lock.c vpalias.c seek.c vlimits.c maildirquota.c vutil.c vlistlib.c backfill.c
COMMONSOURCES = vpopmail.c md5.c bigdir.c vauth.c file_lock.c vpalias.c seek.c vlimits.c maildirquota.c vutil.c vlistlib.c backfill.c client.c conf.c ippp.c
CONFIG_CLEAN_FILES = vauth.c cdb/conf-cc cdb/conf-ld cdb/compile cdb/load
-MYSQLCONF = $(DESTDIR)@vpopmaildir@/etc/vpopmail.mysql
-VLIMITS = $(DESTDIR)@vpopmaildir@/etc/vlimits.default
@ -67,37 +20,5 @@ Attach backfill.c and authvchkpw.c to the build.
libvpopmail_a_LIBADD = cdb/*.o
-libvpopmail_a_CFLAGS = -fPIC
vpopmailbindir = @vpopmaildir@/bin
vuserinfo_SOURCES = vuserinfo.c maildirquota.c
vuserinfo_LDADD = libvpopmail.a @auth_libs@
@@ -325,6 +328,8 @@
vlist_LDADD = libvpopmail.a @auth_libs@
vpopmaild_SOURCES = vpopmaild.c
vpopmaild_LDADD = libvpopmail.a @auth_libs@
+authvchkpw_SOURCES = authvchkpw.c hmac_md5.c
+authvchkpw_LDADD = libvpopmail.a @auth_libs@
vdominfo_SOURCES = vdominfo.c
vdominfo_LDADD = libvpopmail.a @auth_libs@
vchkpw_SOURCES = vchkpw.c md5.c hmac_md5.c
@@ -524,6 +529,9 @@
vpopmaild$(EXEEXT): $(vpopmaild_OBJECTS) $(vpopmaild_DEPENDENCIES)
@rm -f vpopmaild$(EXEEXT)
$(LINK) $(vpopmaild_OBJECTS) $(vpopmaild_LDADD) $(LIBS)
+authvchkpw$(EXEEXT): $(authvchkpw_OBJECTS) $(authvchkpw_DEPENDENCIES)
+ @rm -f authvchkpw$(EXEEXT)
+ $(LINK) $(authvchkpw_OBJECTS) $(authvchkpw_LDADD) $(LIBS)
vsetuserquota$(EXEEXT): $(vsetuserquota_OBJECTS) $(vsetuserquota_DEPENDENCIES)
@rm -f vsetuserquota$(EXEEXT)
$(LINK) $(vsetuserquota_OBJECTS) $(vsetuserquota_LDADD) $(LIBS)
@@ -609,6 +617,12 @@
libvpopmail_a-vlistlib.obj: vlistlib.c
$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libvpopmail_a_CFLAGS) $(CFLAGS) -c -o libvpopmail_a-vlistlib.obj `if test -f 'vlistlib.c'; then $(CYGPATH_W) 'vlistlib.c'; else $(CYGPATH_W) '$(srcdir)/vlistlib.c'; fi`
+libvpopmail_a-backfill.o: backfill.c
+ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libvpopmail_a_CFLAGS) $(CFLAGS) -c -o libvpopmail_a-backfill.o `test -f 'backfill.c' || echo '$(srcdir)/'`backfill.c
+
+libvpopmail_a-backfill.obj: backfill.c
+ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(libvpopmail_a_CFLAGS) $(CFLAGS) -c -o libvpopmail_a-backfill.obj `if test -f 'backfill.c'; then $(CYGPATH_W) 'backfill.c'; else $(CYGPATH_W) '$(srcdir)/backfill.c'; fi`
+
# This directory's subdirectories are mostly independent; you can cd
# into them and run `make' without going through this Makefile.
# To change the values of `make' variables: instead of editing Makefiles,
vusagec_SOURCES = vusagec.c client.c conf.c ippp.c
vusagec_LDADD = libvpopmail.a @auth_libs@

View File

@ -1,7 +1,10 @@
Fix a typo.
Description: Fix a typo.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/README.onchange
+++ b/README.onchange
--- a/doc/README.onchange
+++ b/doc/README.onchange
@@ -8,7 +8,7 @@
only the inital call triggers the script. For example vadddomain uses
vadduser and vmoduser to create the postmaster user, and set its

View File

@ -1,7 +1,10 @@
Fix a typo.
Description: Fix a typo.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/README.vdelivermail
+++ b/README.vdelivermail
--- a/doc/README.vdelivermail
+++ b/doc/README.vdelivermail
@@ -57,7 +57,7 @@
If you are not sure what you are doing writing .qmail files, and mucking around

View File

@ -1,7 +1,10 @@
Fix a couple of typos and grammatical errors.
Description: Fix a couple of typos and grammatical errors.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/README.vpopmaild
+++ b/README.vpopmaild
--- a/doc/README.vpopmaild
+++ b/doc/README.vpopmaild
@@ -243,7 +243,7 @@
Rights required: Must be a valid email address.

View File

@ -1,21 +1,25 @@
Buffer handling:
- use snprintf() instead of strncpy() to ensure null-termination;
- explicitly pass sizeof(var) as a second argument to snprintf() to
protect against a variable definition changing in the future;
- display the correct amount of failed-to-allocate memory.
Fix a misspelling of TCPREMOTEIP that would prevent POP-before-SMTP.
Enclose a write() into a loop so that it succeeds even for amounts
too large to write at once.
Display an error message if the execv() in exec_local() fails and
propagate the error all the way up to main()'s exit code.
Extract the indiargs as separate defines so that the port's Makefile may
modify them easily.
Mark two function parameters as unused.
Fix a couple of const-related compiler warnings.
Description: Various sanity- and security-related fixes.
Buffer handling:
- use snprintf() instead of strncpy() to ensure null-termination;
- explicitly pass sizeof(var) as a second argument to snprintf() to
protect against a variable definition changing in the future;
- display the correct amount of failed-to-allocate memory.
Fix a misspelling of TCPREMOTEIP that would prevent POP-before-SMTP.
Enclose a write() into a loop so that it succeeds even for amounts
too large to write at once.
Display an error message if the execv() in exec_local() fails and
propagate the error all the way up to main()'s exit code.
Extract the indiargs as separate defines so that the port's Makefile may
modify them easily.
Mark two function parameters as unused.
Fix a couple of const-related compiler warnings.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/authvchkpw.c
+++ b/authvchkpw.c
@@ -56,6 +56,18 @@
@@ -54,6 +54,18 @@
#define AUTH_SIZE 512
#endif
@ -34,7 +38,7 @@ Fix a couple of const-related compiler warnings.
int authlen = AUTH_SIZE;
static int exec_local(char **, char *, char *, struct vqpasswd *, char *);
static char hextab[] = "0123456789abcdef";
@@ -72,7 +84,7 @@
@@ -70,7 +82,7 @@
}
int
@ -43,7 +47,7 @@ Fix a couple of const-related compiler warnings.
{
unsigned char digest[16];
unsigned char digascii[33];
@@ -107,7 +119,7 @@
@@ -105,7 +117,7 @@
* getEnvConfigStr
*/
void
@ -52,7 +56,7 @@ Fix a couple of const-related compiler warnings.
{
if (!(*source = getenv(envname)))
*source = defaultValue;
@@ -117,8 +129,8 @@
@@ -115,8 +127,8 @@
int
Login_Tasks(pw, user, ServiceType)
struct passwd *pw;
@ -63,7 +67,7 @@ Fix a couple of const-related compiler warnings.
{
char *domain, *ptr;
char fqemail[MAX_BUFF];
@@ -133,17 +145,17 @@
@@ -131,17 +143,17 @@
if (!pw)
return(1);
@ -84,7 +88,7 @@ Fix a couple of const-related compiler warnings.
*ptr = 0;
}
if (access(pw->pw_dir, F_OK))
@@ -157,7 +169,7 @@
@@ -155,7 +167,7 @@
#ifdef MIN_LOGIN_INTERVAL
last_time = vget_lastauth(pw, domain);
#endif
@ -93,7 +97,7 @@ Fix a couple of const-related compiler warnings.
ptr = "0.0.0.0";
vset_lastauth(pw->pw_name, domain, ptr);
#ifdef MIN_LOGIN_INTERVAL
@@ -170,10 +182,12 @@
@@ -168,10 +180,12 @@
}
int
@ -107,7 +111,7 @@ Fix a couple of const-related compiler warnings.
if ((pstat = signal(SIGPIPE, SIG_IGN)) == SIG_ERR)
{
@@ -196,7 +210,10 @@
@@ -194,7 +208,10 @@
close(pipe_fd[0]);
if(pipe_fd[1] != 3 && pipe_fd[1] != 4)
close(pipe_fd[1]);
@ -119,7 +123,7 @@ Fix a couple of const-related compiler warnings.
{
fprintf(stderr, "pipe_exec: %s: %s\n", argv[1], strerror(errno));
signal(SIGPIPE, pstat);
@@ -214,13 +231,13 @@
@@ -212,13 +229,13 @@
{
char *buf, *tmpbuf, *login, *challenge, *crypt_pass,
*prog_name, *service, *service_type;
@ -136,7 +140,7 @@ Fix a couple of const-related compiler warnings.
if ((prog_name = strrchr(argv[0], '/')))
prog_name++;
@@ -274,7 +291,7 @@
@@ -272,7 +289,7 @@
}
if (!(buf = calloc(1, (offset + 1) * sizeof(char))))
{
@ -145,7 +149,7 @@ Fix a couple of const-related compiler warnings.
return(1);
}
memcpy(buf, tmpbuf, offset);
@@ -327,7 +344,7 @@
@@ -325,7 +342,7 @@
pipe_exec(argv, buf, offset);
return (1);
}
@ -154,7 +158,7 @@ Fix a couple of const-related compiler warnings.
if (vauth_open(0))
{
fprintf(stderr, "%s: inquery: %s\n", prog_name, strerror(errno));
@@ -404,8 +421,7 @@
@@ -402,8 +419,7 @@
pipe_exec(argv, buf, offset);
return (1);
}
@ -164,7 +168,7 @@ Fix a couple of const-related compiler warnings.
}
static int
@@ -420,7 +436,7 @@
@@ -418,7 +434,7 @@
#endif
for (cptr = TheUser, ptr = userid;*ptr && *ptr != '@';*cptr++ = *ptr++);
*cptr = 0;
@ -173,7 +177,7 @@ Fix a couple of const-related compiler warnings.
if ((ptr = strrchr(TmpBuf, ':')))
*ptr = 0;
status = Login_Tasks(pw, userid, TmpBuf);
@@ -430,22 +446,22 @@
@@ -428,22 +444,22 @@
return(1);
}
close_connection();
@ -203,7 +207,7 @@ Fix a couple of const-related compiler warnings.
putenv(authenv1);
putenv(authenv2);
putenv(authenv3);
@@ -453,6 +469,7 @@
@@ -451,6 +467,7 @@
putenv(authenv5);
close_connection();
execv(argv[0], argv);

View File

@ -1,10 +1,13 @@
Buffer handling:
- convert a strncpy() to snprintf() to ensure null-termination;
- explicitly pass sizeof(var) as the second argument of snprintf().
Description: String buffer handling fixes.
- convert a strncpy() to snprintf() to ensure null-termination;
- explicitly pass sizeof(var) as the second argument of snprintf().
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/backfill.c
+++ b/backfill.c
@@ -56,7 +56,7 @@
@@ -54,7 +54,7 @@
return(-1);
#endif
/*- format a new string */
@ -13,7 +16,7 @@ Buffer handling:
if (rename(filename, bak_file))
{
fprintf(stderr, "rename %s->%s: %s\n", filename, bak_file, strerror(errno));
@@ -155,7 +155,7 @@
@@ -153,7 +153,7 @@
fprintf(stderr, "%s: No such domain\n", domain);
return((char *) 0);
}
@ -22,7 +25,7 @@ Buffer handling:
if (operation == 1) /*- Delete */
{
if (!(fp = fopen(filename, "r")))
@@ -193,7 +193,7 @@
@@ -191,7 +191,7 @@
} else
if (operation == 2) /*- add */
{

View File

@ -1,4 +1,7 @@
Do not unconditionally add -fPIC, this is only done for the shared libs.
Description: Do not unconditionally add -fPIC, this is only done for the shared libs.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/cdb/Makefile
+++ b/cdb/Makefile

View File

@ -1,8 +1,11 @@
Add two SpamAssassin-related definitions.
Description: Add two SpamAssassin-related definitions.
Forwarded: not-needed
Author: Alex Dupre <ale@FreeBSD.org>
Last-Update: 2009-11-26
--- a/config.h.in
+++ b/config.h.in
@@ -277,6 +277,12 @@
@@ -280,6 +280,12 @@
#undef SPAMC_PROG
/* "" */

View File

@ -1,14 +1,20 @@
Add the --enable-spam-threshold and --enable-spam-junkfolder options.
Do not try to create the etc/vpopmail directory and tcp.smtp in place,
this is done by the port at install time.
FreeBSD does not have libresolv.
Pass the correct compiler and linker flags to the cdb build.
FreeBSD does not need -R $libdir (a.k.a. --rpath) - the MySQL client
library is added to ldconfig's search path in its own startup script.
Description: Configure for the FreeBSD ports build system.
Add the --enable-spam-threshold and --enable-spam-junkfolder options.
Do not try to create the etc/vpopmail directory and tcp.smtp in place,
this is done by the port at install time.
FreeBSD does not have libresolv.
Pass the correct compiler and linker flags to the cdb build.
FreeBSD does not need -R $libdir (a.k.a. --rpath) - the MySQL client
library is added to ldconfig's search path in its own startup script.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>,
Alex Dupre <ale@FreeBSD.org>,
Renato Botelho <garga@FreeBSD.org>
Last-Update: 2009-11-26
--- a/configure
+++ b/configure
@@ -1326,6 +1326,8 @@
@@ -1455,6 +1455,8 @@
--enable-onchange-script Enable onchange script. See README.onchange for more info.
--enable-spamassassin Enable spamassassin. See README.spamassassin for more info.
--enable-spamc-prog=PATH Full path to spamc program /usr/{local/}bin/spamc.
@ -16,8 +22,8 @@ library is added to ldconfig's search path in its own startup script.
+ --enable-spam-junkfolder Automatically move (not deleted) spam messages into Junk folder
--enable-maildrop Enable maildrop. See README.maildrop for more info.
--enable-maildrop-prog=PATH Full path to maildrop program /usr/{local/}bin/maildrop.
--enable-domains-dir=TEXT Directory in ~vpopmail to store domains (default=domains).
@@ -6504,27 +6506,6 @@
--enable-domainquotas Enable non-system domain quotas. See README.quotas for more info.
@@ -6884,27 +6886,6 @@
#----------------------------------------------------------------------
@ -25,15 +31,15 @@ library is added to ldconfig's search path in its own startup script.
-then
- if test ! -d $vpopmaildir
- then
- { echo "$as_me:$LINENO: WARNING: creating $vpopmaildir " >&5
-echo "$as_me: WARNING: creating $vpopmaildir " >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: creating $vpopmaildir " >&5
-$as_echo "$as_me: WARNING: creating $vpopmaildir " >&2;}
- mkdir -p $vpopmaildir
- chown $vpopmailuid $vpopmaildir
- chgrp $vpopmailgid $vpopmaildir
- chmod 755 $vpopmaildir
- fi
- { echo "$as_me:$LINENO: WARNING: making a vpopmail etc directory " >&5
-echo "$as_me: WARNING: making a vpopmail etc directory " >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: making a vpopmail etc directory " >&5
-$as_echo "$as_me: WARNING: making a vpopmail etc directory " >&2;}
- mkdir $vpopmaildir/etc
- chown $vpopmailuid "$vpopmaildir"/etc
- chgrp $vpopmailgid "$vpopmaildir"/etc
@ -42,42 +48,42 @@ library is added to ldconfig's search path in its own startup script.
-
-#----------------------------------------------------------------------
-
{ echo "$as_me:$LINENO: checking whether roaming-users has been enabled" >&5
echo $ECHO_N "checking whether roaming-users has been enabled... $ECHO_C" >&6; }
{ $as_echo "$as_me:$LINENO: checking whether roaming-users has been enabled" >&5
$as_echo_n "checking whether roaming-users has been enabled... " >&6; }
# Check whether --enable-roaming-users was given.
@@ -6611,30 +6592,9 @@
@@ -6991,30 +6972,11 @@
# Check whether --enable-tcpserver_file was given.
if test "${enable_tcpserver_file+set}" = set; then
enableval=$enable_tcpserver_file; tcpserver_file="$enableval"
-else
-
+ echo "127.:allow,RELAYCLIENT=\"\"" > ${VCFGDIR}/tcp.smtp
else
- if test "$tcpserver_file" = ""
- then
- { echo "$as_me:$LINENO: WARNING: Unable to find your tcpserver relay file." >&5
-echo "$as_me: WARNING: Unable to find your tcpserver relay file." >&2;}
- { echo "$as_me:$LINENO: WARNING: Creating tcp.smtp in \"$vpopmaildir\"/etc/tcp.smtp." >&5
-echo "$as_me: WARNING: Creating tcp.smtp in \"$vpopmaildir\"/etc/tcp.smtp." >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: Unable to find your tcpserver relay file." >&5
-$as_echo "$as_me: WARNING: Unable to find your tcpserver relay file." >&2;}
- { $as_echo "$as_me:$LINENO: WARNING: Creating tcp.smtp in \"$vpopmaildir\"/etc/tcp.smtp." >&5
-$as_echo "$as_me: WARNING: Creating tcp.smtp in \"$vpopmaildir\"/etc/tcp.smtp." >&2;}
-
- echo "127.:allow,RELAYCLIENT=\"\"" > "$vpopmaildir"/etc/tcp.smtp
- tcpserver_file="$vpopmaildir"/etc/tcp.smtp
- fi
-
-
+ echo "127.:allow,RELAYCLIENT=\"\"" > ${VCFGDIR}/tcp.smtp
fi
-
- if test ! -f "$tcpserver_file"
- then
- { { echo "$as_me:$LINENO: error: Unable to find your tcp.smtp file, specify --enable-tcpserver-path=/full/path/to/tcp.smtp" >&5
-echo "$as_me: error: Unable to find your tcp.smtp file, specify --enable-tcpserver-path=/full/path/to/tcp.smtp" >&2;}
- { { $as_echo "$as_me:$LINENO: error: Unable to find your tcp.smtp file, specify --enable-tcpserver-path=/full/path/to/tcp.smtp" >&5
-$as_echo "$as_me: error: Unable to find your tcp.smtp file, specify --enable-tcpserver-path=/full/path/to/tcp.smtp" >&2;}
- { (exit 1); exit 1; }; }
- fi
-
{ echo "$as_me:$LINENO: result: yes" >&5
echo "${ECHO_T}yes" >&6; }
{ $as_echo "$as_me:$LINENO: result: yes" >&5
$as_echo "yes" >&6; }
@@ -7143,6 +7103,44 @@
@@ -7523,6 +7485,44 @@
#define SPAMC_PROG "$spamc_prog"
_ACEOF
@ -122,7 +128,7 @@ library is added to ldconfig's search path in its own startup script.
;;
esac
@@ -7396,7 +7394,7 @@
@@ -7785,7 +7785,7 @@
{ (exit 1); exit 1; }; }
fi
@ -131,7 +137,7 @@ library is added to ldconfig's search path in its own startup script.
;;
@@ -7463,7 +7461,7 @@
@@ -7852,7 +7852,7 @@
#define USE_LDAP $USE_LDAP
_ACEOF
@ -140,7 +146,7 @@ library is added to ldconfig's search path in its own startup script.
auth_inc="-I/usr/local/include"
@@ -9954,8 +9952,8 @@
@@ -10466,8 +10466,8 @@
;;
esac

View File

@ -0,0 +1,59 @@
Description: Use the FreeBSD endianness symbols.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/storage.h
+++ b/storage.h
@@ -27,6 +27,42 @@
htonll() and ntohll()
*/
+#ifdef __FreeBSD__
+
+#include <sys/endian.h>
+
+#if defined(_BYTE_ORDER) && defined(_LITTLE_ENDIAN) && defined(_BIG_ENDIAN)
+# if _BYTE_ORDER == _LITTLE_ENDIAN
+
+#define VPOPMAIL_HOST_LITTLE_ENDIAN
+
+# ifndef ntohll
+# define ntohll(_x_) __bswap64(_x_)
+# endif
+# ifndef htonll
+# define htonll(_x_) __bswap64(_x_)
+# endif
+
+# elif _BYTE_ORDER == _BIG_ENDIAN
+
+#define VPOPMAIL_HOST_BIG_ENDIAN
+
+# ifndef ntohll
+# define ntohll(_x_) _x_
+# endif
+# ifndef htonll
+# define htonll(_x_) _x_
+# endif
+
+# else
+#error A byte order must be selected
+# endif
+#else
+#error Could not find the _BYTE_ORDER, _LITTLE_ENDIAN, or _BIG_ENDIAN defs
+#endif
+
+#else
+
#include <endian.h>
#include <byteswap.h>
@@ -56,6 +92,8 @@
# error A byte order must be selected
#endif
+#endif
+
/*
Define htonll() and ntohll() if not already defined
*/

View File

@ -1,5 +1,10 @@
Add SpamAssassin support.
Drop the unneeded MAX_ENV_BUFF definition.
Description: SpamAssassin support, build optimization
Add SpamAssassin support.
Drop the unneeded MAX_ENV_BUFF definition.
Forwarded: not-needed
Author: Alex Dupre <ale@FreeBSD.org>,
Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vdelivermail.c
+++ b/vdelivermail.c
@ -117,7 +122,7 @@ Drop the unneeded MAX_ENV_BUFF definition.
/* This is an command */
if ( *address == '|' ) {
@@ -895,9 +939,6 @@
@@ -898,9 +942,6 @@
*/
void run_command(char *prog)
{
@ -127,7 +132,7 @@ Drop the unneeded MAX_ENV_BUFF definition.
int child;
char *(args[4]);
int wstat;
@@ -1211,19 +1252,22 @@
@@ -1214,19 +1255,22 @@
* * in the email headers for X-Spam-Level: which
* * we put in each spam email
* *
@ -154,7 +159,7 @@ Drop the unneeded MAX_ENV_BUFF definition.
/* check for blank line, end of headers */
for(k=j,found=0;k<i;++k) {
@@ -1246,13 +1290,19 @@
@@ -1249,13 +1293,19 @@
}
if ( found == 0 ) {
InHeaders=0;

View File

@ -0,0 +1,16 @@
Description: Fix a crash when adding a virtual domain.
Forwarded: no
Author: Suzuki <xsuzu@yokohama.riken.jp>
Last-Update: 2009-11-26
--- a/vldap.c
+++ b/vldap.c
@@ -661,7 +661,7 @@
}
}
- lm = (LDAPMod **)safe_malloc(sizeof(LDAPMod *) * 2);
+ lm = (LDAPMod **)safe_malloc(sizeof(LDAPMod *) * 3);
lm[0] = (LDAPMod *)safe_malloc(sizeof(LDAPMod));

View File

@ -1,5 +1,9 @@
Do not impose an arbitrary limit of 100 list entries.
Fix the usage message and an error message.
Description: Sanity and usage fixes.
Do not impose an arbitrary limit of 100 list entries.
Fix the usage message and an error message.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vlist.c
+++ b/vlist.c

View File

@ -1,9 +1,13 @@
Honor lots of limits - convert sprintf() to snprintf(), use the correct
limit size, etc.
Check a couple more calls for errors.
Wait for the correct child process - waitpid() instead of wait().
Add two closedir()'s to fix file descriptor leaks.
Look for the arguments properly if progname should ever containing spaces.
Description: Sanity and safety checks.
Honor lots of limits - convert sprintf() to snprintf(), use the correct
limit size, etc.
Check a couple more calls for errors.
Wait for the correct child process - waitpid() instead of wait().
Add two closedir()'s to fix file descriptor leaks.
Look for the arguments properly if progname should ever containing spaces.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vlistlib.c
+++ b/vlistlib.c
@ -34,7 +38,7 @@ Look for the arguments properly if progname should ever containing spaces.
- snprintf( LI->SQLPass, MAX_FILE_NAME, "dbpass" );
- snprintf( LI->SQLTable, MAX_FILE_NAME, "ezmlm" );
- snprintf( LI->SQLUser, MAX_FILE_NAME, "dbUser" );
+ snprintf( LI->OwnerEmail, sizeof(LI->OwnerEmail), "postmaster@%s", LI->Domain );
+ snprintf( LI->OwnerEmail, sizeof(LI->OwnerEmail), "postmaster@%s", LI->Domain );
+ snprintf( LI->ReplyTo_Addr, sizeof(LI->ReplyTo_Addr), "%s", "" );
+ snprintf( LI->SQLBase, sizeof(LI->SQLBase), "ezmlm" );
+ snprintf( LI->SQLHost, sizeof(LI->SQLHost), "localhost" );
@ -299,7 +303,7 @@ Look for the arguments properly if progname should ever containing spaces.
FILE *fs;
- int handles[2],pid,z = 0,subuser_count = 0;
+ int handles[2],pid,status,z = 0,subuser_count = 0;
+ int handles[2],pid,status,z = 0,subuser_count = 0;
char ProgramPath[MAX_BUFF];
char ListPath[MAX_BUFF];
char buf[256];

View File

@ -1,9 +1,11 @@
Fix the virtual alias support.
Implement SQL_REMOVE_DELETED.
Description: Fix the virtual alias support; implement SQL_REMOVE_DELETED.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vmysql.c
+++ b/vmysql.c
@@ -596,12 +596,14 @@
@@ -599,6 +599,7 @@
#endif
#ifdef ENABLE_SQL_LOGGING
@ -11,14 +13,15 @@ Implement SQL_REMOVE_DELETED.
qnprintf( SqlBufUpdate, SQL_BUF_SIZE,
"delete from vlog where domain = '%s'", domain );
if (mysql_query(&mysql_update,SqlBufUpdate)) {
return(-1);
@@ -607,6 +608,7 @@
fprintf(stderr, "vauth_deldomain: warning: mysql_query(%s) failed: %s\n", SqlBufUpdate, mysql_error(&mysql_update));
}
#endif
+#endif
vdel_limits(domain);
@@ -647,6 +649,7 @@
@@ -656,6 +658,7 @@
#endif
#ifdef ENABLE_SQL_LOGGING
@ -26,15 +29,15 @@ Implement SQL_REMOVE_DELETED.
qnprintf( SqlBufUpdate, SQL_BUF_SIZE,
"delete from vlog where domain = '%s' and user = '%s'",
domain, user );
@@ -654,6 +657,7 @@
err = -1;
@@ -667,6 +670,7 @@
err = 0;
}
#endif
+#endif
return(err);
}
@@ -1580,7 +1584,7 @@
@@ -1593,7 +1597,7 @@
* valias_select_names
*/
@ -43,7 +46,7 @@ Implement SQL_REMOVE_DELETED.
{
struct linklist *temp_entry = NULL;
@@ -1609,16 +1613,13 @@
@@ -1622,16 +1626,13 @@
}
while ((row = mysql_fetch_row(res_read))) {
@ -62,7 +65,7 @@ Implement SQL_REMOVE_DELETED.
}
/************************************************************************
@@ -1626,16 +1627,13 @@
@@ -1639,16 +1640,13 @@
* valias_select_names_next
*/

View File

@ -1,4 +1,7 @@
Honor the correct limits.
Description: Honor the correct limits.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vpalias.c
+++ b/vpalias.c

View File

@ -1,9 +1,11 @@
Implement valias support.
Implement SQL_REMOVE_DELETED.
Description: Implement valias support; implement SQL_REMOVE_DELETED.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vpgsql.c
+++ b/vpgsql.c
@@ -390,13 +390,15 @@
@@ -392,13 +392,15 @@
#endif
#ifdef ENABLE_SQL_LOGGING
@ -21,7 +23,7 @@ Implement SQL_REMOVE_DELETED.
return(0);
}
@@ -443,14 +445,16 @@
@@ -445,14 +447,16 @@
#endif
#ifdef ENABLE_SQL_LOGGING
@ -40,7 +42,7 @@ Implement SQL_REMOVE_DELETED.
return(err);
}
@@ -1553,6 +1557,80 @@
@@ -1555,6 +1559,80 @@
return valias_current->data;
}
}

View File

@ -1,8 +1,13 @@
Implement SpamAssassin support.
Honor limits correctly.
Wait for the correct child process - waitpid() instead of wait().
Check for a couple more errors.
Add a closedir() to fix a file descriptor leak.
Description: SpamAssassin support, sanity checks.
Implement SpamAssassin support.
Honor limits correctly.
Wait for the correct child process - waitpid() instead of wait().
Check for a couple more errors.
Add a closedir() to fix a file descriptor leak.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>,
Alex Dupre <ale@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vpopmail.c
+++ b/vpopmail.c
@ -14,7 +19,7 @@ Add a closedir() to fix a file descriptor leak.
return(-1);
}
}
@@ -1562,7 +1563,7 @@
@@ -1563,7 +1564,7 @@
i++;
}
@ -23,7 +28,7 @@ Add a closedir() to fix a file descriptor leak.
if( i>0 ) {
for( j=0; j<k; j++ ) {
@@ -1574,7 +1575,7 @@
@@ -1575,7 +1576,7 @@
// trim spaces and tabs from end
i = strlen(s) - 1;
@ -32,7 +37,7 @@ Add a closedir() to fix a file descriptor leak.
i--;
}
@@ -2345,7 +2346,12 @@
@@ -2348,7 +2349,12 @@
char calling_dir[MAX_BUFF];
char domain_dir[MAX_BUFF];
const char *dirnames[] = {"Maildir", "Maildir/new", "Maildir/cur",
@ -46,7 +51,7 @@ Add a closedir() to fix a file descriptor leak.
int i;
verrori = 0;
@@ -3107,6 +3113,13 @@
@@ -3114,6 +3120,13 @@
if (mkdir("cur",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
if (mkdir("new",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
if (mkdir("tmp",VPOPMAIL_DIR_MODE) == -1) { chdir(calling_dir); return(-1); }
@ -60,7 +65,7 @@ Add a closedir() to fix a file descriptor leak.
/* set permissions on the user's dir */
chdir(dir);
@@ -4139,11 +4152,19 @@
@@ -4163,11 +4176,19 @@
}
else if ( pid > 0 )
{

View File

@ -1,5 +1,9 @@
Optimize a lot of calls by just using access(2).
Fix a file descriptor and FILE structure leak.
Description: Sanity and safety.
Optimize a lot of calls by just using access(2).
Fix a file descriptor and FILE structure leak.
Forwarded: no
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/vutil.c
+++ b/vutil.c

View File

@ -1,9 +1,12 @@
Activate the SQL_REMOVE_DELETED code.
Only applied if this is requested at port build time.
Description: Activate the SQL_REMOVE_DELETED code.
Only applied if this is requested at port build time.
Forwarded: not-needed
Author: Peter Pentchev <roam@FreeBSD.org>
Last-Update: 2009-11-26
--- a/config.h.in
+++ b/config.h.in
@@ -371,3 +371,5 @@
@@ -374,3 +374,5 @@
/* Define to `int' if <sys/types.h> doesn't define. */
#undef uid_t

View File

@ -1,5 +1,8 @@
Fix the SMTP auth calculations - use the correct order of arguments.
Only applied if requested at port build time.
Description: Use the correct order of arguments for the SMTP auth calculations.
Only applied if requested at port build time.
Forwarded: not-needed
Author: Nikolay Georgiev <niki@techlab.office1.bg>
Last-Update: 2009-11-26
--- a/vchkpw.c
+++ b/vchkpw.c

View File

@ -23,6 +23,7 @@ vpopmail/bin/vpasswd
vpopmail/bin/vpopbull
vpopmail/bin/vpopmaild
vpopmail/bin/vsetuserquota
vpopmail/bin/vusagec
vpopmail/bin/vuserinfo
%%PORTDOCS%%vpopmail/doc/doc_html/vpopmail.html
%%PORTDOCS%%vpopmail/doc/doc_html/vpopmail5.abw
@ -76,7 +77,11 @@ vpopmail/etc/vlimits.default-dist
%%MYSQL%%@unexec if cmp -s %D/vpopmail/etc/vpopmail.mysql %D/vpopmail/etc/vpopmail.mysql-dist; then rm -f %D/vpopmail/etc/vpopmail.mysql; fi
%%MYSQL%%vpopmail/etc/vpopmail.mysql-dist
%%MYSQL%%@exec if [ ! -f %D/vpopmail/etc/vpopmail.mysql ] ; then cp -p %D/%F %B/vpopmail.mysql; fi
vpopmail/include/client.h
vpopmail/include/conf.h
vpopmail/include/config.h
vpopmail/include/ippp.h
vpopmail/include/storage.h
vpopmail/include/vauth.h
vpopmail/include/vlimits.h
vpopmail/include/vpopmail.h