archivers/py-borgbackup: use fixed xxhash instead of avoiding it
This reverts commit9db903a89b
because it does not fix the situation for lack of a PORTREVISION bump. Let us use the opportunity to fix the real bug instead. Now with xxhash fixed as of 0.8.1_2, drop9db903a89
, and bump PORTREVISION so we flush out the old garbage packages. A simple web search would have brought up that static_assert() is a C11 convenience macro defined in <assert.h>, and a detailed search would have turned up that this had been fixed in xxhash before. While here, add a smoke test to post-install. Proper fix was Reported by: Thierry Dussuet <thierry.dussuet@protonmail.com> PR: 265060 MFH: 2022Q3 (cherry picked from commit714af13781
)
This commit is contained in:
parent
b5eed5731a
commit
0b4a732cb0
@ -14,7 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:devel/py-setuptools_scm@${PY_FLAVOR}
|
||||
LIB_DEPENDS= liblz4.so:archivers/liblz4 \
|
||||
libzstd.so:archivers/zstd
|
||||
libzstd.so:archivers/zstd \
|
||||
libxxhash.so:devel/xxhash
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAVOR}
|
||||
|
||||
USES= python:3.5+ ssl
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- setup.py.orig 2022-07-16 16:20:52 UTC
|
||||
+++ setup.py
|
||||
@@ -23,7 +23,7 @@ prefer_system_libzstd = True
|
||||
prefer_system_libb2 = True
|
||||
|
||||
# True: use the shared libxxhash (>= 0.6.5 [>= 0.7.2 on ARM]) from the system, False: use the bundled xxhash code
|
||||
-prefer_system_libxxhash = True
|
||||
+prefer_system_libxxhash = False
|
||||
|
||||
# prefer_system_msgpack is another option, but you need to set it in src/borg/helpers.py.
|
||||
|
Loading…
Reference in New Issue
Block a user