Add new port devel/edb:
edb (Evan's Debugger) is a cross platform x86/x86-64 debugger. It was inspired by OllyDbg, but aims to function on x86 and x86-64 as well as multiple OS's. Linux is the only officially supported platform at the moment, but FreeBSD, OpenBSD, OSX and Windows ports are underway with varying degrees of functionality. WWW: http://codef00.com/projects#debugger PR: based on ports/170779 Submitted by: HU Dong <itechbear at gmail.com>
This commit is contained in:
parent
a69be38555
commit
0b2b32af10
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=304463
@ -364,6 +364,7 @@
|
||||
SUBDIR += ecore-ipc
|
||||
SUBDIR += ecore-main
|
||||
SUBDIR += ecos-tools
|
||||
SUBDIR += edb
|
||||
SUBDIR += eet
|
||||
SUBDIR += eggdbus
|
||||
SUBDIR += egypt
|
||||
|
50
devel/edb/Makefile
Normal file
50
devel/edb/Makefile
Normal file
@ -0,0 +1,50 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= edb
|
||||
PORTVERSION= 0.9.18
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://codef00.com/projects/
|
||||
DISTNAME= debugger-${PORTVERSION}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= itechbear@gmail.com
|
||||
COMMENT= Cross-platform x86/x86-64 debugger based on Qt 4
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
|
||||
|
||||
USE_QT4= gui network xml moc_build qmake_build rcc_build uic_build
|
||||
HAS_CONFIGURE= yes
|
||||
QMAKE_ARGS= -recursive PREFIX=${PREFIX} \
|
||||
DEFAULT_PLUGIN_PATH="${PREFIX}/libexec/${PORTNAME}"
|
||||
|
||||
WRKSRC= ${WRKDIR}/debugger
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
MAN1= edb.1
|
||||
PORTDOCS= *
|
||||
|
||||
ONLY_FOR_ARCHS= i386 amd64
|
||||
|
||||
STRIP_FILES= bin/${PORTNAME} libexec/${PORTNAME}/*.so
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
do-configure:
|
||||
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
|
||||
${QMAKE} ${QMAKE_ARGS} ${QMAKEFLAGS}
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MDOCS}
|
||||
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
|
||||
.endif
|
||||
${MKDIR} ${PREFIX}/share/applications
|
||||
${INSTALL_DATA} ${WRKSRC}/edb.desktop ${PREFIX}/share/applications
|
||||
${MKDIR} ${PREFIX}/share/pixmaps
|
||||
${INSTALL_DATA} ${WRKSRC}/src/images/edb48-logo.png ${PREFIX}/share/pixmaps/edb.png
|
||||
${MKDIR} ${MANPREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/edb.1 ${MANPREFIX}/man/man1/edb.1
|
||||
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/edb/distinfo
Normal file
2
devel/edb/distinfo
Normal file
@ -0,0 +1,2 @@
|
||||
SHA256 (debugger-0.9.18.tgz) = dd046187ca6301265f1a2116919a3bf4af64c9ad3fa14809030abbfe82af7b43
|
||||
SIZE (debugger-0.9.18.tgz) = 725688
|
18
devel/edb/files/patch-plugins__plugins.pri
Normal file
18
devel/edb/files/patch-plugins__plugins.pri
Normal file
@ -0,0 +1,18 @@
|
||||
--- ./plugins/plugins.pri.orig 2011-08-23 19:12:08.000000000 +0000
|
||||
+++ ./plugins/plugins.pri 2012-09-13 21:26:13.620559681 +0000
|
||||
@@ -6,6 +6,7 @@
|
||||
#CONFIG += silent
|
||||
DESTDIR = $$EDB_ROOT
|
||||
INSTALLS += target
|
||||
+target.path = $$DEFAULT_PLUGIN_PATH
|
||||
|
||||
DEFINES += EDB_PLUGIN
|
||||
|
||||
@@ -54,7 +55,6 @@
|
||||
!macx {
|
||||
INCLUDEPATH += $$EDB_ROOT/include/arch/$$QT_ARCH
|
||||
DEPENDPATH += $$EDB_ROOT/include/arch/$$QT_ARCH
|
||||
- include(plugins-$${QT_ARCH}.pri)
|
||||
}
|
||||
|
||||
debug:OBJECTS_DIR = $${OUT_PWD}/.obj/debug-shared
|
11
devel/edb/files/patch-src__src.pro
Normal file
11
devel/edb/files/patch-src__src.pro
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./src/src.pro.orig 2011-12-12 21:27:25.000000000 +0000
|
||||
+++ ./src/src.pro 2012-09-13 21:26:00.215566381 +0000
|
||||
@@ -5,7 +5,7 @@
|
||||
INCLUDEPATH += ./widgets ../include
|
||||
RESOURCES = debugger.qrc
|
||||
DESTDIR = ../
|
||||
-target.path = /bin/
|
||||
+target.path = $$PREFIX/bin/
|
||||
INSTALLS += target
|
||||
QT += xml
|
||||
|
7
devel/edb/pkg-descr
Normal file
7
devel/edb/pkg-descr
Normal file
@ -0,0 +1,7 @@
|
||||
edbg (Evan's Debugger) is a cross platform x86/x86-64 debugger. It
|
||||
was inspired by OllyDbg, but aims to function on x86 and x86-64 as
|
||||
well as multiple OS's. Linux is the only officially supported
|
||||
platform at the moment, but FreeBSD, OpenBSD, OSX and Windows ports
|
||||
are underway with varying degrees of functionality.
|
||||
|
||||
WWW: http://codef00.com/projects#debugger
|
23
devel/edb/pkg-plist
Normal file
23
devel/edb/pkg-plist
Normal file
@ -0,0 +1,23 @@
|
||||
bin/edb
|
||||
libexec/edb/libAnalyzer.so
|
||||
libexec/edb/libBinarySearcher.so
|
||||
libexec/edb/libBookmarks.so
|
||||
libexec/edb/libBreakpointManager.so
|
||||
libexec/edb/libCheckVersion.so
|
||||
libexec/edb/libDebuggerCore.so
|
||||
libexec/edb/libDumpState.so
|
||||
libexec/edb/libELFBinaryInfo.so
|
||||
libexec/edb/libEnvironment.so
|
||||
libexec/edb/libFunctionFinder.so
|
||||
libexec/edb/libHardwareBreakpoints.so
|
||||
libexec/edb/libHeapAnalyzer.so
|
||||
libexec/edb/libOpcodeSearcher.so
|
||||
libexec/edb/libROPTool.so
|
||||
libexec/edb/libReferences.so
|
||||
libexec/edb/libSessionManager.so
|
||||
libexec/edb/libStringSearcher.so
|
||||
libexec/edb/libSymbolViewer.so
|
||||
share/applications/edb.desktop
|
||||
share/pixmaps/edb.png
|
||||
@dirrmtry share/applications
|
||||
@dirrm libexec/edb
|
Loading…
Reference in New Issue
Block a user