Add phatbeat 1.1,

In a nutshell, PhatBeat is a cross-platform (Linux and Windows)
beat counter for use by collectors, producers, DJs, and others
interested in beat-oriented music. For now it requires users to
tap in the beat during listening, after which it calculates and
displays the track's BPM and the size of a measure in seconds.

PR:		ports/68198
Submitted by:	Jean-Yves Lefort <jylefort@brutele.be>
This commit is contained in:
Kirill Ponomarev 2004-06-22 14:34:15 +00:00
parent bd7a90118c
commit 0aff719a38
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=111987
7 changed files with 161 additions and 0 deletions

View File

@ -264,6 +264,7 @@
SUBDIR += p5-libvorbis
SUBDIR += p5-tagged
SUBDIR += pd
SUBDIR += phatbeat
SUBDIR += pimp3
SUBDIR += play
SUBDIR += playmidi

26
audio/phatbeat/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: PhatBeat
# Date created: 22 Jun 2004
# Whom: Jean-Yves Lefort <jylefort@brutele.be>
#
# $FreeBSD$
#
PORTNAME= phatbeat
PORTVERSION= 1.1
CATEGORIES= audio
MASTER_SITES= http://www.postreal.org/files/
DISTNAME= PhatBeat-${PORTVERSION}
MAINTAINER= jylefort@brutele.be
COMMENT= A beat counter
USE_X_PREFIX= yes
USE_SDL= sdl image
MAN1= phatbeat.1
MAKE_ENV= MKDIR="${MKDIR}" \
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_MAN="${INSTALL_MAN}" \
INSTALL_DATA="${INSTALL_DATA}"
.include <bsd.port.mk>

2
audio/phatbeat/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (PhatBeat-1.1.tar.gz) = 72a1c38db5e1b197f0e1d06a0928f922
SIZE (PhatBeat-1.1.tar.gz) = 206229

View File

@ -0,0 +1,82 @@
--- Makefile.orig Tue Jun 22 14:28:51 2004
+++ Makefile Tue Jun 22 14:47:27 2004
@@ -1,11 +1,10 @@
-CPP = g++
-SDL_LIBS = `sdl-config --libs`
-SDL_CFLAGS = `sdl-config --cflags`
+SDL_LIBS = `$(SDL_CONFIG) --libs`
+SDL_CFLAGS = `$(SDL_CONFIG) --cflags`
## dirs must be appended with a / character!
-LOCAL = /usr/local/
-SHAREDIR = $(LOCAL)share/phatbeat/
+LOCAL = $(PREFIX)
+SHAREDIR = $(LOCAL)/share/phatbeat/
D_PFLAGS = -Wall -g ## For debugging, use this.
-PFLAGS = -Wall -finline-functions -O3 $(SDL_CFLAGS)
+PFLAGS = $(CFLAGS) $(SDL_CFLAGS)
XFLAGS = $(PFLAGS) $(SDL_LIBS) -lSDL_image -lm
PROGS = phatbeat phatx
@@ -18,34 +17,34 @@
all: $(PROGS)
phatbeat: BeatCounter.o phatbeat.o
- $(CPP) $(PFLAGS) phatbeat.o BeatCounter.o -o phatbeat
+ $(CXX) $(PFLAGS) phatbeat.o BeatCounter.o -o phatbeat
phatx: BeatCounter.o phatx.o numbers.o resize.o portability.o
- $(CPP) $(XFLAGS) portability.o phatx.o resize.o numbers.o BeatCounter.o -o phatx
+ $(CXX) $(XFLAGS) portability.o phatx.o resize.o numbers.o BeatCounter.o -o phatx
BeatCounter.o: BeatCounter.h BeatCounter.cpp
- $(CPP) $(PFLAGS) -c BeatCounter.cpp
+ $(CXX) $(PFLAGS) -c BeatCounter.cpp
numbers.o: numbers.h numbers.cpp portability.o
- $(CPP) $(PFLAGS) -c numbers.cpp
-
+ $(CXX) $(PFLAGS) -c numbers.cpp
+
resize.o: resize.h resize.cpp
- $(CPP) $(PFLAGS) -c resize.cpp
+ $(CXX) $(PFLAGS) -c resize.cpp
phatbeat.o: phatbeat.cpp
- $(CPP) $(PFLAGS) -c phatbeat.cpp
+ $(CXX) $(PFLAGS) -c phatbeat.cpp
phatx.o: phatx.cpp
- $(CPP) $(PFLAGS) -c phatx.cpp
+ $(CXX) $(PFLAGS) -c phatx.cpp
portability.o: portability.cpp
- $(CPP) $(PFLAGS) -D'SHAREDIR="$(SHAREDIR)"' -c portability.cpp
+ $(CXX) $(PFLAGS) -D'SHAREDIR="$(SHAREDIR)"' -c portability.cpp
## For compiling a win32 version under cygwin, issue
## 'make phat_win', and it will do so.
phat_win: BeatCounter.o phatx.o numbers.o resize.o phatres.o
- $(CPP) -o phat_win.exe phatx.o resize.o numbers.o BeatCounter.o portability.o phatres.o $(XFLAGS)
+ $(CXX) -o phat_win.exe phatx.o resize.o numbers.o BeatCounter.o portability.o phatres.o $(XFLAGS)
phatres.o: phatres.rc
windres phatres.rc phatres.o
@@ -55,10 +54,10 @@
## Installation routines for unix.
install:
- ## First, install the programs.
- /usr/bin/install -c -m 755 phatbeat $(LOCAL)/bin
- /usr/bin/install -c -m 755 phatx $(LOCAL)/bin
- /usr/bin/install -c -m 444 phatbeat.1 $(LOCAL)/man/man1
- ## Then, the images
- mkdir -p $(SHAREDIR)/images
- /usr/bin/install -c -m 444 images/* $(SHAREDIR)/images
+ $(MKDIR) $(LOCAL)/bin
+ $(INSTALL_PROGRAM) phatbeat $(LOCAL)/bin
+ $(INSTALL_PROGRAM) phatx $(LOCAL)/bin
+ $(MKDIR) $(LOCAL)/man/man1
+ $(INSTALL_MAN) phatbeat.1 $(LOCAL)/man/man1
+ $(MKDIR) $(SHAREDIR)images
+ $(INSTALL_DATA) images/* $(SHAREDIR)images

View File

@ -0,0 +1,12 @@
--- phatbeat.cpp.orig Tue Jun 22 02:34:13 2004
+++ phatbeat.cpp Tue Jun 22 02:35:53 2004
@@ -24,6 +24,9 @@
#include "BeatCounter.h"
using namespace std;
+#include <sys/types.h>
+#include <sys/time.h>
+#include <string.h>
#include <stdlib.h>
using namespace std;
#include <stdio.h>

10
audio/phatbeat/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
In a nutshell, PhatBeat is a cross-platform (Linux and Windows) beat
counter for use by collectors, producers, DJs, and others interested
in beat-oriented music. For now it requires users to tap in the beat
during listening, after which it calculates and displays the track's
BPM and the size of a measure in seconds.
WWW: http://www.postreal.org/phatbeat
- Jean-Yves Lefort
jylefort@brutele.be

28
audio/phatbeat/pkg-plist Normal file
View File

@ -0,0 +1,28 @@
bin/phatbeat
bin/phatx
share/phatbeat/images/0.png
share/phatbeat/images/1.png
share/phatbeat/images/2.png
share/phatbeat/images/3.png
share/phatbeat/images/4.png
share/phatbeat/images/5.png
share/phatbeat/images/6.png
share/phatbeat/images/7.png
share/phatbeat/images/8.png
share/phatbeat/images/9.png
share/phatbeat/images/AC_dn.png
share/phatbeat/images/AC_up.png
share/phatbeat/images/bkgnd_test5.png
share/phatbeat/images/blackgnd.png
share/phatbeat/images/blnk.png
share/phatbeat/images/dnarrow_dn.png
share/phatbeat/images/dnarrow_up.png
share/phatbeat/images/icon.png
share/phatbeat/images/phaticon.ico
share/phatbeat/images/point.png
share/phatbeat/images/tap_dn.png
share/phatbeat/images/tap_up.png
share/phatbeat/images/uparrow_dn.png
share/phatbeat/images/uparrow_up.png
@dirrm share/phatbeat/images
@dirrm share/phatbeat