- Update nfsshell to the version by Michael Brown <michael@netdirect.ca>
This version also supports NFSv3 (but not without issues) - Enable STAGE support
This commit is contained in:
parent
29653cb71e
commit
0acb77f4cb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337876
@ -2,22 +2,25 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= nfsshell
|
||||
PORTVERSION= 19980519
|
||||
PORTVERSION= 20130510
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= http://www.cs.vu.nl/pub/leendert/
|
||||
#MASTER_SITES= http://www.cs.vu.nl/pub/leendert/
|
||||
DISTNAME= ${PORTNAME}
|
||||
|
||||
MAINTAINER= johans@FreeBSD.org
|
||||
COMMENT= Userland NFS command tool
|
||||
|
||||
WRKSRC= ${WRKDIR}/nfs
|
||||
ALL_TARGET= nfs
|
||||
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DREADLINE" LIBS="-lreadline"
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= NetDirect
|
||||
GH_TAGNAME= ${GH_COMMIT}
|
||||
GH_COMMIT= 09cdd52
|
||||
|
||||
ALL_TARGET= nfsshell
|
||||
MAKE_ARGS= CC="${CC}" LIBS="-lreadline"
|
||||
|
||||
PLIST_FILES= bin/nfsshell
|
||||
|
||||
NO_STAGE= yes
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/nfs ${PREFIX}/bin/nfsshell
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/nfsshell ${STAGEDIR}${PREFIX}/bin/nfsshell
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (nfsshell.tar.gz) = 900056f591e3a4f7ac9a7ea8d89464e9addc16ca4fe991a703ed61c98af38e2a
|
||||
SIZE (nfsshell.tar.gz) = 29213
|
||||
SHA256 (nfsshell.tar.gz) = f5df3ce7c313b11f0b0d7b7d6a2ecbb1c23761e6a4226cf6d5556ddceb37b25e
|
||||
SIZE (nfsshell.tar.gz) = 40129
|
||||
|
@ -1,10 +1,11 @@
|
||||
--- nfs.c.orig Sat Feb 5 23:17:18 2005
|
||||
+++ nfs.c Sat Feb 5 23:17:09 2005
|
||||
@@ -50,7 +50,6 @@
|
||||
--- nfsshell.c.orig 2013-05-10 23:40:04.000000000 +0200
|
||||
+++ nfsshell.c 2013-12-28 16:34:53.000000000 +0100
|
||||
@@ -70,7 +70,7 @@
|
||||
#include <netinet/in.h>
|
||||
#include <arpa/inet.h>
|
||||
#include <sys/time.h>
|
||||
-#include <sys/sysmacros.h>
|
||||
+#include <sys/param.h>
|
||||
#include "mount.h"
|
||||
#include "nfs_prot.h"
|
||||
#include <netinet/in_systm.h>
|
||||
|
10
net/nfsshell/files/patch-nfs_prot_xdr.c
Normal file
10
net/nfsshell/files/patch-nfs_prot_xdr.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- nfs_prot_xdr.c.orig 2013-12-28 16:36:09.000000000 +0100
|
||||
+++ nfs_prot_xdr.c 2013-12-28 16:36:34.000000000 +0100
|
||||
@@ -4,6 +4,7 @@
|
||||
*/
|
||||
|
||||
#include "nfs_prot.h"
|
||||
+#define xdr_u_quad_t xdr_u_int64_t
|
||||
|
||||
bool_t
|
||||
xdr_cookieverf3 (XDR *xdrs, cookieverf3 objp)
|
Loading…
Reference in New Issue
Block a user