- Fix mysqlhotdump vulnerability

- Fix plist (don't install .la files)

Approved by:	portmgr (marcus)
This commit is contained in:
Alex Dupre 2004-09-24 16:21:27 +00:00
parent 41b555d7e9
commit 0ac896f1ce
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=118376
29 changed files with 360 additions and 83 deletions

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 2
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 1
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)

View File

@ -29,8 +29,7 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql50-client
PKGINSTALL?= ${WRKDIR}/pkg-install
DB_DIR?= /var/db/mysql
USE_GNOME= lthack
USE_LIBTOOL_VER= 13
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -67,7 +66,7 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "i386"
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
.if defined(WITH_LINUXTHREADS)

View File

@ -1,14 +1,14 @@
--- configure.orig Sun Dec 21 19:03:09 2003
+++ configure Wed Dec 24 10:40:53 2003
@@ -9069,7 +9070,7 @@
;;
esac
fi
-HOSTNAME=$ac_cv_path_HOSTNAME
+HOSTNAME="$ac_cv_path_HOSTNAME -s"
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
@@ -8128,8 +8128,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"; $ac_aux_dir/ltconfig $LIBTOOL_DEPS;
-# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Prevent multiple expansion
@@ -9261,43 +9262,8 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6

View File

@ -0,0 +1,49 @@
--- scripts/mysqlhotcopy.sh.orig Sun Dec 21 19:01:29 2003
+++ scripts/mysqlhotcopy.sh Thu Sep 23 11:02:45 2004
@@ -7,6 +7,7 @@
use File::Path;
use DBI;
use Sys::Hostname;
+use File::Temp;
=head1 NAME
@@ -607,7 +608,6 @@
sub copy_index
{
my ($method, $files, $source, $target) = @_;
- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
foreach my $file (@$files)
@@ -633,23 +633,23 @@
}
close OUTPUT || die "Error on close of $to: $!\n";
}
- elsif ($opt{method} eq 'scp')
+ elsif ($opt{method} =~ /^scp\b/)
{
- my $tmp=$tmpfile;
- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
- if (syswrite(OUTPUT,$buff) != length($buff))
+ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
+ die "Can\'t create/open file in $opt_tmpdir\n";
+ if (syswrite($fh,$buff) != length($buff))
{
die "Error when writing data to $tmp: $!\n";
}
- close OUTPUT || die "Error on close of $tmp: $!\n";
- safe_system("scp $tmp $to");
+ close $fh || die "Error on close of $tmp: $!\n";
+ safe_system("$opt{method} $tmp $to");
+ unlink $tmp;
}
else
{
die "Can't use unsupported method '$opt{method}'\n";
}
}
- unlink "$tmpfile" if ($opt{method} eq 'scp');
}

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 2
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 1
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)

View File

@ -29,8 +29,7 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql50-client
PKGINSTALL?= ${WRKDIR}/pkg-install
DB_DIR?= /var/db/mysql
USE_GNOME= lthack
USE_LIBTOOL_VER= 13
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -67,7 +66,7 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "i386"
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
.if defined(WITH_LINUXTHREADS)

View File

@ -1,14 +1,14 @@
--- configure.orig Sun Dec 21 19:03:09 2003
+++ configure Wed Dec 24 10:40:53 2003
@@ -9069,7 +9070,7 @@
;;
esac
fi
-HOSTNAME=$ac_cv_path_HOSTNAME
+HOSTNAME="$ac_cv_path_HOSTNAME -s"
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
@@ -8128,8 +8128,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"; $ac_aux_dir/ltconfig $LIBTOOL_DEPS;
-# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Prevent multiple expansion
@@ -9261,43 +9262,8 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6

View File

@ -0,0 +1,49 @@
--- scripts/mysqlhotcopy.sh.orig Sun Dec 21 19:01:29 2003
+++ scripts/mysqlhotcopy.sh Thu Sep 23 11:02:45 2004
@@ -7,6 +7,7 @@
use File::Path;
use DBI;
use Sys::Hostname;
+use File::Temp;
=head1 NAME
@@ -607,7 +608,6 @@
sub copy_index
{
my ($method, $files, $source, $target) = @_;
- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
foreach my $file (@$files)
@@ -633,23 +633,23 @@
}
close OUTPUT || die "Error on close of $to: $!\n";
}
- elsif ($opt{method} eq 'scp')
+ elsif ($opt{method} =~ /^scp\b/)
{
- my $tmp=$tmpfile;
- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
- if (syswrite(OUTPUT,$buff) != length($buff))
+ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
+ die "Can\'t create/open file in $opt_tmpdir\n";
+ if (syswrite($fh,$buff) != length($buff))
{
die "Error when writing data to $tmp: $!\n";
}
- close OUTPUT || die "Error on close of $tmp: $!\n";
- safe_system("scp $tmp $to");
+ close $fh || die "Error on close of $tmp: $!\n";
+ safe_system("$opt{method} $tmp $to");
+ unlink $tmp;
}
else
{
die "Can't use unsupported method '$opt{method}'\n";
}
}
- unlink "$tmpfile" if ($opt{method} eq 'scp');
}

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 2
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 1
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)

View File

@ -29,8 +29,7 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql50-client
PKGINSTALL?= ${WRKDIR}/pkg-install
DB_DIR?= /var/db/mysql
USE_GNOME= lthack
USE_LIBTOOL_VER= 13
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -67,7 +66,7 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "i386"
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
.if defined(WITH_LINUXTHREADS)

View File

@ -1,14 +1,14 @@
--- configure.orig Sun Dec 21 19:03:09 2003
+++ configure Wed Dec 24 10:40:53 2003
@@ -9069,7 +9070,7 @@
;;
esac
fi
-HOSTNAME=$ac_cv_path_HOSTNAME
+HOSTNAME="$ac_cv_path_HOSTNAME -s"
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
@@ -8128,8 +8128,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"; $ac_aux_dir/ltconfig $LIBTOOL_DEPS;
-# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Prevent multiple expansion
@@ -9261,43 +9262,8 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6

View File

@ -0,0 +1,49 @@
--- scripts/mysqlhotcopy.sh.orig Sun Dec 21 19:01:29 2003
+++ scripts/mysqlhotcopy.sh Thu Sep 23 11:02:45 2004
@@ -7,6 +7,7 @@
use File::Path;
use DBI;
use Sys::Hostname;
+use File::Temp;
=head1 NAME
@@ -607,7 +608,6 @@
sub copy_index
{
my ($method, $files, $source, $target) = @_;
- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
foreach my $file (@$files)
@@ -633,23 +633,23 @@
}
close OUTPUT || die "Error on close of $to: $!\n";
}
- elsif ($opt{method} eq 'scp')
+ elsif ($opt{method} =~ /^scp\b/)
{
- my $tmp=$tmpfile;
- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
- if (syswrite(OUTPUT,$buff) != length($buff))
+ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
+ die "Can\'t create/open file in $opt_tmpdir\n";
+ if (syswrite($fh,$buff) != length($buff))
{
die "Error when writing data to $tmp: $!\n";
}
- close OUTPUT || die "Error on close of $tmp: $!\n";
- safe_system("scp $tmp $to");
+ close $fh || die "Error on close of $tmp: $!\n";
+ safe_system("$opt{method} $tmp $to");
+ unlink $tmp;
}
else
{
die "Can't use unsupported method '$opt{method}'\n";
}
}
- unlink "$tmpfile" if ($opt{method} eq 'scp');
}

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 2
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 1
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)

View File

@ -29,8 +29,7 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql50-client
PKGINSTALL?= ${WRKDIR}/pkg-install
DB_DIR?= /var/db/mysql
USE_GNOME= lthack
USE_LIBTOOL_VER= 13
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -67,7 +66,7 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "i386"
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
.if defined(WITH_LINUXTHREADS)

View File

@ -1,14 +1,14 @@
--- configure.orig Sun Dec 21 19:03:09 2003
+++ configure Wed Dec 24 10:40:53 2003
@@ -9069,7 +9070,7 @@
;;
esac
fi
-HOSTNAME=$ac_cv_path_HOSTNAME
+HOSTNAME="$ac_cv_path_HOSTNAME -s"
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
@@ -8128,8 +8128,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"; $ac_aux_dir/ltconfig $LIBTOOL_DEPS;
-# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Prevent multiple expansion
@@ -9261,43 +9262,8 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6

View File

@ -0,0 +1,49 @@
--- scripts/mysqlhotcopy.sh.orig Sun Dec 21 19:01:29 2003
+++ scripts/mysqlhotcopy.sh Thu Sep 23 11:02:45 2004
@@ -7,6 +7,7 @@
use File::Path;
use DBI;
use Sys::Hostname;
+use File::Temp;
=head1 NAME
@@ -607,7 +608,6 @@
sub copy_index
{
my ($method, $files, $source, $target) = @_;
- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
foreach my $file (@$files)
@@ -633,23 +633,23 @@
}
close OUTPUT || die "Error on close of $to: $!\n";
}
- elsif ($opt{method} eq 'scp')
+ elsif ($opt{method} =~ /^scp\b/)
{
- my $tmp=$tmpfile;
- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
- if (syswrite(OUTPUT,$buff) != length($buff))
+ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
+ die "Can\'t create/open file in $opt_tmpdir\n";
+ if (syswrite($fh,$buff) != length($buff))
{
die "Error when writing data to $tmp: $!\n";
}
- close OUTPUT || die "Error on close of $tmp: $!\n";
- safe_system("scp $tmp $to");
+ close $fh || die "Error on close of $tmp: $!\n";
+ safe_system("$opt{method} $tmp $to");
+ unlink $tmp;
}
else
{
die "Can't use unsupported method '$opt{method}'\n";
}
}
- unlink "$tmpfile" if ($opt{method} eq 'scp');
}

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 2
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 1
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)

View File

@ -29,8 +29,7 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql50-client
PKGINSTALL?= ${WRKDIR}/pkg-install
DB_DIR?= /var/db/mysql
USE_GNOME= lthack
USE_LIBTOOL_VER= 13
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -67,7 +66,7 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "i386"
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
.if defined(WITH_LINUXTHREADS)

View File

@ -1,14 +1,14 @@
--- configure.orig Sun Dec 21 19:03:09 2003
+++ configure Wed Dec 24 10:40:53 2003
@@ -9069,7 +9070,7 @@
;;
esac
fi
-HOSTNAME=$ac_cv_path_HOSTNAME
+HOSTNAME="$ac_cv_path_HOSTNAME -s"
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
@@ -8128,8 +8128,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"; $ac_aux_dir/ltconfig $LIBTOOL_DEPS;
-# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Prevent multiple expansion
@@ -9261,43 +9262,8 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6

View File

@ -0,0 +1,49 @@
--- scripts/mysqlhotcopy.sh.orig Sun Dec 21 19:01:29 2003
+++ scripts/mysqlhotcopy.sh Thu Sep 23 11:02:45 2004
@@ -7,6 +7,7 @@
use File::Path;
use DBI;
use Sys::Hostname;
+use File::Temp;
=head1 NAME
@@ -607,7 +608,6 @@
sub copy_index
{
my ($method, $files, $source, $target) = @_;
- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
foreach my $file (@$files)
@@ -633,23 +633,23 @@
}
close OUTPUT || die "Error on close of $to: $!\n";
}
- elsif ($opt{method} eq 'scp')
+ elsif ($opt{method} =~ /^scp\b/)
{
- my $tmp=$tmpfile;
- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
- if (syswrite(OUTPUT,$buff) != length($buff))
+ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
+ die "Can\'t create/open file in $opt_tmpdir\n";
+ if (syswrite($fh,$buff) != length($buff))
{
die "Error when writing data to $tmp: $!\n";
}
- close OUTPUT || die "Error on close of $tmp: $!\n";
- safe_system("scp $tmp $to");
+ close $fh || die "Error on close of $tmp: $!\n";
+ safe_system("$opt{method} $tmp $to");
+ unlink $tmp;
}
else
{
die "Can't use unsupported method '$opt{method}'\n";
}
}
- unlink "$tmpfile" if ($opt{method} eq 'scp');
}

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 2
PKGNAMESUFFIX= -client
COMMENT= Multithreaded SQL database (client)

View File

@ -29,8 +29,7 @@ COMMENT?= Multithreaded SQL database (server)
SLAVEDIRS= databases/mysql50-client
PKGINSTALL?= ${WRKDIR}/pkg-install
DB_DIR?= /var/db/mysql
USE_GNOME= lthack
USE_LIBTOOL_VER= 13
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@ -67,7 +66,7 @@ CONFIGURE_ARGS+=--with-mysqld-ldflags=-all-static
.include <bsd.port.pre.mk>
.if ${MACHINE_ARCH} == "i386"
.if ${ARCH} == "i386"
CONFIGURE_ARGS+=--enable-assembler --with-berkeley-db
.endif
.if defined(WITH_LINUXTHREADS)

View File

@ -1,14 +1,14 @@
--- configure.orig Sun Dec 21 19:03:09 2003
+++ configure Wed Dec 24 10:40:53 2003
@@ -9069,7 +9070,7 @@
;;
esac
fi
-HOSTNAME=$ac_cv_path_HOSTNAME
+HOSTNAME="$ac_cv_path_HOSTNAME -s"
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
@@ -8128,8 +8128,6 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"; $ac_aux_dir/ltconfig $LIBTOOL_DEPS;
-# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
# Prevent multiple expansion
@@ -9261,43 +9262,8 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6

View File

@ -0,0 +1,49 @@
--- scripts/mysqlhotcopy.sh.orig Sun Dec 21 19:01:29 2003
+++ scripts/mysqlhotcopy.sh Thu Sep 23 11:02:45 2004
@@ -7,6 +7,7 @@
use File::Path;
use DBI;
use Sys::Hostname;
+use File::Temp;
=head1 NAME
@@ -607,7 +608,6 @@
sub copy_index
{
my ($method, $files, $source, $target) = @_;
- my $tmpfile="$opt_tmpdir/mysqlhotcopy$$";
print "Copying indices for ".@$files." files...\n" unless $opt{quiet};
foreach my $file (@$files)
@@ -633,23 +633,23 @@
}
close OUTPUT || die "Error on close of $to: $!\n";
}
- elsif ($opt{method} eq 'scp')
+ elsif ($opt{method} =~ /^scp\b/)
{
- my $tmp=$tmpfile;
- open(OUTPUT,">$tmp") || die "Can\'t create file $tmp: $!\n";
- if (syswrite(OUTPUT,$buff) != length($buff))
+ my ($fh, $tmp)=tempfile('mysqlhotcopy-XXXXXX', DIR => $opt_tmpdir);
+ die "Can\'t create/open file in $opt_tmpdir\n";
+ if (syswrite($fh,$buff) != length($buff))
{
die "Error when writing data to $tmp: $!\n";
}
- close OUTPUT || die "Error on close of $tmp: $!\n";
- safe_system("scp $tmp $to");
+ close $fh || die "Error on close of $tmp: $!\n";
+ safe_system("$opt{method} $tmp $to");
+ unlink $tmp;
}
else
{
die "Can't use unsupported method '$opt{method}'\n";
}
}
- unlink "$tmpfile" if ($opt{method} eq 'scp');
}