Update to 1.50.

This commit is contained in:
Adam Weinberger 2014-12-26 20:05:07 +00:00
parent be0e5ed6eb
commit 0abb49dbcf
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=375653
3 changed files with 7 additions and 47 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= xdiskusage
PORTVERSION= 1.48
PORTREVISION= 8
PORTVERSION= 1.50
CATEGORIES= x11-fm
MASTER_SITES= http://xdiskusage.sourceforge.net/ \
http://www.gnu-darwin.org/distfiles/
@ -21,7 +20,10 @@ LDFLAGS+= `fltk-config --ldflags`
PLIST_FILES= bin/xdiskusage man/man1/xdiskusage.1.gz
post-patch:
${REINPLACE_CMD} -e '22,24d' ${WRKSRC}/Makefile
${REINPLACE_CMD} -e '/^configure:/d; /autoconf/d' \
${WRKSRC}/Makefile
${REINPLACE_CMD} -e '/@CXXFLAGS@/s|$$| ${CXXFLAGS}|' \
${WRKSRC}/makeinclude.in
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdiskusage ${STAGEDIR}${PREFIX}/bin

View File

@ -1,2 +1,2 @@
SHA256 (xdiskusage-1.48.tgz) = 7842aa42510bf52c367164d44a977915ad9f070864d5175157738f8d6894274b
SIZE (xdiskusage-1.48.tgz) = 37332
SHA256 (xdiskusage-1.50.tgz) = 828128775885b99397e9067b7d731f485ca1378ded256619a2d733a3ded36013
SIZE (xdiskusage-1.50.tgz) = 54211

View File

@ -1,42 +0,0 @@
--- xdiskusage.C.orig 2004-09-21 07:23:14.000000000 +0200
+++ xdiskusage.C 2011-06-21 21:34:20.000000000 +0200
@@ -392,8 +392,8 @@
strncpy(pathbuf, path, 1024);
for (int i=0; i<10; i++) {
char *p = (char*)fl_filename_name(pathbuf);
- int i = readlink(pathbuf, p, 1024-(p-pathbuf));
- if (i < 0) {
+ int j = readlink(pathbuf, p, 1024-(p-pathbuf));
+ if (j < 0) {
if (errno != EINVAL) {
strcat(pathbuf, ": no such file");
fl_alert(pathbuf);
@@ -401,8 +401,8 @@
}
break;
}
- if (*p == '/') {memmove(pathbuf, p, i); p = pathbuf;}
- p[i] = 0;
+ if (*p == '/') {memmove(pathbuf, p, j); p = pathbuf;}
+ p[j] = 0;
path = pathbuf;
}
}
@@ -988,7 +988,7 @@
void OutputWindow::sort_cb(Fl_Widget* o, void*v) {
OutputWindow* d = (OutputWindow*)(o->window());
int (*compare)(const Node*, const Node*);
- switch ((int)v) {
+ switch ((unsigned long)v) {
case 's': compare = largestfirst; break;
case 'r': compare = smallestfirst; break;
case 'a': compare = alphabetical; break;
@@ -1001,7 +1001,7 @@
void OutputWindow::columns_cb(Fl_Widget* o, void*v) {
OutputWindow* d = (OutputWindow*)(o->window());
- int n = (int)v;
+ unsigned long n = (unsigned long)v;
::ncols = n;
if (n == d->ncols) return;
if (d->current_depth > d->root_depth+n-1) {