Update to 1.8

PR:		34136
Submitted by:	maintainer
This commit is contained in:
Patrick Li 2002-01-22 06:03:04 +00:00
parent 85f8175f62
commit 0ab2484919
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=53528
7 changed files with 21 additions and 60 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= proxy-suite
PORTVERSION= 1.7
PORTREVISION= 1
PORTVERSION= 1.8
CATEGORIES= net
MASTER_SITES= ftp://ftp.suse.com/pub/projects/proxy-suite/src/ \
ftp://ftp.crc.ca/pub/systems/linux/suse/projects/proxy-suite/src/ \
@ -23,11 +22,17 @@ USE_GMAKE= yes
# basic configure args
#
CONFIGURE_ARGS= --prefix=${PREFIX} --with-libwrap=/usr/lib --with-regex \
--sysconfdir=${PREFIX}/etc/proxy-suite \
--localstatedir=/var/run \
--enable-warnings --enable-so-linger --enable-rfc1579 \
--enable-warnings --enable-so-linger \
--disable-proc-mods
#
# OPTIONAL: RFC1579 support -- not complete yet.
#
.if defined(WITH_RFC1579)
CONFIGURE_ARGS+= --enable-rfc1579
.endif
#
# OPTIONAL: include ldap-support - currently ldap.2 needs minor fixes...
#
@ -53,4 +58,7 @@ MAN5= ftp-proxy.conf.5
pre-install:
@strip ${WRKSRC}/ftp-proxy/ftp-proxy
post-install:
@${SED} 's|PREFIX|${PREFIX}|' ${PKGMESSAGE}
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (proxy-suite-1.7.tar.gz) = de879e5d0c6398fde9970db3c5877fad
MD5 (proxy-suite-1.8.tar.gz) = 6411481720439022a3a2a0f30ec6a86b

View File

@ -1,11 +0,0 @@
--- ftp-proxy/Makefile.in
+++ ftp-proxy/Makefile.in Tue Jun 26 01:12:06 2001
@@ -55,7 +55,7 @@
PROC_FTP= @PROC_FTP@
CONF_SRC= ftp-proxy.conf.sample
-CONF_DST= $(ETC_DIR)/ftp-proxy.conf
+CONF_DST= $(ETC_DIR)/ftp-proxy.conf.sample
FTP_MAN5= ftp-proxy.conf.5
FTP_MAN8= ftp-proxy.8

View File

@ -1,26 +0,0 @@
diff -ur work/proxy-suite-1.7/ftp-proxy/Makefile.in new/proxy-suite-1.7/ftp-proxy/Makefile.in
--- work/proxy-suite-1.7/ftp-proxy/Makefile.in Fri Oct 22 11:29:01 1999
+++ ftp-proxy/Makefile.in Wed May 2 01:07:28 2001
@@ -44,7 +44,7 @@
INSTALL= @INSTALL@
CC= @CC@
-CFLAGS= @CFLAGS@
+CFLAGS= @CFLAGS@ -DETC_PATH=\"$(ETC_DIR)/\"
LDFLAGS= @LDFLAGS@
LIBS= @LIB_WRAP@ @LIB_LDAP@ @LIB_REGEX@ @LIBS@
diff -ur work/proxy-suite-1.7/ftp-proxy/ftp-main.c new/proxy-suite-1.7/ftp-proxy/ftp-main.c
--- work/proxy-suite-1.7/ftp-proxy/ftp-main.c Fri Oct 22 11:29:01 1999
+++ ftp-proxy/ftp-main.c Wed May 2 01:03:58 2001
@@ -75,7 +75,9 @@
#define SELECT_TIMEOUT 60 /* Wake up regularly */
-#define ETC_PATH "/etc/proxy-suite/"
+#if !defined (ETC_PATH)
+# define ETC_PATH "/etc/proxy-suite/"
+#endif
#define DEFAULT_CONFIG ETC_PATH "ftp-proxy.conf"
#if defined(COMPILE_DEBUG)

View File

@ -1,13 +0,0 @@
--- common/com-socket.c.orig Fri Feb 11 15:20:33 2000
+++ common/com-socket.c Fri Feb 11 15:20:52 2000
@@ -71,8 +71,9 @@
#include <sys/ioctl.h>
#include <netdb.h>
-#include <netinet/ip.h>
#include <netinet/in.h>
+#include <netinet/in_systm.h>
+#include <netinet/ip.h>
#include <sys/socket.h>
#include <arpa/inet.h>

View File

@ -1,4 +1,7 @@
This port provides a sample configuration file as
PREFIX/etc/proxy-suite/ftp-proxy.conf.sample
Please copy this file to ftp-proxy.conf and edit
to fit your needs. Default PREFIX is /usr/local.
This port provides a configuration file at
PREFIX/etc/proxy-suite/ftp-proxy.conf
Edit to fit your needs.

View File

@ -1,3 +1,3 @@
sbin/ftp-proxy
etc/proxy-suite/ftp-proxy.conf.sample
etc/proxy-suite/ftp-proxy.conf
@dirrm etc/proxy-suite