Fix linking after r436971
/usr/bin/ld: cannot find -lweather_ion c++: error: linker command failed with exit code 1 (use -v to see invocation) *** Error code 1 Add missing dependencies Fix LICENSE and add LICENSE_FILE
This commit is contained in:
parent
b4555a2a12
commit
0aabff3b94
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=437187
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= yawp
|
||||
PORTVERSION= 0.4.5
|
||||
PORTREVISION= 4
|
||||
PORTREVISION= 5
|
||||
CATEGORIES= deskutils kde
|
||||
MASTER_SITES= SF
|
||||
PKGNAMEPREFIX= plasma-applet-
|
||||
@ -10,10 +10,12 @@ PKGNAMEPREFIX= plasma-applet-
|
||||
MAINTAINER= jhale@FreeBSD.org
|
||||
COMMENT= KDE4 weather plasma applet
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE= GPLv2+
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE-GPL2
|
||||
|
||||
USES= cmake gettext kde:4 tar:bzip2
|
||||
USE_KDE= automoc4 workspace
|
||||
USE_QT4= qmake_build moc_build rcc_build uic_build
|
||||
USE_KDE= automoc4 kdelibs workspace
|
||||
USE_QT4= corelib dbus gui network svg xml \
|
||||
qmake_build moc_build rcc_build uic_build
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
23
deskutils/plasma-applet-yawp/files/patch-CMakeLists.txt
Normal file
23
deskutils/plasma-applet-yawp/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,23 @@
|
||||
Raise CMake minimum version requirement to squash warnings
|
||||
Don't redefine KDE4WORKSPACE_WEATHERION_LIBRARY as it causes linking failure
|
||||
|
||||
--- CMakeLists.txt.orig 2013-03-23 08:31:22 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -1,5 +1,5 @@
|
||||
PROJECT(plasma-applet-yawp)
|
||||
-cmake_minimum_required(VERSION 2.6)
|
||||
+cmake_minimum_required(VERSION 2.8.9)
|
||||
|
||||
#if you don't want the full compiler output, remove the following line
|
||||
SET(CMAKE_VERBOSE_MAKEFILE ON)
|
||||
@@ -40,10 +40,6 @@ else ( ${KDE_VERSION} VERSION_LESS "4.1.
|
||||
set( PLASMA_LIBS ${KDE4_PLASMA_LIBS} )
|
||||
endif ( ${KDE_VERSION} VERSION_LESS "4.1.90" )
|
||||
|
||||
-if ( ${KDE_VERSION} VERSION_GREATER "4.2.9" )
|
||||
- set( KDE4WORKSPACE_WEATHERION_LIBRARY weather_ion)
|
||||
-endif ( ${KDE_VERSION} VERSION_GREATER "4.2.9" )
|
||||
-
|
||||
FIND_PACKAGE(Qt4 REQUIRED QtNetwork QtGui QtCore QtXml QtSvg QtDbus)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user