Update to version 4.5.31.

PR:             11844
Submitted by:   Jeremy Lea <reg@shale.csir.co.za>
This commit is contained in:
Steve Price 1999-05-30 03:57:42 +00:00
parent 56895b072f
commit 0aa402e8e2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19118
6 changed files with 51 additions and 37 deletions

View File

@ -1,13 +1,13 @@
# New ports collection makefile for: gnomemc
# Version required: 4.5.30
# Version required: 4.5.31
# Date created: 26 January 1999
# Whom: Jeremy Lea <reg@shale.csir.co.za>
#
# $Id: Makefile,v 1.4 1999/04/08 18:08:38 steve Exp $
# $Id: Makefile,v 1.5 1999/05/09 17:16:07 steve Exp $
#
DISTNAME= mc-4.5.30
PKGNAME= gnomemc-4.5.30
DISTNAME= mc-4.5.31
PKGNAME= gnomemc-4.5.31
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/mc
@ -17,8 +17,7 @@ MAINTAINER= reg@shale.csir.co.za
BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
# implicit dependencies:
# gettext, glib12, xpm, gnomelibs
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
USE_X_PREFIX= yes
USE_GMAKE= yes
@ -26,9 +25,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
--without-edit -with-ncurses
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAKE="gmake" \
GLIB_CONFIG="${LOCALBASE}/bin/glib12-config" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
GLIB_CONFIG="${GLIB_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (mc-4.5.30.tar.gz) = 8b134ec792ec5a7916092b274847b99e
MD5 (mc-4.5.31.tar.gz) = ac1e86c7cba7584c7ab7dd1ef5fc28cf

View File

@ -10,13 +10,11 @@
INSTOBJEXT=.mo
DATADIRNAME=share
- INTLDEPS='$(top_builddir)/intl/libintl.a'
- INTLLIBS=$INTLDEPS
- LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+ INTLDEPS='-lintl'
INTLLIBS=$INTLDEPS
LIBS=`echo $LIBS | sed -e 's/-lintl//'`
- nls_cv_header_intl=intl/libintl.h
- nls_cv_header_libgt=intl/libgettext.h
+# INTLDEPS='$(top_builddir)/intl/libintl.a'
+# INTLLIBS=$INTLDEPS
+# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+# nls_cv_header_intl=intl/libintl.h
+# nls_cv_header_libgt=intl/libgettext.h
fi

View File

@ -1,6 +1,17 @@
--- vfs/Make-mc.in.orig Sat Apr 10 21:38:29 1999
+++ vfs/Make-mc.in Thu May 6 08:42:43 1999
@@ -184,21 +184,14 @@
--- vfs/Make-mc.in.orig Tue Mar 30 08:34:34 1999
+++ vfs/Make-mc.in Wed Apr 7 22:53:32 1999
@@ -13,8 +13,9 @@
DEFS = $(XDEFS)
LIBS = @LINTL@ @SHADOWLIB@ $(XLIBS) @TERMNET@ @PAMLIBS@ @LCRYPT@ $(XLIB)
INSTALL = @INSTALL@
-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -m 755
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
AR = @AR@
#
@@ -184,9 +185,6 @@
-$(RMF) $(srcdir)/Makefile
install: @mcserv@ install.extfs
@ -10,18 +21,17 @@
install.extfs:
for I in $(EXTFS_MISC); do \
- $(INSTALL_DATA) $(srcdir)/extfs/$$I \
+ $(INSTALL_DATA) extfs/$$I \
@@ -194,11 +192,11 @@
$(DESTDIR)$(extfsdir)/$$I; \
done
- for I in $(EXTFS_CONST) ; do \
for I in $(EXTFS_CONST) ; do \
- $(INSTALL_PROGRAM) $(srcdir)/extfs/$$I \
- $(DESTDIR)$(extfsdir)/$$I; \
- done
- for I in $(EXTFS_OUT) ; do \
+ $(INSTALL_SCRIPT) $(srcdir)/extfs/$$I \
$(DESTDIR)$(extfsdir)/$$I; \
done
for I in $(EXTFS_OUT) ; do \
- $(INSTALL_PROGRAM) $(builddir)/vfs/extfs/$$I \
+ for I in $(EXTFS_CONST) $(EXTFS_OUT) ; do \
+ install -c -o root -g wheel -m 555 -m 755 extfs/$$I \
+ $(INSTALL_SCRIPT) $(builddir)/vfs/extfs/$$I \
$(DESTDIR)$(extfsdir)/$$I; \
done

View File

@ -1,19 +1,14 @@
--- Make.common.in.orig Thu May 6 09:19:55 1999
+++ Make.common.in Thu May 6 09:22:12 1999
@@ -19,14 +19,14 @@
bindir = @bindir@
sysconfdir = @sysconfdir@
datadir = @datadir@
-libdir = @libdir@
+libdir = @localstatedir@
mandir = @mandir@
--- Make.common.in.orig Tue Mar 30 08:34:33 1999
+++ Make.common.in Wed Apr 7 23:18:45 1999
@@ -24,9 +24,9 @@
gnomeicondir = @gnomeicondir@
xv_bindir = @xv_bindir@
corbadir = $(sysconfdir)/CORBA/servers
mclibdir = $(libdir)/mc
-mclibdir = $(libdir)/mc
+mclibdir = $(datadir)/mc
desktopdir = $(mclibdir)/desktop-scripts
-idldir = $(prefix)/share/idl
+idldir = @localstatedir@/idl
+idldir = $(datadir)/idl
suppbindir = $(mclibdir)/bin
gnewdir = $(prefix)/share/mc/templates
tidir = $(mclibdir)/term

View File

@ -21,9 +21,11 @@ share/gnome/mc/extfs/rpms
share/gnome/mc/extfs/sfs.ini
share/gnome/mc/extfs/trpm
share/gnome/mc/extfs/uar
share/gnome/mc/extfs/uarj
share/gnome/mc/extfs/ucpio
share/gnome/mc/extfs/uha
share/gnome/mc/extfs/ulha
share/gnome/mc/extfs/unarj.diff
share/gnome/mc/extfs/urar
share/gnome/mc/extfs/uzip
share/gnome/mc/extfs/uzoo
@ -56,6 +58,15 @@ share/gnome/pixmaps/mc/gnome-application-postscript.png
share/gnome/pixmaps/mc/gnome-application-x-c-header.png
share/gnome/pixmaps/mc/gnome-application-x-c-source.png
share/gnome/pixmaps/mc/gnome-application-x-cc-source.png
share/gnome/pixmaps/mc/gnome-audio-basic.png
share/gnome/pixmaps/mc/gnome-audio-midi.png
share/gnome/pixmaps/mc/gnome-audio-ulaw.png
share/gnome/pixmaps/mc/gnome-audio-x-aiff.png
share/gnome/pixmaps/mc/gnome-audio-x-mod.png
share/gnome/pixmaps/mc/gnome-audio-x-mp3.png
share/gnome/pixmaps/mc/gnome-audio-x-pn-realaudio.png
share/gnome/pixmaps/mc/gnome-audio-x-voc.png
share/gnome/pixmaps/mc/gnome-audio-x-wav.png
share/gnome/pixmaps/mc/gnome-audio.png
share/gnome/pixmaps/mc/gnome-compressed.png
share/gnome/pixmaps/mc/gnome-core.png
@ -79,6 +90,7 @@ share/gnome/pixmaps/mc/gnome-image-xbm.png
share/gnome/pixmaps/mc/gnome-image-xcf.png
share/gnome/pixmaps/mc/gnome-image-xpm.png
share/gnome/pixmaps/mc/gnome-image-xwd.png
share/gnome/pixmaps/mc/gnome-library.png
share/gnome/pixmaps/mc/gnome-manpage.png
share/gnome/pixmaps/mc/gnome-objectfile.png
share/gnome/pixmaps/mc/gnome-pack-deb.png