bbFTP is a file transfer software. It implements its own transfer protocol,

which is optimized for large files (larger than 2GB) and secure as it does not
read the password in a file and encrypts the connection information.  bbFTP
main features are:

    * Encoded username and password at connection
    * SSH and Certificate authentication modules
    * Multi-stream transfer
    * Big windows as defined in RFC1323
    * On-the-fly data compression
    * Automatic retry
    * Customizable time-outs
    * Transfer simulation
    * AFS authentication integration
    * RFIO interface

bbFTP is open-source software, released under the GNU General Public License.
It was written by Gilles Farrache at IN2P3 Computing Center in Lyon, France.

WWW: http://doc.in2p3.fr/bbftp/index.html

PR:		ports/98610
Submitted by:	Petr Holub <hopet@ics.muni.cz>
This commit is contained in:
Pav Lucistnik 2006-06-07 18:38:09 +00:00
parent 672b6f32fe
commit 0a95856432
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=164736
7 changed files with 243 additions and 0 deletions

View File

@ -7,6 +7,7 @@
SUBDIR += axel
SUBDIR += axelq
SUBDIR += axyftp
SUBDIR += bbftp
SUBDIR += bftpd
SUBDIR += bsdftpd-ssl
SUBDIR += cftp

42
ftp/bbftp/Makefile Normal file
View File

@ -0,0 +1,42 @@
# New ports collection makefile for: bbftp
# Date created: 6 June 2006
# Whom: Petr Holub <hopet@ics.muni.cz>
#
# $FreeBSD$
#
PORTNAME= bbftp
PORTVERSION= 3.0.2
CATEGORIES= ftp
MASTER_SITES= http://doc.in2p3.fr/bbftp/dist/ \
http://ftp.riken.go.jp/pub/net/bbftp/
MAINTAINER= hopet@ics.muni.cz
COMMENT= Multiple stream file transfer protocol optimized for large files
USE_GMAKE= yes
GNU_CONFIGURE= yes
EXTRA_PATCHES= ${FILESDIR}/bbftp.patch
USE_RC_SUBR= bbftpd
MAN1= bbftp.1 bbftpd.1
do-configure:
${CP} -f ${TEMPLATES}/config.guess ${WRKSRC}
${CP} -f ${TEMPLATES}/config.sub ${WRKSRC}
cd ${WRKSRC}/bbftpc && ./configure --prefix=${PREFIX} ${CONFIGURE_ARGS}
cd ${WRKSRC}/bbftpd && ./configure --prefix=${PREFIX} ${CONFIGURE_ARGS}
do-build:
cd ${WRKSRC}/bbftpc && ${GMAKE}
cd ${WRKSRC}/bbftpd && ${GMAKE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bbftpc/bbftp ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/bbftpd/bbftpd ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/bbftp.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/doc/bbftpd.1 ${PREFIX}/man/man1
.include <bsd.port.mk>

3
ftp/bbftp/distinfo Normal file
View File

@ -0,0 +1,3 @@
MD5 (bbftp-3.0.2.tar.gz) = 8acd5509b1769fa71f03d1d4e71f198c
SHA256 (bbftp-3.0.2.tar.gz) = 539ef20f90778783890f81cf6b4cd434bb6c47c392ec824caf92f6ca1005cc72
SIZE (bbftp-3.0.2.tar.gz) = 344495

145
ftp/bbftp/files/bbftp.patch Normal file
View File

@ -0,0 +1,145 @@
diff -ru bbftpc/bbftp_socket.c bbftp/bbftpc/bbftp_socket.c
--- bbftpc/bbftp_socket.c Wed May 7 14:59:17 2003
+++ bbftpc/bbftp_socket.c Tue Jun 6 23:53:25 2006
@@ -28,10 +28,10 @@
#include <errno.h>
#include <fcntl.h>
#include <netinet/in.h>
+#include <sys/types.h>
#include <netinet/tcp.h>
#include <syslog.h>
#include <sys/socket.h>
-#include <sys/types.h>
#include <unistd.h>
#include <utime.h>
diff -ru bbftpc/bbftp_utils.c bbftp/bbftpc/bbftp_utils.c
--- bbftpc/bbftp_utils.c Mon Jun 30 14:41:40 2003
+++ bbftpc/bbftp_utils.c Tue Jun 6 23:55:14 2006
@@ -44,6 +44,7 @@
#ifdef HAVE_BYTESWAP_H
#include <byteswap.h>
#endif
+#include <sys/time.h>
extern int incontrolsock ;
extern int outcontrolsock ;
diff -ru bbftpc/setsignals.c bbftp/bbftpc/setsignals.c
--- bbftpc/setsignals.c Wed Apr 17 10:44:24 2002
+++ bbftpc/setsignals.c Tue Jun 6 23:55:59 2006
@@ -129,9 +129,6 @@
if ( sigaction(SIGTSTP,&sga,0) < 0 ) {
printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGTSTP : %s \n",strerror(errno)) ;
}
- if ( sigaction(SIGPOLL,&sga,0) < 0 ) {
- printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGPOLL : %s \n",strerror(errno)) ;
- }
if ( sigaction(SIGPROF,&sga,0) < 0 ) {
printmessage(stderr,CASE_FATAL_ERROR,32,timestamp,"Error setting signal SIGPROF : %s \n",strerror(errno)) ;
}
diff -ru bbftpd/bbftpd.c bbftp/bbftpd/bbftpd.c
--- bbftpd/bbftpd.c Thu Jul 24 15:27:55 2003
+++ bbftpd/bbftpd.c Tue Jun 6 23:56:46 2006
@@ -61,6 +61,7 @@
#include <limits.h>
#include <netdb.h>
#include <netinet/in.h>
+#include <sys/types.h>
#include <netinet/tcp.h>
#include <pwd.h>
#include <signal.h>
diff -ru bbftpd/bbftpd_daemon.c bbftp/bbftpd/bbftpd_daemon.c
--- bbftpd/bbftpd_daemon.c Wed Jun 11 17:17:51 2003
+++ bbftpd/bbftpd_daemon.c Tue Jun 6 23:57:11 2006
@@ -43,6 +43,7 @@
*****************************************************************************/
#include <netdb.h>
#include <netinet/in.h>
+#include <sys/types.h>
#include <netinet/tcp.h>
#include <stdio.h>
#include <syslog.h>
diff -ru bbftpd/bbftpd_login.c bbftp/bbftpd/bbftpd_login.c
--- bbftpd/bbftpd_login.c Mon Feb 24 10:26:59 2003
+++ bbftpd/bbftpd_login.c Tue Jun 6 23:59:34 2006
@@ -47,7 +47,6 @@
*****************************************************************************/
-#include <crypt.h>
#include <errno.h>
#include <netinet/in.h>
#include <pwd.h>
@@ -287,6 +286,7 @@
PAM_BAIL;
retcode = pam_acct_mgmt(pamh, 0);
PAM_BAIL;
+#define PAM_ESTABLISH_CRED 1
#ifdef PAM_ESTABLISH_CRED
retcode = pam_setcred(pamh, PAM_ESTABLISH_CRED);
#else
diff -ru bbftpd/bbftpd_signals.c bbftp/bbftpd/bbftpd_signals.c
--- bbftpd/bbftpd_signals.c Tue Mar 11 13:34:36 2003
+++ bbftpd/bbftpd_signals.c Wed Jun 7 00:00:47 2006
@@ -268,7 +268,7 @@
*/
if ( unlinkfile == 1 ) unlink(realfilename) ;
clean_child() ;
- exit() ;
+ exit(0) ;
} else {
exit(EINTR) ;
}
@@ -358,10 +358,6 @@
}
if ( sigaction(SIGTSTP,&sga,0) < 0 ) {
syslog(BBFTPD_ERR,"Error sigaction SIGTSTP : %s",strerror(errno)) ;
- return(-1) ;
- }
- if ( sigaction(SIGPOLL,&sga,0) < 0 ) {
- syslog(BBFTPD_ERR,"Error sigaction SIGPOLL : %s",strerror(errno)) ;
return(-1) ;
}
if ( sigaction(SIGPROF,&sga,0) < 0 ) {
diff -ru bbftpd/bbftpd_socket.c bbftp/bbftpd/bbftpd_socket.c
--- bbftpd/bbftpd_socket.c Wed Mar 5 12:23:37 2003
+++ bbftpd/bbftpd_socket.c Wed Jun 7 00:01:04 2006
@@ -30,10 +30,10 @@
#include <errno.h>
#include <fcntl.h>
#include <netinet/in.h>
+#include <sys/types.h>
#include <netinet/tcp.h>
#include <syslog.h>
#include <sys/socket.h>
-#include <sys/types.h>
#include <unistd.h>
#include <utime.h>
diff -ru bbftpd/createreceivesock.c bbftp/bbftpd/createreceivesock.c
--- bbftpd/createreceivesock.c Wed Apr 17 10:45:10 2002
+++ bbftpd/createreceivesock.c Wed Jun 7 00:01:20 2006
@@ -52,10 +52,10 @@
#include <errno.h>
#include <fcntl.h>
#include <netinet/in.h>
+#include <sys/types.h>
#include <netinet/tcp.h>
#include <syslog.h>
#include <sys/socket.h>
-#include <sys/types.h>
#include <unistd.h>
#include <common.h>
diff -ru bbftpd/signals_routines.c bbftp/bbftpd/signals_routines.c
--- bbftpd/signals_routines.c Wed Apr 17 10:45:10 2002
+++ bbftpd/signals_routines.c Wed Jun 7 00:01:40 2006
@@ -192,7 +192,7 @@
*/
if ( unlinkfile == 1 ) unlink(currentfilename) ;
clean_child() ;
- exit() ;
+ exit(0) ;
} else {
exit(EINTR) ;
}

27
ftp/bbftp/files/bbftpd.in Normal file
View File

@ -0,0 +1,27 @@
#!/bin/sh
# PROVIDE: bbftpd
# REQUIRE: LOGIN
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
#
# bbftp_enable (bool): Set to NO by default.
# Set it to YES to enable bbftpd.
#
. %%RC_SUBR%%
name="bbftpd"
rcvar=${name}_enable
command=%%PREFIX%%/bin/${name}
pidfile=/var/run/${name}.pid
load_rc_config $name
: ${bbftp_enable="NO"}
command_args="-b"
run_rc_command "$1"

23
ftp/bbftp/pkg-descr Normal file
View File

@ -0,0 +1,23 @@
bbFTP is a file transfer software. It implements its own transfer protocol,
which is optimized for large files (larger than 2GB) and secure as it does not
read the password in a file and encrypts the connection information. bbFTP
main features are:
* Encoded username and password at connection
* SSH and Certificate authentication modules
* Multi-stream transfer
* Big windows as defined in RFC1323
* On-the-fly data compression
* Automatic retry
* Customizable time-outs
* Transfer simulation
* AFS authentication integration
* RFIO interface
bbFTP is open-source software, released under the GNU General Public License.
It was written by Gilles Farrache at IN2P3 Computing Center in Lyon, France.
WWW: http://doc.in2p3.fr/bbftp/index.html
- Petr
hopet@ics.muni.cz

2
ftp/bbftp/pkg-plist Normal file
View File

@ -0,0 +1,2 @@
bin/bbftp
bin/bbftpd