Update to 1.2.8

PR:		12443
Submitted by:	maintainer
This commit is contained in:
Chris Piazza 1999-06-29 17:09:23 +00:00
parent 595fce410f
commit 0a92f1cd60
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=19899
6 changed files with 42 additions and 20 deletions

View File

@ -1,12 +1,12 @@
# New ports collection makefile for: wmcp
# Version required: 1.2.6
# Version required: 1.2.8
# Date created: 10 February 1999
# Whom: Jim Mock <jim@phrantic.phear.net>
#
# $Id: Makefile,v 1.1.1.1 1999/03/30 18:46:36 taoka Exp $
# $Id: Makefile,v 1.2 1999/05/09 16:56:14 steve Exp $
#
DISTNAME= wmcp-1.2.6
DISTNAME= wmcp-1.2.8
CATEGORIES= misc windowmaker
MASTER_SITES= http://users.linuxbox.com/~bac/src/wmcp/
@ -17,15 +17,13 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_GMAKE= yes
USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
pre-build:
(cd ${WRKSRC} && ${GMAKE} clean)
do-build:
(cd ${WRKSRC} && make)
(cd ${WRKSRC} && ${GMAKE})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmcp ${PREFIX}/bin
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (wmcp-1.2.6.tar.gz) = 384736be9178d92e02c87c55bd290150
MD5 (wmcp-1.2.8.tar.gz) = 6f347dd6fb0b017de868081088cdcf13

View File

@ -1,5 +1,5 @@
--- Makefile.orig Tue Feb 9 23:16:16 1999
+++ Makefile Tue Feb 9 23:16:34 1999
--- Makefile.orig Thu May 27 00:17:20 1999
+++ Makefile Tue Jun 29 10:07:22 1999
@@ -1,6 +1,6 @@
@ -8,3 +8,16 @@
LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
LIBS = -lm -lX11 -lXpm -lXext
@@ -31,10 +31,10 @@
###################################################################
${OBJECTS}: ${SOURCE}
- gcc -g -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
+ ${CC} ${CFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
${TARGET}: ${OBJECTS}
- gcc -g -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
+ ${CC} ${CFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
clean::
for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done

View File

@ -1,12 +1,12 @@
# New ports collection makefile for: wmcp
# Version required: 1.2.6
# Version required: 1.2.8
# Date created: 10 February 1999
# Whom: Jim Mock <jim@phrantic.phear.net>
#
# $Id: Makefile,v 1.1.1.1 1999/03/30 18:46:36 taoka Exp $
# $Id: Makefile,v 1.2 1999/05/09 16:56:14 steve Exp $
#
DISTNAME= wmcp-1.2.6
DISTNAME= wmcp-1.2.8
CATEGORIES= misc windowmaker
MASTER_SITES= http://users.linuxbox.com/~bac/src/wmcp/
@ -17,15 +17,13 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_GMAKE= yes
USE_X_PREFIX= yes
.include <bsd.port.pre.mk>
pre-build:
(cd ${WRKSRC} && ${GMAKE} clean)
do-build:
(cd ${WRKSRC} && make)
(cd ${WRKSRC} && ${GMAKE})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmcp ${PREFIX}/bin
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (wmcp-1.2.6.tar.gz) = 384736be9178d92e02c87c55bd290150
MD5 (wmcp-1.2.8.tar.gz) = 6f347dd6fb0b017de868081088cdcf13

View File

@ -1,5 +1,5 @@
--- Makefile.orig Tue Feb 9 23:16:16 1999
+++ Makefile Tue Feb 9 23:16:34 1999
--- Makefile.orig Thu May 27 00:17:20 1999
+++ Makefile Tue Jun 29 10:07:22 1999
@@ -1,6 +1,6 @@
@ -8,3 +8,16 @@
LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
LIBS = -lm -lX11 -lXpm -lXext
@@ -31,10 +31,10 @@
###################################################################
${OBJECTS}: ${SOURCE}
- gcc -g -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
+ ${CC} ${CFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
${TARGET}: ${OBJECTS}
- gcc -g -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
+ ${CC} ${CFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
clean::
for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done