Update to 1.66.0

This commit is contained in:
Baptiste Daroussin 2020-09-28 11:29:18 +00:00
parent 345d090124
commit 0a429216f8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=550422
5 changed files with 45 additions and 14 deletions

View File

@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= gjs
PORTVERSION= 1.52.4
PORTREVISION= 4
PORTVERSION= 1.66.0
CATEGORIES= lang gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME Javascript binding
@ -16,17 +15,21 @@ LICENSE_COMB= multi
LICENSE_FILE_MPL11= ${WRKSRC}/COPYING
LICENSE_FILE_LGPL20+ = ${WRKSRC}/COPYING.LGPL
LIB_DEPENDS= libmozjs-52.so:lang/spidermonkey52 \
LIB_DEPENDS= libmozjs-78.so:lang/spidermonkey78 \
libffi.so:devel/libffi
USES= compiler:c++11-lib gettext gmake gnome libtool \
localbase pathfix pkgconfig python:build readline tar:xz xorg
USES= compiler:c++11-lib gettext gnome \
localbase meson pkgconfig python:build readline tar:xz xorg
USE_GNOME= cairo gdkpixbuf2 gtk30 introspection
USE_XORG= x11 xext
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
CONFIGURE_ARGS+=--disable-profiler
MESON_ARGS= -Dcairo=enabled \
-Dreadline=enabled \
-Dprofiler=disabled \
-Dinstalled_tests=false
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CONFIGURE_ENV= PYTHONDONTWRITEBYTECODE=1
MAKE_ENV= PYTHONDONTWRITEBYTECODE=1
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1539116944
SHA256 (gnome3/gjs-1.52.4.tar.xz) = 9c160cf9383ca20fcba3b75154c9d19efae9decf63bec6164a81403092d3b4f7
SIZE (gnome3/gjs-1.52.4.tar.xz) = 626960
TIMESTAMP = 1601286593
SHA256 (gnome/gjs-1.66.0.tar.xz) = f30cf90e016db6c8fdd0059749559611760f0721f375b2b61e0b7239b43ab5f8
SIZE (gnome/gjs-1.66.0.tar.xz) = 439596

View File

@ -0,0 +1,16 @@
--- gjs/jsapi-class.h.orig 2020-09-12 19:34:36 UTC
+++ gjs/jsapi-class.h
@@ -77,11 +77,11 @@ bool gjs_define_property_dynamic(JSContext *cx,
* do_base_typecheck and priv_from_js
*/
#define GJS_DEFINE_PRIV_FROM_JS(type, klass) \
- GJS_ALWAYS_INLINE [[nodiscard]] [[maybe_unused]] static inline bool \
+ GJS_ALWAYS_INLINE static inline bool \
do_base_typecheck(JSContext* cx, JS::HandleObject obj, bool throw_error) { \
return gjs_typecheck_instance(cx, obj, &klass, throw_error); \
} \
- GJS_ALWAYS_INLINE [[nodiscard]] static inline type* priv_from_js( \
+ GJS_ALWAYS_INLINE static inline type* priv_from_js( \
JSContext* cx, JS::HandleObject obj) { \
return static_cast<type*>( \
JS_GetInstancePrivate(cx, obj, &klass, nullptr)); \

View File

@ -0,0 +1,11 @@
--- gjs/jsapi-util-args.h.orig 2020-09-12 19:34:36 UTC
+++ gjs/jsapi-util-args.h
@@ -43,7 +43,7 @@
#include "gjs/jsapi-util.h"
#include "gjs/macros.h"
-GJS_ALWAYS_INLINE [[nodiscard]] static inline bool check_nullable(
+GJS_ALWAYS_INLINE static inline bool check_nullable(
const char*& fchar, const char*& fmt_string) {
if (*fchar != '?')
return false;

View File

@ -2,10 +2,11 @@ bin/gjs
bin/gjs-console
include/gjs-1.0/gjs/context.h
include/gjs-1.0/gjs/coverage.h
include/gjs-1.0/gjs/error-types.h
include/gjs-1.0/gjs/gjs.h
include/gjs-1.0/gjs/macros.h
include/gjs-1.0/gjs/mem.h
include/gjs-1.0/gjs/profiler.h
include/gjs-1.0/util/error.h
lib/gjs/girepository-1.0/GjsPrivate-1.0.typelib
lib/libgjs.so
lib/libgjs.so.0